Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1415497 - virt-who doesn't work with rhev4 out of box [NEEDINFO]
Summary: virt-who doesn't work with rhev4 out of box
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Patrick Creech
QA Contact: Eko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-22 16:56 UTC by Rich Jerrido
Modified: 2017-11-03 17:47 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:24:47 UTC
bkearney: needinfo? (csnyder)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3055811 None None None 2017-05-25 20:15:27 UTC
Red Hat Product Errata RHBA-2017:2084 normal SHIPPED_LIVE virt-who bug fix and enhancement update 2017-08-01 18:14:28 UTC
Red Hat Bugzilla 961677 None CLOSED [RFE] ovirt-engine URI rework 2019-03-28 21:38:37 UTC
Red Hat Bugzilla 1509411 None CLOSED virt-who el6sat bump 2019-03-28 21:38:37 UTC
Github virt-who virt-who pull 48 None None None 2017-02-07 14:21:30 UTC

Internal Links: 961677 1509411

Description Rich Jerrido 2017-01-22 16:56:18 UTC
Description of problem:

In RHEV4, the API endpoint has moved from:

$HOSTNAME/api 

to 

$HOSTNAME/ovirt-engine/api/

Version-Release number of selected component (if applicable):
virt-who-0.17-11.el7_3.noarch


How reproducible:
100%

Steps to Reproduce:
1. install virt-who. 
2. Configure it as per the docs (either https://access.redhat.com/documentation/en/red-hat-satellite/6.2/single/virtual-instances-guide#configuring_virt_who_to_connect_to_red_hat_enterprise_virtualization_hypervisor or via the instructions in the virt-who manual. 
3. run virt-who 

Actual results:

Virt-who fails to gather host/guest mappings and fails with an error similar to the following. 

2017-01-22 11:48:37,083 [virtwho.rhev-farm ERROR] RhevM-2(11346):MainThread @virt.py:run:375 - Virt backend 'rhev-farm' fails with error: Unable to connect to RHEV-M server: 404 Client Error: Not Found



Expected results:

Successful virt-who report. 

Additional info:


Configuring virt-who with /ovirt-engine/ appended to the server= directive allows a successful report as shown below:


$ cat /etc/virt-who.d/rhev.conf
[rhev-farm]
# type = esx,rhevm,kvm
type=rhevm

# server = vcenter OR individual ESXi host
# Works with RHV4
server=https://rhevm.example.com:443/ovirt-engine/

# Does NOT work with RHV4
# server=https://rhevm.example.com:443/


This _could_ be treated as a docs BZ, but ideally, I'd like virt-who to try both API endpoints and use whichever works (as there will be users upgrading from RHEV3 to RHV4, and I'd like virt-who to 'just work' post upgrade).

Comment 4 Chris Snyder 2017-02-07 15:27:57 UTC
For reference here is the bug for the change in ovirt (RHEV): https://bugzilla.redhat.com/show_bug.cgi?id=961677

Comment 10 errata-xmlrpc 2017-08-01 19:24:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2084


Note You need to log in before you can comment on or make changes to this bug.