Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1414092 - shrink-mon support
Summary: shrink-mon support
Keywords:
Status: CLOSED DUPLICATE of bug 1366807
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 3.0
Assignee: Alfredo Deza
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 17:57 UTC by Alfredo Deza
Modified: 2017-06-29 14:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-29 14:01:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible issues 1234 None None None 2017-01-20 04:34:18 UTC

Description Alfredo Deza 2017-01-17 17:57:43 UTC
Description of problem: There is some support for removing a single Monitor or OSD node, but the current approach requires the node from where the playbook runs to be configured like the cluster (same ceph.conf, admin keys, etc...)

This needs to be re-worked to allow normal ansible remote execution without requiring Ceph to be installed.

A test scenario for validating the changes should be in place as well.

Comment 3 Drew Harris 2017-06-29 14:01:26 UTC

*** This bug has been marked as a duplicate of bug 1366807 ***


Note You need to log in before you can comment on or make changes to this bug.