Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1410601 - [RFE] virt-who need to make sure there is only one entry in satellite content host for the same hypervisor when configure hypervisor_id for uuid or hostname or hwuuid
Summary: [RFE] virt-who need to make sure there is only one entry in satellite content...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 2.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: 2.6
Assignee: William Poteat
QA Contact: Katello QA List
URL:
Whiteboard:
: 1380510 1412719 1520807 (view as bug list)
Depends On:
Blocks: 1408782 1410600 1362724 1412719
TreeView+ depends on / blocked
 
Reported: 2017-01-05 21:00 UTC by Barnaby Court
Modified: 2019-04-12 13:59 UTC (History)
16 users (show)

Fixed In Version: candlepin-2.6.4-1
Doc Type: Enhancement
Doc Text:
Clone Of: 1408782
: 1694752 (view as bug list)
Environment:
Last Closed: 2019-04-10 19:58:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1314902 None CLOSED 2 virt-who reporting on the same hypervisor using local libvirt and remote libvirt methods creates duplicate systems 2019-04-15 00:15:15 UTC
Red Hat Bugzilla 1566000 None VERIFIED KVM hypervisor profile does not contain guests running on it in the webui and creates duplicate profile with virt-who-* ... 2019-04-15 00:15:15 UTC
Github candlepin candlepin pull 2284 None None None 2019-03-28 19:46:38 UTC
Foreman Issue Tracker 26600 None None None 2019-04-12 13:59:27 UTC
Red Hat Bugzilla 1576110 None CLOSED Org admins not able to view system 2019-04-15 00:15:15 UTC

Internal Links: 1314902 1566000 1576110

Comment 1 Kevin Howell 2017-07-27 15:07:04 UTC
For candlepin, overall changes necessary are:
 1) Accept all 3 (hw_uuid, uuid, hostname) [TBD: as facts or as their own thing]
 2) When receiving a hypervisor checkin, lookup existing hypervisors by the tuple (hw_uuid, uuid, hostname) & delete/migrate as necessary.

Some design decisions to be made before implementation.

Comment 2 Kevin Howell 2017-07-31 17:42:14 UTC
*** Bug 1380510 has been marked as a duplicate of this bug. ***

Comment 3 Kevin Howell 2017-07-31 17:44:34 UTC
*** Bug 1412719 has been marked as a duplicate of this bug. ***

Comment 5 Kevin Howell 2017-12-07 15:10:49 UTC
*** Bug 1520807 has been marked as a duplicate of this bug. ***

Comment 7 johnhomes 2019-02-07 10:10:27 UTC
lookup existing hypervisors by the tuple (hw_uuid, uuid, hostname) & delete/migrate as necessary.
Thanks
https://driverrestore.com/

Comment 8 William Poteat 2019-03-27 16:14:18 UTC
This was errantly resolved as part of a change for libvirt and rhevm. Will create a separate fix for esx.

Comment 9 William Poteat 2019-03-28 19:45:58 UTC
An additional exception existed in the matching of a hypervisor when its hypervisor id changed.

Comment 10 William Poteat 2019-03-28 19:47:33 UTC
Will also require a virt-who update. Will be included in RHEL 7.7 and RHEL 8.1.

Comment 11 Jonathon Turel 2019-04-12 13:59:27 UTC
Created redmine issue https://projects.theforeman.org/issues/26600 from this bug


Note You need to log in before you can comment on or make changes to this bug.