Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 141050 - Permission of logical volumes do not allow backup.
Summary: Permission of logical volumes do not allow backup.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: device-mapper-obsolete
Version: 3
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
: 142123 153002 161555 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-28 19:50 UTC by Michael J. Pawlowsky
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version: RHEA-2005-188
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-01-05 22:01:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:192 low SHIPPED_LIVE lvm2 bug fix and enhancement update 2005-06-09 04:00:00 UTC
Red Hat Product Errata RHEA-2005:188 low SHIPPED_LIVE device-mapper enhancement update 2005-06-08 04:00:00 UTC

Description Michael J. Pawlowsky 2004-11-28 19:50:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Logical volumes are create as root.root with 600 permissions.
It would be nice if they had similar permissions as regular disks.

Owner: root
Group: disk
Permissions: 660

That way out of the box amanda would not complain that it does not
have permissions to backup / for instance.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ls /dev/mapper
2.
3.
    

Actual Results:  brw-------   1 root root 253,  0 Nov 28 08:25 vg00-lvroot


Expected Results:  brw-rw----   1 root disk 253,  0 Nov 28 08:25
vg00-lvroot


Additional info:

Comment 1 Alasdair Kergon 2004-11-30 00:51:17 UTC
umask can be set in the lvm2 config file.

Will think about the best way to incorporate this (distribution-independent)
maybe as a libdevmapper extension configured from the lvm2 config file.

Comment 2 Alasdair Kergon 2005-01-05 20:18:01 UTC
*** Bug 142123 has been marked as a duplicate of this bug. ***

Comment 3 Alasdair Kergon 2005-01-05 20:27:44 UTC
The code currently does:

mknod(path, S_IFBLK | S_IRUSR | S_IWUSR | S_IRGRP, dev)


Comment 4 Alasdair Kergon 2005-01-05 20:29:50 UTC
libdevmapper needs to take uid, gid + custom umask.

Comment 5 Michael J. Pawlowsky 2005-01-05 21:31:47 UTC
Well the other problem is that if you try and add mapper/* for
instance  in a udev permissions file, all other files in /dev/mapper
will change permissions, owner and group but not the lv devices.

Comment 6 Alasdair Kergon 2005-01-05 21:35:11 UTC
For now, I'm making the uid,gid, mode compile-time options, so that
each distribution can choose appropriate settings.  libdevmapper
interface can then be extended to make the settings per-LV if there's
sufficient demand.

Comment 7 Alasdair Kergon 2005-01-05 22:01:47 UTC
Fixed in device-mapper CVS; will be included in next release.

Comment 8 Alasdair Kergon 2005-01-06 20:40:32 UTC
Included in 1.00.20

Comment 9 Alasdair Kergon 2005-03-31 21:38:34 UTC
*** Bug 153002 has been marked as a duplicate of this bug. ***

Comment 10 Bastien Nocera 2005-06-28 09:12:23 UTC
*** Bug 161555 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.