Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 140897 - RFE: Add foomatic entries for www.linuxprinting.org PPDs
Summary: RFE: Add foomatic entries for www.linuxprinting.org PPDs
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: foomatic
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 150491 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2004-11-26 07:34 UTC by Walter Mueller
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-19 17:28:10 UTC


Attachments (Terms of Use)

Description Walter Mueller 2004-11-26 07:34:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
No match for USB device:
  mfr "Kyocera"
  model "FS-1020D"
  desc "Kyocera Mita FS-1020D"
  cmdset "PCLXL,PostScript Emulation,PCL5E,PJL"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.

Version-Release number of selected component (if applicable):
foomatic-3.0.2-3

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 3
2. Connect Kyocera Mita FS-1020 via USB to the computer
3. Printer is recognized in the boot process but no driver available
4. Start system-config-printer as root
    

Actual Results:  The Kyocera Mita FS-1020D connected via USB is
recognized but the system does not find a matching entry in the
foomatic database

Expected Results:  Find an entry for this printer in the foomatic database

Additional info:

The ppd files are available on 
http://www.linuxprinting.org/download/PPD/Kyocera/current/English/Kyocera_Mita_FS-1020_English.ppd
Other languages are also available

Comment 1 Tim Waugh 2004-11-26 10:23:20 UTC
Hmm, I wonder why there isn't a corresponding foomatic database entry.  There
was a plan at one stage for foomatic to switch over to being PPD-based instead
of XML-based; maybe it's because of that.

I'll ask the maintainer.

Comment 2 Tim Waugh 2005-03-07 18:08:18 UTC
*** Bug 150491 has been marked as a duplicate of this bug. ***

Comment 4 Tim Waugh 2005-09-08 12:58:17 UTC
0.6.142-1 implements the new PPD load procedure, taking a copy of the original PPD.

Comment 5 Tim Waugh 2006-01-19 17:28:10 UTC
Closing.


Note You need to log in before you can comment on or make changes to this bug.