Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1406778 - Addition of HE host had been hidden and its not possible to add hosted-engine-hosts (deploy) any more.
Summary: Addition of HE host had been hidden and its not possible to add hosted-engine...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
urgent vote
Target Milestone: ovirt-4.1.0-rc
: ---
Assignee: Phillip Bailey
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1361511
TreeView+ depends on / blocked
 
Reported: 2016-12-21 12:57 UTC by Nikolai Sednev
Modified: 2017-05-11 10:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-26 10:30:58 UTC
oVirt Team: SLA
rule-engine: ovirt-4.1?
nsednev: planning_ack?
msivak: devel_ack+
nsednev: testing_ack?


Attachments (Terms of Use)
Screenshot from 2016-12-21 14-57-05.png (deleted)
2016-12-21 12:58 UTC, Nikolai Sednev
no flags Details

Description Nikolai Sednev 2016-12-21 12:57:32 UTC
Description of problem:
Addition of HE host had been hidden and its not possible to add hosted-engine-hosts (deploy) any more.

Once it was possible to add new host via WEBUI and then there was a tab named Hosted-Engine, but now its gone.

Version-Release number of selected component (if applicable):
Host:
vdsm-4.18.999-1218.gitd36143e.el7.centos.x86_64
ovirt-host-deploy-1.6.0-0.0.master.20161107121647.gitfd7ddcd.el7.centos.noarch
libvirt-client-2.0.0-10.el7_3.2.x86_64
ovirt-vmconsole-1.0.4-1.el7ev.noarch
rhev-release-4.0.6-8-001.noarch
qemu-kvm-rhev-2.6.0-28.el7_3.2.x86_64
ovirt-hosted-engine-ha-2.1.0-0.0.master.20161130135331.20161130135328.git3541725.el7.centos.noarch
ovirt-engine-appliance-4.1-20161202.1.el7.centos.noarch
sanlock-3.4.0-1.el7.x86_64
ovirt-setup-lib-1.1.0-0.0.master.20161107100014.gitb73abeb.el7.centos.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7ev.noarch
ovirt-imageio-common-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
mom-0.5.8-1.el7ev.noarch
ovirt-hosted-engine-setup-2.1.0-0.0.master.20161130101611.gitb3ad261.el7.centos.noarch
ovirt-release41-pre-4.1.0-0.6.beta2.20161221025826.gitc487776.el7.centos.noarch
ovirt-imageio-daemon-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
Linux version 3.10.0-514.2.2.el7.x86_64 (mockbuild@x86-019.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Wed Nov 16 13:15:13 EST 2016
Linux 3.10.0-514.2.2.el7.x86_64 #1 SMP Wed Nov 16 13:15:13 EST 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.3 (Maipo)

Engine:
ovirt-engine-userportal-debuginfo-4.2.0-0.0.master.20161219225535.git893d571.el7.centos.noarch
ovirt-engine-tools-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
python-ovirt-engine-sdk4-4.1.0-0.1.a0.20161215git77fce51.el7.centos.x86_64
ovirt-engine-setup-plugin-vmconsole-proxy-helper-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-hosts-ansible-inventory-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-backend-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-dashboard-1.1.0-0.4.20161128git5ed6f96.el7.centos.noarch
ovirt-engine-setup-base-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-extension-aaa-jdbc-1.1.3-0.0.master.20161118164738.gitd0ff686.el7.noarch
ovirt-engine-setup-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-websocket-proxy-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-tools-backup-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-dbscripts-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-sdk-python-3.6.9.2-0.1.20161204.gite99bbd1.el7.centos.noarch
ovirt-engine-dwh-4.1.0-0.0.master.20161129154019.el7.centos.noarch
ovirt-engine-webadmin-portal-debuginfo-4.2.0-0.0.master.20161219225535.git893d571.el7.centos.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-setup-plugin-websocket-proxy-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-extensions-api-impl-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-webadmin-portal-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-userportal-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-dwh-setup-4.1.0-0.0.master.20161129154019.el7.centos.noarch
ovirt-engine-setup-plugin-ovirt-engine-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-vmconsole-proxy-helper-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-wildfly-10.1.0-1.el7.x86_64
ovirt-engine-wildfly-overlay-10.0.0-1.el7.noarch
ovirt-engine-cli-3.6.9.2-1.el7.centos.noarch
ovirt-engine-lib-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
ovirt-engine-restapi-4.2.0-0.0.master.20161220201840.git36084db.el7.centos.noarch
Linux version 3.10.0-327.36.3.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Mon Oct 24 16:09:20 UTC 2016
Linux 3.10.0-327.36.3.el7.x86_64 #1 SMP Mon Oct 24 16:09:20 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
CentOS Linux release 7.3.1611 (Core) 


How reproducible:
100%

Steps to Reproduce:
1.Deploy HE over NFS on one host and then add data storage domain.
2.Try adding additional hosted engine host.
3.

Actual results:
Impossible to add additional hosted-engine-host.

Expected results:
Should be  https://bugzilla.redhat.com/show_bug.cgi?id=1406001possible to add additional hosted-engine-host via WEBUI.

Additional info:
Screenshot from 2016-12-21 14-57-05.png

Comment 1 Nikolai Sednev 2016-12-21 12:58:15 UTC
Created attachment 1234389 [details]
Screenshot from 2016-12-21 14-57-05.png

Comment 2 Phillip Bailey 2016-12-21 14:34:24 UTC
The Hosted Engine side tab will not be visible in the New/Edit Host popups if the hosted engine VM isn't running on an existing host. You can determine if the host is properly recognizing that it is running the hosted engine VM by checking for a gold crown beside the host in the webadmin UI. 

If the host on which the hosted engine VM is running doesn't have a gold crown, then it isn't being properly recognized as the hosted engine host and the Hosted Engine side tab will not be available.

Comment 3 Nikolai Sednev 2016-12-26 10:30:58 UTC
Initially this issue appeared because of the HE-VM was not active in engine WEBADMIN, although was reported as successfully auto-imported.
So because there is no active HE-VM within the WEBADMIN, then Hosted Engine side tab being hidden, that is by design.
Works fine now on these components on hosts:
ovirt-engine-appliance-4.1-20161222.1.el7.centos.noarch
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
mom-0.5.8-1.el7ev.noarch
ovirt-hosted-engine-setup-2.1.0-0.0.master.20161221071755.git46cacd3.el7.centos.noarch
ovirt-setup-lib-1.1.0-1.el7.centos.noarch
libvirt-client-2.0.0-10.el7_3.2.x86_64
ovirt-release41-pre-4.1.0-0.6.beta2.20161221025826.gitc487776.el7.centos.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
qemu-kvm-rhev-2.6.0-28.el7_3.2.x86_64
ovirt-hosted-engine-ha-2.1.0-0.0.master.20161221070856.20161221070854.git387fa53.el7.centos.noarch
ovirt-engine-appliance-4.1-20161222.1.el7.centos.noarch
sanlock-3.4.0-1.el7.x86_64
ovirt-host-deploy-1.6.0-0.0.master.20161215101008.gitb76ad50.el7.centos.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7ev.noarch
ovirt-imageio-common-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
vdsm-4.18.999-1218.gitd36143e.el7.centos.x86_64
ovirt-imageio-daemon-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
Linux version 3.10.0-514.2.2.el7.x86_64 (mockbuild@x86-019.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Wed Nov 16 13:15:13 EST 2016
Linux 3.10.0-514.2.2.el7.x86_64 #1 SMP Wed Nov 16 13:15:13 EST 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.3 (Maipo)
You have new mail in /var/spool/mail/root

On engine:
ovirt-engine-setup-plugin-ovirt-engine-common-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-imageio-proxy-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
ovirt-iso-uploader-4.1.0-0.0.master.20160909154152.git14502bd.el7.centos.noarch
ovirt-engine-userportal-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-dbscripts-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-setup-plugin-vmconsole-proxy-helper-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-extensions-api-impl-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-imageio-common-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
ovirt-host-deploy-1.6.0-0.0.master.20161215101008.gitb76ad50.el7.centos.noarch
python-ovirt-engine-sdk4-4.1.0-0.1.a0.20161215git77fce51.el7.centos.x86_64
ovirt-host-deploy-java-1.6.0-0.0.master.20161215101008.gitb76ad50.el7.centos.noarch
ovirt-release41-pre-4.1.0-0.6.beta2.20161221025826.gitc487776.el7.centos.noarch
ovirt-setup-lib-1.1.0-1.el7.centos.noarch
ovirt-engine-extension-aaa-jdbc-1.1.2-1.el7.noarch
ovirt-engine-dwh-setup-4.1.0-0.0.master.20161129154019.el7.centos.noarch
ovirt-imageio-proxy-setup-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
ovirt-engine-tools-backup-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-websocket-proxy-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-setup-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-backend-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-tools-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-webadmin-portal-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-restapi-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-vmconsole-proxy-helper-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-setup-plugin-ovirt-engine-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-wildfly-overlay-10.0.0-1.el7.noarch
ovirt-engine-cli-3.6.9.2-1.el7.centos.noarch
ovirt-web-ui-0.1.1-2.el7.centos.x86_64
ovirt-engine-setup-base-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-vmconsole-1.0.4-1.el7.centos.noarch
ovirt-engine-dwh-4.1.0-0.0.master.20161129154019.el7.centos.noarch
ovirt-engine-setup-plugin-websocket-proxy-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-hosts-ansible-inventory-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-dashboard-1.1.0-0.4.20161128git5ed6f96.el7.centos.noarch
ovirt-engine-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-guest-agent-common-1.0.13-1.20161220085008.git165fff1.el7.centos.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7.centos.noarch
ovirt-engine-wildfly-10.1.0-1.el7.x86_64
ovirt-engine-lib-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-vmconsole-proxy-1.0.4-1.el7.centos.noarch
Linux version 3.10.0-514.2.2.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Tue Dec 6 23:06:41 UTC 2016
Linux 3.10.0-514.2.2.el7.x86_64 #1 SMP Tue Dec 6 23:06:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
CentOS Linux release 7.3.1611 (Core) 

Closing this bug as works for me.


Note You need to log in before you can comment on or make changes to this bug.