Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 140674 - Dual Head no longer works in fc3 -- second monitor not activated
Summary: Dual Head no longer works in fc3 -- second monitor not activated
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display
Version: 3
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
: 149878 (view as bug list)
Depends On:
Blocks: FC6Target FC6Desktop
TreeView+ depends on / blocked
Reported: 2004-11-24 05:46 UTC by P V
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-10-31 20:33:01 UTC

Attachments (Terms of Use)
/etc/X11/xorg.conf for attempted dual head (deleted)
2004-11-24 05:51 UTC, P V
no flags Details
/var/log/Xorg.0.log as requested (deleted)
2004-11-25 23:31 UTC, P V
no flags Details
/var/log/Xorg.0.log.old -- just in case it might be useful (deleted)
2004-11-25 23:32 UTC, P V
no flags Details
/etc/sysconfig/init (deleted)
2004-11-26 05:16 UTC, P V
no flags Details
Modified xorg.conf (deleted)
2004-12-06 18:24 UTC, Paul Nasrat
no flags Details
/var/log/Xorg.0.log (deleted)
2004-12-10 03:19 UTC, P V
no flags Details

Description P V 2004-11-24 05:46:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040927 Galeon/1.3.17

Description of problem:
Hi, I was running dual head on this hardware with fc2 without any
complications. After I installed fc3, the original
system-config-display would not accept "OK" once dual display was
checked on (see bug 136916)
Upgrading to system-config-display-1.0.24-1 solved that problem;
system-config-display now exits as though all is well, but restarting
X or rebooting does not activate the second monitor.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Verify that dual display is checked on
2. Reboot
3. Verify that display is only on one monitor.

Actual Results:  Mouse is limited to the boundaries of one screen
Second monitor says no signal and eventually enters powersaving mode.

Expected Results:  Second monitor should be active and cursor should
be able to traverse across to it. This worked in fc2 on this hardware.

Additional info:

Video Cards: AGP "RIVA TNT2" & PCI "ATI Radeon 7200"
Monitors: "Dell D1626HT" & Sony 420GS
$ rpm -q system-config-display
$ uname -a
Linux localhost.localdomain 2.6.9-1.678_FC3 #1 Mon Nov 15 18:28:07 EST
2004 i686 athlon i386 GNU/Linux

Comment 1 P V 2004-11-24 05:51:19 UTC
Created attachment 107383 [details]
/etc/X11/xorg.conf for attempted dual head

see attached /etc/X11/xorg.conf for attempted dual head

Comment 2 Paul Nasrat 2004-11-24 14:12:36 UTC
Do you have your fc2 xorg.conf?

Comment 3 Paul Nasrat 2004-11-24 14:15:51 UTC
Also can you attach the Xorg.0.log for booting with this config.  Can
you also disable graphical boot and test (edit /etc/sysconfig/init or
edit the boot line in grub to remove for a boot rhgb).

Comment 4 P V 2004-11-24 17:29:56 UTC
> Do you have your fc2 xorg.conf?

No, I did a fresh install. I will try the others later.

Comment 5 P V 2004-11-25 23:31:34 UTC
Created attachment 107467 [details]
/var/log/Xorg.0.log  as requested

Comment 6 P V 2004-11-25 23:32:55 UTC
Created attachment 107468 [details]
/var/log/Xorg.0.log.old  -- just in case it might be useful

Comment 7 P V 2004-11-26 05:16:04 UTC
Created attachment 107471 [details]

Changed to 

and rebooted. It seems I got the usual behavior (graphical interface, single
monitor active.) Please advise.

Comment 8 Paul Nasrat 2004-12-06 18:24:54 UTC
Created attachment 107974 [details]
Modified xorg.conf

Can you disable rhgb, and test with the attached xorg.conf.  Let me know what
the behaviour is and attach the Xorg.log from running this.

Comment 9 P V 2004-12-10 03:19:46 UTC
Created attachment 108294 [details]

Below my grub.conf, I hope i disabled rhgb properly.
Video is still the same: one monitor only. *
# grub.conf generated by anaconda
#... comments deleted ...
title Fedora Core (2.6.9-1.681_FC3)
	root (hd1,0)
#	kernel /boot/vmlinuz-2.6.9-1.681_FC3 ro root=LABEL=/1 rhgb quiet
	kernel /boot/vmlinuz-2.6.9-1.681_FC3 ro root=LABEL=/1	   quiet
	initrd /boot/initrd-2.6.9-1.681_FC3.img
title Fedora Core (2.6.9-1.678_FC3)
	root (hd1,0)
#	kernel /boot/vmlinuz-2.6.9-1.678_FC3 ro root=LABEL=/1 rhgb quiet
	kernel /boot/vmlinuz-2.6.9-1.678_FC3 ro root=LABEL=/1	   quiet
	initrd /boot/initrd-2.6.9-1.678_FC3.img
title Fedora Core (2.6.9-1.667)
	root (hd1,0)
#	kernel /boot/vmlinuz-2.6.9-1.667 ro root=LABEL=/1 rhgb quiet
	kernel /boot/vmlinuz-2.6.9-1.667 ro root=LABEL=/1      quiet
	initrd /boot/initrd-2.6.9-1.667.img
title Other
	rootnoverify (hd0,0)
	chainloader +1

Comment 10 Lane Inman 2004-12-23 01:24:23 UTC
I have same problem on x86_64

Comment 11 Jim Parsons 2005-03-01 18:19:45 UTC
*** Bug 149878 has been marked as a duplicate of this bug. ***

Comment 12 Adam Jackson 2006-03-03 15:31:24 UTC
Mass update: move dual head bugs from FC5 to FC6, no way they can get fixed
before FC5 release at this point.

Comment 13 P V 2006-03-03 18:01:44 UTC
I was able to *manually* set up my xorg.conf to do dual head on i586 and deal
and triple head on x86_64.

One smaller problem was that one of the monitor configs was wrong. 
I think it was the Sony, since it has lower limits, but it's best you check the
current code.

Below the correct numbers:
    ModelName    "DELL D1626HT"
        HorizSync    30.0 - 107.0
        VertRefresh  50.0 - 160.0
    ModelName    "Sony 420GS"
        HorizSync    30.0 - 96.0
        VertRefresh  48.0 - 120.0   # This line is correct
        VertRefresh  50.0 - 120.0   # This line helps multiple monitors play
well together.

However, system-config-display never sets up dual head correctly. 
It would tend to not permit necessary changes, like not act on the OK button,
but throw errors (sorry not included)
and now on a working handcrafted xorg.conf attempting to use
system-config-display generates errors like:

 Traceback (most recent call last):
  File "/usr/share/system-config-display/", line 390, in ?
  File "/usr/lib64/python2.4/site-packages/rhpl/", line 363, in
    device = xf86config.lookupDevice(xconfig, screen.device)
  File "/usr/lib64/python2.4/site-packages/", line 128, in lookupDevice
    raise XF86SectionMissing("No device found with the identifier" + device_id)

but there would be similar errors when xorg.conf file was deleted or moved.

Comment 14 Matthias Clasen 2006-07-06 21:54:57 UTC
Add to FC6Destop tracker

Comment 15 Matthew Miller 2006-07-10 22:44:51 UTC
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!

Comment 16 John Thacker 2006-10-31 20:33:01 UTC
Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.