Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1406001 - Package rubygem-fluent-plugin-rewrite-tag-filter cannot be found
Summary: Package rubygem-fluent-plugin-rewrite-tag-filter cannot be found
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Host-Deploy
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
urgent vote
Target Milestone: ovirt-4.1.0-beta
: ---
Assignee: Sandro Bonazzola
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1264085 1361511
TreeView+ depends on / blocked
 
Reported: 2016-12-19 13:24 UTC by Nikolai Sednev
Modified: 2017-01-02 10:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-02 07:58:17 UTC
oVirt Team: Integration
rule-engine: ovirt-4.1+
rule-engine: blocker+


Attachments (Terms of Use)
sosreport from puma18 (original host with HE VM) (deleted)
2016-12-19 13:46 UTC, Nikolai Sednev
no flags Details
sosreport from puma19 (additional HE host) (deleted)
2016-12-19 13:47 UTC, Nikolai Sednev
no flags Details
different logs from the engine (deleted)
2016-12-19 13:48 UTC, Nikolai Sednev
no flags Details

Description Nikolai Sednev 2016-12-19 13:24:21 UTC
Description of problem:
Addition of additional hosted-engine host failed and ovirtmgmt bridge was not created on additional host.
	
Dec 19, 2016 3:11:26 PM
	
	
Host puma19.scl.lab.tlv.redhat.com installation failed. Command returned failure code 1 during SSH session 'root@puma19.scl.lab.tlv.redhat.com'.
	
Dec 19, 2016 3:11:26 PM
	
	
Installing Host puma19.scl.lab.tlv.redhat.com. Stage: Termination.
	
Dec 19, 2016 3:11:26 PM
	
	
Installing Host puma19.scl.lab.tlv.redhat.com. Retrieving installation logs to: '/var/log/ovirt-engine/host-deploy/ovirt-host-deploy-20161219151126-puma19.scl.lab.tlv.redhat.com-4afcf20f.log'.
	
Dec 19, 2016 3:11:26 PM
	
	
Installing Host puma19.scl.lab.tlv.redhat.com. Stage: Pre-termination.
	
Dec 19, 2016 3:11:26 PM
	
	
Installing Host puma19.scl.lab.tlv.redhat.com. Yum Performing yum transaction rollback.
	
Dec 19, 2016 3:11:26 PM
	
	
Failed to install Host puma19.scl.lab.tlv.redhat.com. Failed to execute stage 'Package installation': Package rubygem-fluent-plugin-rewrite-tag-filter cannot be found.
	
Dec 19, 2016 3:11:26 PM
	
	
Failed to install Host puma19.scl.lab.tlv.redhat.com. Yum Cannot queue package rubygem-fluent-plugin-rewrite-tag-filter: Package rubygem-fluent-plugin-rewrite-tag-filter cannot be found.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Deploy 4.1 HE on NFS on one host from the appliance and update then the appliance to latest bits.
2.Try adding additional hosted-engine-host.
3.

Actual results:
Addition of additional HE-host failed.
Failed to install Host puma19.scl.lab.tlv.redhat.com. Yum Cannot queue package rubygem-fluent-plugin-rewrite-tag-filter: Package rubygem-fluent-plugin-rewrite-tag-filter cannot be found.

Expected results:
Additional hosted-engine host should be added without any issue.

Additional info:

Comment 1 Nikolai Sednev 2016-12-19 13:46:54 UTC
Created attachment 1233381 [details]
sosreport from puma18 (original host with HE VM)

Comment 2 Nikolai Sednev 2016-12-19 13:47:59 UTC
Created attachment 1233382 [details]
sosreport from puma19 (additional HE host)

Comment 3 Nikolai Sednev 2016-12-19 13:48:31 UTC
Created attachment 1233383 [details]
different logs from the engine

Comment 4 Red Hat Bugzilla Rules Engine 2016-12-27 16:39:48 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 5 Sandro Bonazzola 2017-01-02 07:58:17 UTC
(In reply to Nikolai Sednev from comment #0)

> Actual results:
> Addition of additional HE-host failed.
> Failed to install Host puma19.scl.lab.tlv.redhat.com. Yum Cannot queue
> package rubygem-fluent-plugin-rewrite-tag-filter: Package
> rubygem-fluent-plugin-rewrite-tag-filter cannot be found.

"rubygem-fluent-plugin-rewrite-tag-filter cannot be found" is the only relevant part of this bug.
I see it has been added to oVirt repos with bug #1401840.
and I see it within the repo: http://resources.ovirt.org/pub/ovirt-4.1-pre/rpm/el7/noarch/rubygem-fluent-plugin-rewrite-tag-filter-1.5.5-1.el7.centos.noarch.rpm

I'm going to close this as work for me, please reopen if you can reproduce.

Comment 6 Nikolai Sednev 2017-01-02 10:14:04 UTC
(In reply to Sandro Bonazzola from comment #5)
> (In reply to Nikolai Sednev from comment #0)
> 
> > Actual results:
> > Addition of additional HE-host failed.
> > Failed to install Host puma19.scl.lab.tlv.redhat.com. Yum Cannot queue
> > package rubygem-fluent-plugin-rewrite-tag-filter: Package
> > rubygem-fluent-plugin-rewrite-tag-filter cannot be found.
> 
> "rubygem-fluent-plugin-rewrite-tag-filter cannot be found" is the only
> relevant part of this bug.
> I see it has been added to oVirt repos with bug #1401840.
> and I see it within the repo:
> http://resources.ovirt.org/pub/ovirt-4.1-pre/rpm/el7/noarch/rubygem-fluent-
> plugin-rewrite-tag-filter-1.5.5-1.el7.centos.noarch.rpm
> 
> I'm going to close this as work for me, please reopen if you can reproduce.

Sure, it works for me too on upstream clean deployment now.


Note You need to log in before you can comment on or make changes to this bug.