Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 140511 - rdesktop with wrong colors and transparent with xcompmgr
Summary: rdesktop with wrong colors and transparent with xcompmgr
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rdesktop
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2004-11-23 09:15 UTC by Luca Bruera
Modified: 2008-05-13 11:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-28 16:43:58 UTC


Attachments (Terms of Use)

Description Luca Bruera 2004-11-23 09:15:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
rdesktop window appears translucid and with wrong colors when used
with xcomposite extension enabled in xorg and a composition manager
(e.g. xcompmgr). Probably wrong check of the display color depth.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Enable xcomposite in xorg
2.Open a rdesktop connection
3.start xcompmgr
    

Actual Results:  rdesktop window and decorations appear
semi-transparent and with wrong color

Expected Results:  rdesktop window to behave as other normal windows

Additional info:

Comment 1 Luca Bruera 2005-01-18 11:29:22 UTC
A possible workaround for the problem is setting the
XLIB_SKIP_ARGB_VISUALS environment variable before starting tsclient:
e.g.:

export XLIB_SKIP_ARGB_VISUALS=1;tsclient

Comment 3 Gilboa Davara 2006-03-22 10:27:38 UTC
FYI: Fixed in the latest cvs version of xcompmgr.

Comment 4 Ray Strode [halfline] 2007-03-28 16:43:58 UTC
Gilboa, good to know. Thanks!


Note You need to log in before you can comment on or make changes to this bug.