Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1402583 - [RFE][nova]: Expose SR-IOV physical function's VLAN tag to guests
Summary: [RFE][nova]: Expose SR-IOV physical function's VLAN tag to guests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Vladik Romanovsky
QA Contact: Joe H. Rahme
URL: https://blueprints.launchpad.net/nova...
Whiteboard: upstream_milestone_ocata-3 upstream_d...
: 1367786 (view as bug list)
Depends On:
Blocks: 1336839 1427469 1439785 1461074
TreeView+ depends on / blocked
 
Reported: 2016-12-07 21:43 UTC by Stephen Gordon
Modified: 2018-05-04 16:19 UTC (History)
26 users (show)

Fixed In Version: openstack-nova-15.0.1-1.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1439785 1461074 (view as bug list)
Environment:
Last Closed: 2017-06-06 13:20:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1694183 None None None 2017-06-01 05:53:59 UTC
OpenStack gerrit 212472 None None None 2016-12-07 21:43:58 UTC
OpenStack gerrit 381370 None None None 2016-12-07 21:44:03 UTC
OpenStack gerrit 405948 None None None 2016-12-07 21:44:07 UTC
OpenStack gerrit 405949 None None None 2016-12-07 21:44:12 UTC
OpenStack gerrit 405950 None None None 2016-12-07 21:44:22 UTC
OpenStack gerrit 405951 None None None 2016-12-07 21:44:28 UTC
OpenStack gerrit 405952 None None None 2016-12-07 21:44:33 UTC
OpenStack gerrit 405953 None None None 2016-12-07 21:44:39 UTC
OpenStack gerrit 405954 None None None 2016-12-07 21:44:44 UTC
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Stephen Gordon 2016-12-07 21:43:51 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/sriov-pf-passthrough-neutron-port-vlan.

Description:

The sriov-pf-passthrough-neutron-port[1] spec, that introduced network awareness
for the passed-through Physical Functions, has been implemented in the Newton
Cycle. However, current implementation ignores VLAN tags set on the associated
Neutron port.

[1] https://review.openstack.org/#/c/212472

Specification URL (additional information):

https://review.openstack.org/#/c/381370/

Comment 1 Stephen Gordon 2016-12-07 21:54:03 UTC
Sorry Prasanth, one more being worked on in 11 that needs qa_ack+, though this is moving slowly so maybe ends up in Pike we'll see.

Comment 2 Stephen Gordon 2016-12-07 21:55:56 UTC
Vladik is there any additional Nova or Neutron configuration required here that we need to scope from a director POV?

Comment 3 Stephen Gordon 2016-12-20 22:00:06 UTC
qa_ack+ still outstanding.

Comment 5 Vladik Romanovsky 2017-01-09 15:43:36 UTC
(In reply to Stephen Gordon from comment #2)
> Vladik is there any additional Nova or Neutron configuration required here
> that we need to scope from a director POV?

There shouldn't be any additional configuration on the neutron side, I think.

Comment 6 Vladik Romanovsky 2017-01-09 15:50:03 UTC
Patches are currently under review. There is an argument about https://review.openstack.org/#/c/405948/ which may affect the whole series.

The current implementation is consistent with the merged spec, however, now it seems that some part will have to be re-implemented.

Hope the feature will still be merged.

Comment 7 Stephen Gordon 2017-01-24 21:14:10 UTC
*** Bug 1367786 has been marked as a duplicate of this bug. ***

Comment 8 Stephen Gordon 2017-01-27 17:29:23 UTC
Hi Vladik,

What is the up to date status here as of the freeze (Ocata-3), it looks to my naive eyes like this merged and we can move to POST?

Thanks,

Steve

Comment 9 Vladik Romanovsky 2017-01-27 17:41:16 UTC
(In reply to Stephen Gordon from comment #8)
> Hi Vladik,
> 
> What is the up to date status here as of the freeze (Ocata-3), it looks to
> my naive eyes like this merged and we can move to POST?
> 
> Thanks,
> 
> Steve

Yea, it got merged in the last moment :)

Vladik

Comment 10 Stephen Gordon 2017-01-29 23:31:34 UTC
(In reply to Vladik Romanovsky from comment #9)
> (In reply to Stephen Gordon from comment #8)
> > Hi Vladik,
> > 
> > What is the up to date status here as of the freeze (Ocata-3), it looks to
> > my naive eyes like this merged and we can move to POST?
> > 
> > Thanks,
> > 
> > Steve
> 
> Yea, it got merged in the last moment :)
> 
> Vladik

Cool :). Can you please provide some rough guidance on how to test the final implementation for the benefit of the QE folks?

Thanks!

Comment 11 Stephen Gordon 2017-02-01 19:45:12 UTC
*** Bug 1396432 has been marked as a duplicate of this bug. ***

Comment 17 errata-xmlrpc 2017-05-17 19:49:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245

Comment 18 Eran Kuris 2017-06-06 07:31:05 UTC
Opening this RFE due to a bug:
https://bugs.launchpad.net/nova/+bug/1694183

Comment 19 Stephen Gordon 2017-06-06 13:20:30 UTC
(In reply to Eran Kuris from comment #18)
> Opening this RFE due to a bug:
> https://bugs.launchpad.net/nova/+bug/1694183

Please raise a new BZ, this one has already shipped on an errata.

Comment 20 Artom Lifshitz 2018-05-04 16:19:51 UTC
*** Bug 1367786 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.