Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1400242 - lensfun update fails over broken dependencies
Summary: lensfun update fails over broken dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lensfun
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Germano Massullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1405384 1405581 1405582
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-30 17:50 UTC by Michal Jaegermann
Modified: 2016-12-24 02:58 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-19 01:26:48 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2016-11-30 17:50:37 UTC
Description of problem:

In an attempt to update to the latest lensfun for F23 one gets (with 'dnf -b'):

Error: package ufraw-0.21-3.fc23.x86_64 requires liblensfun.so.0()(64bit), but none of the providers can be installed


Version-Release number of selected component (if applicable):
lensfun-0.3.2-2.fc23

Additional information:ufraw-0.21-3.fc23.x86_64
Not even on koji it is possible to find an F23 package later than ufraw-0.21-3.fc23

Comment 1 Rex Dieter 2016-11-30 17:57:01 UTC
Germano, you submitted

https://bodhi.fedoraproject.org/updates/FEDORA-2016-8c6baa752f

why an abi-breaking update?  Are you going to take care of rebuilding all dependencies too?

Comment 2 Rex Dieter 2016-11-30 18:22:46 UTC
according to repoquery, dependencies include:
darktable
digikam
gegl
gimp-lensfun
librawstudio
rawstudio
ufraw

Comment 3 Rex Dieter 2016-11-30 18:25:57 UTC
that said, since f23 is close to EOL, may be wiser to push an epoch'd lensfun-0.3.1 update to supercede the broken (0.3.2) one and leave it at that.

Comment 4 Germano Massullo 2016-12-02 15:27:59 UTC
(In reply to Rex Dieter from comment #1)
> Germano, you submitted
> 
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-8c6baa752f
> 
> why an abi-breaking update?  Are you going to take care of rebuilding all
> dependencies too?

I am sorry, I made a mistake while I was making my first Build Override. Unfortunately the documentation is not very complete[1].
Could you help me, so that I will not make damages again?

Thank you

[1]: https://fedoraproject.org/wiki/Bodhi/BuildRootOverrides

Comment 5 Sergio Monteiro Basto 2016-12-02 23:48:02 UTC
I may rebuild rawstudio (librawstudio) and ufraw on F23 , but what is your decision ? 0.3.2 or 0.3.1 in F23 ?

Comment 6 Rex Dieter 2016-12-03 00:07:59 UTC
Re: comment #4

What do you need help with in particular?

As I said, my preference is to revert back to 0.3.1 to resolve broken dependencies

Comment 7 Nils Philippsen 2016-12-08 13:22:30 UTC
I concur with Rex, up the epoch on the 0.3.1 lensfun package and push it ASAP.

Comment 8 Kevin Kofler 2016-12-08 16:40:23 UTC
I think that at this point, it is a much better idea to just rebuild the reverse dependencies and get them out ASAP.

Bumping the Epoch of lensfun in F23 means that, for upgrade path reasons, it will also have to be bumped on F24, F25 and Rawhide, and that we will be stuck with the Epoch forever. It is a big mess.

Comment 9 Kevin Kofler 2016-12-08 16:42:13 UTC
The only way I see to revert lensfun in F23 without messing up the upgrade path would be to use the Ubuntu hack, i.e.:
lensfun-0.3.2-2.fc23.1.really0.3.1
but ewww…

Comment 10 Germano Massullo 2016-12-08 16:45:21 UTC
(In reply to Rex Dieter from comment #6)
> Re: comment #4
> 
> What do you need help with in particular?
> 
> As I said, my preference is to revert back to 0.3.1 to resolve broken
> dependencies

I agree with Kevin, so IMHO the best thing to do is to force a new release for
digikam
gegl
gimp-lensfun
librawstudio
rawstudio
ufraw

darktable has already been built against the new lensfun version

Comment 11 Rex Dieter 2016-12-09 13:27:59 UTC
f23 EOL is too close, 
https://fedoramagazine.org/fedora-23-end-of-life/

revert this ASAP, so it doesn't go EOL with broken deps

Comment 12 Kevin Kofler 2016-12-09 13:35:53 UTC
A grouped rebuild will not take any longer to go through the update process than a reversion. It just takes a provenpackager to do the rebuilds.

Comment 13 Rex Dieter 2016-12-09 13:48:07 UTC
Reverting would certainly be simpler and easier to test.

Comment 14 Sergio Monteiro Basto 2016-12-09 17:21:26 UTC
I can rebuild : 
gimp-lensfun 
librawstudio
rawstudio
ufraw

 Rex Dieter  , you may rebuild digikam ? 

just left gegl  ...

Comment 15 Rex Dieter 2016-12-09 17:38:10 UTC
Sure, digikam rebuild:
http://koji.fedoraproject.org/koji/buildinfo?buildID=823989

Comment 16 Rex Dieter 2016-12-09 17:48:49 UTC
digikam is blocking flex bug #1364943

Comment 17 Rex Dieter 2016-12-09 18:50:05 UTC
Here you go,

digikam-4.14.0-8.fc23
http://koji.fedoraproject.org/koji/taskinfo?taskID=16807942

Comment 18 Fedora Update System 2016-12-10 10:26:54 UTC
rawstudio-2.1-0.13.20160223git6643b14_rawspeed_5f78369.fc23.1 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8dfb0ad88d

Comment 19 Fedora Update System 2016-12-11 03:59:58 UTC
rawstudio-2.1-0.13.20160223git6643b14_rawspeed_5f78369.fc23.1 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8dfb0ad88d

Comment 20 Kevin Kofler 2016-12-11 04:17:52 UTC
I'd have pushed all the rebuilds in a grouped update (with stablekarma 1), it would have been much faster to get the required karma that way.

Comment 21 Fedora Update System 2016-12-11 14:39:41 UTC
ufraw-0.22-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1925675c6e

Comment 22 Sergio Monteiro Basto 2016-12-13 00:56:19 UTC
(In reply to Kevin Kofler from comment #20)
> I'd have pushed all the rebuilds in a grouped update (with stablekarma 1),
> it would have been much faster to get the required karma that way.

After ufraw-0.22 be pushed to testing . rawstudio and ufraw packages are ready to go to stable (with stablekarma 1) . 

I'm waiting for 36 hours that bodhi push it .

Comment 23 Kevin Kofler 2016-12-13 01:58:01 UTC
We are missing gegl and gimp-lensfun builds.

Comment 24 Kevin Kofler 2016-12-13 01:59:59 UTC
F24 is still a mess too, and the Release in Rawhide and F25 (2%{?dist}) is still lower than in F24 (3%{?dist}).

Comment 25 Fedora Update System 2016-12-13 05:25:42 UTC
ufraw-0.22-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1925675c6e

Comment 26 Rex Dieter 2016-12-13 13:57:54 UTC
Germano, are you going to file the remaining updates?  Ie, what about digikam I referenced in comment #17 ?

Comment 27 Rex Dieter 2016-12-15 15:22:53 UTC
ping again per comment #26


If Germano (or some other provenpackager) doesn't step up to fix the remaining issues by end of tomorrow (Fri Dec 16), I will likely step in to revert the lensfun update (using epoch++), and submit updated dependencies as needed.  I'm hoping I won't have to do that.

Comment 28 Sergio Monteiro Basto 2016-12-15 21:19:13 UTC
TBH , I prefer move forward , as Germano already built darktable , as provenpackager you may rebuild other 2 , with stablekarma 1 . And hope that we left F23 fixed ...

Comment 29 Kevin Kofler 2016-12-15 21:46:14 UTC
Germano is not a provenpackager, he can't rebuild (nor file updates for) packages he is not in the ACL for.

Comment 30 Sergio Monteiro Basto 2016-12-16 07:22:27 UTC
but Rex Dieter is (provenpackager) .

Comment 31 Germano Massullo 2016-12-16 10:59:35 UTC
I opened a bugreport asking for digikam package rebuild
https://bugzilla.redhat.com/show_bug.cgi?id=1405384

Comment 32 Rex Dieter 2016-12-16 14:20:17 UTC
See comment #17, the build is done and ready to be submitted already

Comment 33 Fedora Update System 2016-12-16 14:38:41 UTC
digikam-4.14.0-8.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-dd2b8f27f2

Comment 34 Rex Dieter 2016-12-16 14:41:15 UTC
I took care of digikam, that's all I have time for right now.

Comment 35 Fedora Update System 2016-12-17 01:35:57 UTC
digikam-4.14.0-8.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-dd2b8f27f2

Comment 36 Fedora Update System 2016-12-19 01:26:36 UTC
rawstudio-2.1-0.13.20160223git6643b14_rawspeed_5f78369.fc23.1 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 37 Fedora Update System 2016-12-19 01:26:40 UTC
ufraw-0.22-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 38 Fedora Update System 2016-12-19 01:26:48 UTC
digikam-4.14.0-8.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 39 Sergio Monteiro Basto 2016-12-20 12:55:44 UTC
All updated !  Thanks to all.

Comment 40 Kevin Kofler 2016-12-20 13:29:16 UTC
Yeah, I got the last 2 ones out in what was probably the very last update push for F23.

Comment 41 Sergio Monteiro Basto 2016-12-22 18:16:49 UTC
(In reply to Germano Massullo from comment #10)
> darktable has already been built against the new lensfun version

where ? wasn't sent to updates , neither see it in testing :( 

https://ask.fedoraproject.org/en/question/98224/dependencies-issues-f23-digikam/?comment=98997#comment-98997

Comment 42 Sergio Monteiro Basto 2016-12-24 02:58:31 UTC
FTR darktable-2.0.5-2.fc23.x86_64.rpm was built against lensfun so we may do 

dnf install https://kojipkgs.fedoraproject.org//packages/darktable/2.0.5/2.fc23/x86_64/darktable-2.0.5-2.fc23.x86_64.rpm 

to work around .


Note You need to log in before you can comment on or make changes to this bug.