Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1399726 - Revert https://bugzilla.redhat.com/show_bug.cgi?id=725178
Summary: Revert https://bugzilla.redhat.com/show_bug.cgi?id=725178
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glib2
Version: 6.9
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: 6.9
Assignee: Colin Walters
QA Contact: Desktop QE
URL:
Whiteboard:
: 1405574 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-29 15:42 UTC by Colin Walters
Modified: 2017-03-21 09:02 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-21 09:02:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2801591 None None None 2016-12-15 13:02:13 UTC
Red Hat Product Errata RHBA-2017:0567 normal SHIPPED_LIVE glib2 bug fix update 2017-03-21 12:22:56 UTC

Description Colin Walters 2016-11-29 15:42:48 UTC
The changes introduced in https://bugzilla.redhat.com/show_bug.cgi?id=725178
allowed monitoring NFS home directories, but also made us start monitoring other NFS mounts, which is problematic.

Given that things work better in RHEL7, and backporting is hard, I think we should revert to the previous RHEL6 behavior (no glib change monitoring on NFS).

Comment 3 Joe Wright 2016-12-12 15:31:22 UTC
I posted in the previous BZ as well, but is there any workaround for disabling this available? this causes issues with netapp filers which may be used for centralized home directories

Comment 5 Ondrej Holy 2016-12-12 16:12:07 UTC
See the following comment for possible workarounds:
https://bugzilla.redhat.com/show_bug.cgi?id=1367175#c3

Comment 7 Muhammad Aizuddin Bin Zali 2016-12-16 03:03:47 UTC
(In reply to Ondrej Holy from comment #5)
> See the following comment for possible workarounds:
> https://bugzilla.redhat.com/show_bug.cgi?id=1367175#c3

Another workaround that is possible is to exclude the monitoring at all in /etc/gamin/gaminrc for nfs and autofs.

Add new line as below and kill the gam_server to get it respawned.

fsset nfs none
fsset autofs none


Of course this introduced new issue which is any changes on the filesystem wont be reflected automatically. At least this is to save performance on the netapp filer that might impacting critical service on NFS. Lesser of two evils I would say.

Comment 8 Muhammad Aizuddin Bin Zali 2016-12-16 03:04:11 UTC
(In reply to Ondrej Holy from comment #5)
> See the following comment for possible workarounds:
> https://bugzilla.redhat.com/show_bug.cgi?id=1367175#c3

Another workaround that is possible is to exclude the monitoring at all in /etc/gamin/gaminrc for nfs and autofs.

Add new line as below and kill the gam_server to get it respawned.

fsset nfs none
fsset autofs none


Of course this introduced new issue which is any changes on the filesystem wont be reflected automatically. At least this is to save performance on the netapp filer that might impacting critical service on NFS. Lesser of two evils I would say.

Comment 9 Colin Walters 2016-12-16 13:22:05 UTC
ne approach we could consider is introducing a "config file" like /etc/glib2-monitor-nfs that if present, would do global NFS monitoring.  Or an environment variable. That would allow desktop users with NFS home directories they do want to monitor to enable it.

Comment 10 Colin Walters 2016-12-16 16:02:13 UTC
For reverting, the spec diff is just:

diff --git a/glib2.spec b/glib2.spec
index f0206aa..8ee6312 100644
--- a/glib2.spec
+++ b/glib2.spec
@@ -3,7 +3,7 @@
 Summary: A library of handy utility functions
 Name: glib2
 Version: 2.28.8
-Release: 6%{?dist}
+Release: 7.nfsrevert.0%{?dist}
 License: LGPLv2+
 Group: System Environment/Libraries
 URL: http://www.gtk.org
@@ -40,7 +40,6 @@ Patch4: Revert-deprecations-since-glib-2.22.patch
 # https://bugzilla.gnome.org/656039
 Patch5: GDBusProxy-thread-safety.patch
 
-Patch6: glib2-force-fam-for-remote-fs.patch
 Patch7: bug-1212722-gmain-source-reuse-for-qemu.patch
 
 %description

Scratch build: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=12247687

Comment 11 Ondrej Holy 2017-01-06 14:27:14 UTC
*** Bug 1405574 has been marked as a duplicate of this bug. ***

Comment 17 errata-xmlrpc 2017-03-21 09:02:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0567.html


Note You need to log in before you can comment on or make changes to this bug.