Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1396472 - Fedora - Missing flannel package for ppc64le architecture
Summary: Fedora - Missing flannel package for ppc64le architecture
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: flannel
Version: 25
Hardware: ppc64le
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Jan Chaloupka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1398575
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2016-11-18 12:20 UTC by Manjunath A Kumatagi
Modified: 2017-02-09 04:21 UTC (History)
10 users (show)

Fixed In Version: flannel-0.6.2-1.fc26 flannel-0.7.0-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-09 04:21:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 149095 None None None 2016-11-25 12:20:44 UTC

Description Manjunath A Kumatagi 2016-11-18 12:20:39 UTC
Description of problem:
Missing flannel package for ppc64le architecture

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. dnf info flannel


Actual results:
[root@localhost ~]# dnf info flannel
Last metadata expiration check: 0:52:52 ago on Fri Nov 18 03:27:17 2016.
Error: No matching Packages to list
[root@localhost ~]# 

Expected results:
Should have a package in the repository.

Additional info:

Comment 1 Dan Horák 2016-11-25 10:06:19 UTC
It's a build dependency issue, the recent flannel builds need golang-github-vishvananda-netlink-0-0.7.git1e2e08e.fc24 in the buildroot, but it fails.

Comment 2 Fedora Update System 2016-12-17 17:34:23 UTC
flannel-0.6.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0b0a3acf2f

Comment 3 Fedora Update System 2016-12-19 02:31:59 UTC
flannel-0.6.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0b0a3acf2f

Comment 4 Manjunath A Kumatagi 2016-12-26 06:19:38 UTC
not able to install through dnf command, can someone help me to test this?

[root@localhost ~]# uname -a
Linux localhost.localdomain 4.8.6-300.fc25.ppc64le #1 SMP Wed Nov 2 16:25:53 UTC 2016 ppc64le ppc64le ppc64le GNU/Linux
[root@localhost ~]# dnf install flannel --enablerepo=updates-testing
Last metadata expiration check: 0:10:55 ago on Sun Dec 25 22:06:56 2016.
No package flannel available.
Error: Unable to find a match.
[root@localhost ~]#

Comment 5 Jan Chaloupka 2017-01-03 14:29:43 UTC
You can run:

dnf install https://kojipkgs.fedoraproject.org//packages/flannel/0.6.2/1.fc26
/ppc64le/flannel-0.6.2-1.fc26.ppc64le.rpm

The flannel for ppc64le is built only in rawhide.
Checking https://ppc.koji.fedoraproject.org/koji/, the latest flannel in rawhide is not ported here yet (though, already built on f25).

Comment 6 IBM Bug Proxy 2017-01-19 08:40:34 UTC
------- Comment From hannsj_uhl@de.ibm.com 2017-01-19 03:31 EDT-------
Comment from  Manjunath A. Kumatagi 2017-01-19 00:53:28 CST

I tried installing package manually and here are my findings:

[root@localhost ~]# rpm -qa | grep flannel
flannel-0.6.2-1.fc26.ppc64le

[root@localhost ~]# flanneld -version
0.5.3+git

[root@localhost ~]# systemctl status flanneld -l
? flanneld.service - Flanneld overlay address etcd agent
Loaded: loaded (/usr/lib/systemd/system/flanneld.service; disabled; vendor pres
Active: active (running) since Wed 2017-01-18 22:48:46 PST; 1min 26s ago
Process: 23293 ExecStartPost=/usr/libexec/flannel/mk-docker-opts.sh -k DOCKER_NE
Main PID: 23273 (flanneld)
Tasks: 9 (limit: 4915)
Memory: 14.8M
CPU: 50ms
CGroup: /system.slice/flanneld.service
??23273 /usr/bin/flanneld -etcd-endpoints=http://127.0.0.1:2379 -etcd-p

Jan 18 22:48:46 localhost.localdomain systemd[1]: Starting Flanneld overlay addres
Jan 18 22:48:46 localhost.localdomain flanneld[23273]: I0118 22:48:46.858789 23273
Jan 18 22:48:46 localhost.localdomain flanneld[23273]: I0118 22:48:46.860140 23273
Jan 18 22:48:46 localhost.localdomain flanneld[23273]: I0118 22:48:46.861386 23273
Jan 18 22:48:46 localhost.localdomain flanneld[23273]: I0118 22:48:46.861420 23273
Jan 18 22:48:46 localhost.localdomain flanneld[23273]: I0118 22:48:46.867002 23273
Jan 18 22:48:46 localhost.localdomain flanneld[23273]: I0118 22:48:46.875103 23273
Jan 18 22:48:46 localhost.localdomain flanneld[23273]: I0118 22:48:46.875986 23273
Jan 18 22:48:46 localhost.localdomain flanneld[23273]: I0118 22:48:46.876008 23273
Jan 18 22:48:46 localhost.localdomain systemd[1]: Started Flanneld overlay address

[root@localhost ~]# ifconfig flannel.1
flannel.1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1450
inet 10.20.66.0  netmask 255.255.0.0  broadcast 0.0.0.0
ether 5e:18:27:eb:7d:14  txqueuelen 0  (Ethernet)
RX packets 0  bytes 0 (0.0 B)
RX errors 0  dropped 0  overruns 0  frame 0
TX packets 0  bytes 0 (0.0 B)
TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Things are working fine, only concern I've is "flannel -version" command is not matching the version in the rpm name. -Thanks.

Comment 7 Fedora Update System 2017-01-21 19:34:25 UTC
flannel-0.7.0-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-013e53830f

Comment 8 Fedora Update System 2017-01-23 02:22:38 UTC
flannel-0.7.0-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-013e53830f

Comment 9 Manjunath A Kumatagi 2017-01-24 08:25:44 UTC
rpm version and command line version is still not matching.

[root@localhost ~]# flanneld --version
0.5.3+git
[root@localhost ~]# 
[root@localhost ~]# 
[root@localhost ~]# rpm -qa | grep flannel
flannel-0.7.0-1.fc26.ppc64le
[root@localhost ~]#

Comment 10 Fedora Update System 2017-01-24 09:55:59 UTC
flannel-0.7.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-44e53aabed

Comment 11 Manjunath A Kumatagi 2017-01-24 11:43:04 UTC
Now the command version and rpm version are matching.

[root@localhost ~]# flanneld --version
0.7.0
[root@localhost ~]# rpm -qa | grep flannel
flannel-0.7.0-2.fc26.ppc64le
[root@localhost ~]#

Comment 12 Fedora Update System 2017-01-28 19:20:02 UTC
flannel-0.7.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-44e53aabed

Comment 13 Fedora Update System 2017-02-09 04:21:10 UTC
flannel-0.7.0-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.