Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1394555 - [UI] 'passthough' should be disabled in Create/edit vNIC profile dialog for external network
Summary: [UI] 'passthough' should be disabled in Create/edit vNIC profile dialog for e...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.1.0
Hardware: x86_64
OS: Linux
low
medium vote
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Marcin Mirecki
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks: 1366899
TreeView+ depends on / blocked
 
Reported: 2016-11-13 13:25 UTC by Mor
Modified: 2017-12-20 11:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:06:47 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
rule-engine: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
fixed window (deleted)
2017-06-05 10:58 UTC, Mor
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 77399 master MERGED webadmin: passthrough and port mirroring must always be disabled for external networks 2017-05-31 14:39:02 UTC

Description Mor 2016-11-13 13:25:48 UTC
Description of problem:
1. UI window of creating/editing vNIC profile, which is attached to external network, has logic problem. When checking and unchecking the "Passthrough" checkbox on this window, greyed-out option "Port Mirroring" becomes available for user selection. 

2. All other unsupported options of external networks in that window, should be greyed-out.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 4.1.0-0.0.master.20161112231308.git672bd31.el7.centos

How reproducible:
100%

Steps to Reproduce:
1. Create a new external network by selecting name and external provider.
2. vNIC profile attached to that network should be created automatically.
3. Edit the vNIC profile.
4. Check/Uncheck the "passthrough" checkbox.

Actual results:
"Port-Mirroring" option become available for selection.


Expected results:
"Port-Mirroring" should stay greyed out.

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2016-11-13 13:25:54 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Marcin Mirecki 2017-05-26 13:03:35 UTC
Title of bug says: 'passthough' should be disabled
Bug says: "Port-Mirroring" should stay greyed out.

I'm disabling both passthrough and portMirroring for external networks.

Comment 3 Mor 2017-06-05 10:56:46 UTC
Verified on: 4.2.0-0.0.master.20170531203202.git1bf6667.el7.centos.

Comment 4 Mor 2017-06-05 10:58:02 UTC
Created attachment 1285016 [details]
fixed window

Port Mirror is greyed out

Comment 5 Mor 2017-06-05 10:59:07 UTC
(In reply to Mor from comment #4)
> Created attachment 1285016 [details]
> fixed window
> 
> Port Mirror is greyed out

* Passthrough

Comment 6 Sandro Bonazzola 2017-12-20 11:06:47 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.