Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 139393 - Gnome Pilot applet gets stuck synchronising calendar information from a PDA
Summary: Gnome Pilot applet gets stuck synchronising calendar information from a PDA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-pilot-conduits
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
Depends On:
Blocks: FC3Update 161133
TreeView+ depends on / blocked
Reported: 2004-11-15 19:38 UTC by Michael Waite
Modified: 2007-11-30 22:10 UTC (History)
5 users (show)

Fixed In Version: evolution-connector-2.0.4-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-08-29 18:23:30 UTC

Attachments (Terms of Use)
Patch to fix broken pilot synchronization (deleted)
2005-03-22 15:05 UTC, Aaron Gaudio
no flags Details | Diff

System ID Priority Status Summary Last Updated
Ximian Software (Novell) 73975 None None None Never

Description Michael Waite 2004-11-15 19:38:16 UTC
Description of problem:
Gnome Pilot applet gets stuck synchronising calendar information from
a PDA.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. set up gnome-pilot ECalendar to sync or to get from PDA
2. try syncing

Actual results:
Sync of data

Expected results:
Seems to get stuck with top progress bar at about 10%, with lower
progress bar going back on forth like crazy. 

Additional info:
Attaching to the gpilot process yields this backtrace:
#0  0x00b347a2 in _dl_sysinfo_int80 () from /lib/
#1  0x00d93ac6 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/
#2  0xf56ddc25 in e_cal_remove_object_with_mod ()
   from /usr/lib/
#3  0xf56ddd26 in e_cal_remove_object () from /usr/lib/
#4  0xf57685c1 in ?? ()
   from /usr/lib/evolution/2.0/conduits/
#5  0x09e0f2f8 in ?? ()
#6  0x09daacf0 in ?? ()
#7  0x00000000 in ?? ()

Comment 1 Michael Waite 2004-11-15 19:40:01 UTC
Works for getting data from computer to PDA; problem appears to be
gettingdata from PDA to computer, and is specifically
calendar-related; e.g. contacts work as expected

Comment 2 Dave Malcolm 2004-11-16 22:42:29 UTC
*** Bug 139617 has been marked as a duplicate of this bug. ***

Comment 3 Aaron Gaudio 2005-03-16 23:24:01 UTC
I'm using evolution 2.0.4 (from Fedora Core 3 testing updates), and it seems to
lock up whether I synchronize or copy from evo (same with evo 2.0.2).

Here is the output from gpilotd when this happens:
ecalconduit-Message: ---------------------------------------------------------

ecalconduit-Message: pre_sync: Calendar Conduit v.0.1.6
ecalconduit-Message:   Using timezone:

I'm trying to sync to a Treo650, which works with local calendars.

I've tried manually upgrading to evo 2.2.0 (rebuilt all appropriate rpms from
Fedora 4 test), but to no avail- that seemed to be less stable.

Comment 4 Aaron Gaudio 2005-03-22 15:05:50 UTC
Created attachment 112214 [details]
Patch to fix broken pilot synchronization

I believe I have solved this. Try this patch out.

Comment 5 Gary Mansell 2005-05-06 09:55:11 UTC
I see this problem on RHEL 4 and it is causing me not to be able to sync my Palm
pilot with Evolution running with the Connector. It appears to be the calendar
that causes the problem.

What do I do about resolving the problem - I would guess that the patch supplied
has to be applied to a source rpm (which one) and are there any instructions
anywhere regarding doing this?

Is it likely to be fixed in the near future - ie is the next update of evolution
going to resolve this problem so that I can just up2date away from the problem?

Comment 6 Aaron Gaudio 2005-05-10 21:42:56 UTC
Gary, the patch above should be applied to Ximian Connector (in the Fedora
'evolution-connector' srpm. To do it manually, download the evolution-connector
rpm for FC3, install it, then edit the spec file to add my patch, as per the RPM
spec format. Then rebuild the rpm with 'rpmbuild -ba evolution-connector.spec'.

BTW, this is really a bug with evolution-connector, not gnome-pilot or the conduits.

Comment 7 Gary Mansell 2005-05-11 08:09:28 UTC
I have tried this and installed the new RPM but it has not fixed the problem.

Any ideas what I do to get Redhat to fix this in RHEL as it is a real nuisance
not to be able to sync with my Palm Pilot?

Comment 8 Dave Malcolm 2005-05-12 03:37:28 UTC
Thanks.  The patch looks good to me; I'm working on a test FC-3 update for this.

It looks like the bug persists upstream, so this will affect FC-4 as well; I'll
help with getting this committed upstream.

Gary Mansell: It may be that the problems you're encountering are this bug, or
that you're seeing a different bug (or perhaps a combination).  I recommend
opening an issue with Red Hat Support so that we can be sure that we get the
problems you're seeeing fixed.
It will help us if you cite this bugzilla ID for reference when you do.

I've marked the problem identified by Aaron Gaudio as a candidate for inclusion
in a RHEL 4 quarterly update.  Please open an issue with Red Hat Support if you
want a faster fix, or information on exactly when the update will be available.

I hope this answers your questions

Comment 9 Dave Malcolm 2005-05-12 04:30:01 UTC
I've released a test update for FC3 containing the patch:

Comment 10 Aaron Gaudio 2005-05-18 14:25:05 UTC

My patch also applies cleanly to connector 2.2.2 (in Fedora Core 4 Test), which
also appears to have the same problem.

Comment 11 Dave Malcolm 2005-05-18 16:27:09 UTC

Has anyone tried the the FC3 test package?

I'm trying to get your patch into the FC4 package before release.

I added some notes to the upstream bug, in the hope of getting this fixed there
as well.

Comment 13 Dave Malcolm 2005-06-18 00:37:37 UTC
Has anyone tried the FC3 test package?

Comment 14 Dave Malcolm 2005-06-20 18:38:20 UTC
(I created bug 161133 to track this bug for RHEL 4)

Comment 16 Dave Malcolm 2005-08-29 18:23:30 UTC
This is now available as a full update for FC3:

Note You need to log in before you can comment on or make changes to this bug.