Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1391203 - ovirt-shell creates .ovirtshellrc not .rhevmshellrc
Summary: ovirt-shell creates .ovirtshellrc not .rhevmshellrc
Keywords:
Status: CLOSED DUPLICATE of bug 1356941
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.0.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-4.0.7
: ---
Assignee: rhev-docs@redhat.com
QA Contact: rhev-docs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-02 19:05 UTC by Jim Wildman
Modified: 2016-11-30 01:18 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-30 01:18:29 UTC
oVirt Team: Docs
Target Upstream Version:


Attachments (Terms of Use)

Description Jim Wildman 2016-11-02 19:05:44 UTC
Description of problem:
https://access.redhat.com/documentation/en/red-hat-virtualization/4.0/single/rhevm-shell-guide#rhevmshellrc_Configuration states

"The .rhevmshellrc is a configuration file that is automatically created and populated when the user first connects to the ovirt-shell."

However, running ovirt-shell creates ~/.ovirtshellrc

ovirt-shell ignores all settings in .rhevmshellrc


Version-Release number of selected component (if applicable):
[rhevm.home ~]# rpm -q ovirt-engine-cli
ovirt-engine-cli-3.6.8.1-1.el7ev.noarch

How reproducible:
run ovirt-shell for the first time

Comment 1 Juan Hernández 2016-11-03 09:11:46 UTC
For version 4 of RHV it was decided to use the same package names that are used upstream. For example, the rhevm-cli package was renamed to ovirt-engine-cli, to preserve the upstream names. A side effect of this change is that the name of the configuration file is also different, it used to be .rhevmshellrc and it is now .ovirtshellrc, like upstream. I think that this shouldn't be changed, we should rather update the documentation, thus I will move the bug to the documentation component. Please comment if you disagree.

Comment 2 Tahlia Richardson 2016-11-30 01:18:29 UTC
I recently updated the file name while working on BZ#1356941. The update will be published soon. 

Closing this bug as a duplicate.

*** This bug has been marked as a duplicate of bug 1356941 ***


Note You need to log in before you can comment on or make changes to this bug.