Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1389392 - Cloudforms attempts to connect to he wrong tenant to reach an instance (all actions but open vnc console)
Summary: Cloudforms attempts to connect to he wrong tenant to reach an instance (all a...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: All
OS: All
high
high
Target Milestone: GA
: 5.8.0
Assignee: Petr Blaho
QA Contact: Mike Foley
URL:
Whiteboard: openstack:tenant
Depends On: 1359268
Blocks: 1370207 1391882 1393511
TreeView+ depends on / blocked
 
Reported: 2016-10-27 14:05 UTC by Felix Dewaleyne
Modified: 2017-06-12 16:07 UTC (History)
13 users (show)

Fixed In Version: 5.8.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1359268
: 1393511 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:07:05 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Comment 4 Petr Blaho 2016-11-07 22:50:49 UTC
For reference:

Description of problem:
When attempting to open a console to an instance, cloudforms fails to connect because theinstance does not exist for that tenant - it attempts to use the wrong tenant

How reproducible:
very frequent in customer environment

Steps to Reproduce:
1. set up a multiple host openstack environment
2. set up multiple projects, some of which use the same names
3. connect cloudforms to the openstack environment
4. try to open a console to instances that are located on the different projects

Actual results:
[----] E, [2016-07-22T13:23:45.070974 #2448:10f5e8c] ERROR -- : excon.error     #<Excon::Errors::NotFound: Expected([200, 202]) <=> Actual(404 Not Found)
excon.error.response
  :body          => "{\"itemNotFound\": {\"message\": \"Instance fd53f617-8b5b-4814-b4c1-f3de1376946d could not be found.\", \"code\": 404}}"
  :headers       => {


Expected results:
the connection establishes

Comment 5 Petr Blaho 2016-11-07 22:51:10 UTC
PR - https://github.com/ManageIQ/manageiq/pull/12486

For these actions:
* stop
* start
* pause
* suspend
* shelve
* shelve offload
* soft reboot
* hard reboot
* delete
* migrate
* evacuate

API calls tested that they use proper tenant id.


Felix, please, can you confirm that these are all actions that are affected by this BZ?
I will investigate more if you find another.

Comment 7 Edu Alcaniz 2016-11-16 14:35:21 UTC
could you update us about this bugzilla please?

Comment 8 Satoe Imaishi 2016-11-16 15:02:02 UTC
Assuming you're asking about cfme-5.7...

BZ #1393511 is tracking this bug for cfme 5.7.  The latest build contains the fix for this issue and the BZ was put to ON_QA yesterday, waiting to be verified by QE.

Comment 9 Felix Dewaleyne 2016-11-30 10:32:40 UTC
(In reply to Petr Blaho from comment #5)
> PR - https://github.com/ManageIQ/manageiq/pull/12486
> 
> For these actions:
> * stop
> * start
> * pause
> * suspend
> * shelve
> * shelve offload
> * soft reboot
> * hard reboot
> * delete
> * migrate
> * evacuate
> 
> API calls tested that they use proper tenant id.
> 
> 
> Felix, please, can you confirm that these are all actions that are affected
> by this BZ?
> I will investigate more if you find another.

finally confirmed there are no other operations than the ones you listed. The customer asked about another one related to provisioning but it turned out to be a misunderstanding.

Comment 10 Ronnie Rasouli 2017-04-04 11:54:27 UTC
verifed on 5.7.2
actions on osp tenant occurs


Note You need to log in before you can comment on or make changes to this bug.