Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1388208 - Custom global keyboard shortcuts don't work any more
Summary: Custom global keyboard shortcuts don't work any more
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-24 18:20 UTC by Christian Stadelmann
Modified: 2016-10-25 08:30 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-25 08:30:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 773005 None None None 2016-10-24 18:23:37 UTC

Description Christian Stadelmann 2016-10-24 18:20:56 UTC
Version-Release number of selected component (if applicable):
gnome-settings-daemon-3.22.1-1.fc25.x86_64
gnome-shell-3.22.1-2.fc25.x86_64
dconf-0.26.0-1.fc25.x86_64
glib2-2.50.1-1.fc25.x86_64
gtk3-3.22.1-2.fc25.x86_64
mutter-3.22.1-5.fc25.x86_64

How reproducible:
always since some recent update (last 7 days)

Steps to Reproduce:
1. Have any custom keyboard shortcut set in gnome-control-center, section "Keyboard"
2. In a gnome session, try to use the shortcut

Actual results:
Most non-default keyboard shortcut don't work any more.

Expected results:
Any user set keyboard shortcut listed in gnome-control-center should work

Additional info:
While the keyboard shortcut fails, I get this message from gnome-settings-daemon printed to syslog with varying IDs:

Could not find accelerator for accel id 129


This issue is present for both old shortcuts (from before the F24→F25 upgrade) and new shortcuts. This issue seems to affect any shortcut, e.g. Ctrl+PgDown or Super+W. All default shortcuts work fine though.

Comment 1 Bastien Nocera 2016-10-25 08:30:15 UTC
We don't need to track this in multiple places, closing.


Note You need to log in before you can comment on or make changes to this bug.