Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 138761 - Installer sets invalid sync rate for X server on ATI Radeon X300/Viewsonic VX-900-2
Summary: Installer sets invalid sync rate for X server on ATI Radeon X300/Viewsonic VX...
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
Reported: 2004-11-11 00:44 UTC by Chris Colohan
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-09-28 00:43:03 UTC

Attachments (Terms of Use) log file generated when running system-config-display (deleted)
2005-06-25 22:15 UTC, Chris Colohan
no flags Details

System ID Priority Status Summary Last Updated 1129 None None None Never 3627 None None None Never

Description Chris Colohan 2004-11-11 00:44:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I tried to install Fedora Core 3 on my computer, and as soon as the X
server is first started my monitor blanks and complains of an invalid
sync rate.  Apparently the probing for valid resolutions and sync
rates for my monitor/video card combination fails.

So here is what I did:

1.  Boot the install disk with "linux resolution=1280x1024", anaconda
is able to start up X windows, and the install process succeeds.

2.  Reboot as directed.  Try to add the "resolution=1280x1024"
parameter to the boot command line.  Figure out that this parameter is
now ignored.  Curse.  Try to log in at the text mode console, and
discover that the login program is not running yet.  Curse. 
Apparently you need to do some more install steps, but I can't see the
screen where these steps are since it is on a mis-functioning X server.

It would be useful if there was a warning on the boot screen that if
you need to use the "resolution" kernel parameter then your install
will complete, but you will never be able to boot the machine which
you have installed since that parameter is only available for the
first stage of the install process.

3.  Boot off of the install disk with "linux rescue".  Edit
/etc/X11/xorg.conf, and add the resolution of "1280x1024" to the
resolutions which are already there (640x480 and 800x600).

4.  Reboot once more.  Breathe a sigh of relief, it is working.

The machine with which I had this problem is a stock Dell Optiplex
GX280 computer with a Dell supplied ATI Radeon X300 video card and a
ViewSonic VX-900-2 LCD monitor hooked up using a DVI cable.

It is probably worth noting that Fedora Core 2 did not have this
problem.  I believe Fedora Core 2 also did not have a specific driver
for my video card -- it instead used the generic SVGA driver.  So
perhaps this is a problem with the ATI Radeon X300 driver.

If you have any test cases you would like me to run, or need more
information, please let me know.


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot Fedora Core 3 install CD
2. Look at blank screen with monitor saying "invalid sync rate"
3. Cry

Additional info:

Comment 1 Chris Colohan 2004-11-15 02:38:58 UTC
I have noticed some related bugs appearing.  In particular, see the
following bugs:

Comment 2 Doug Morton 2004-11-20 04:27:25 UTC
I encountered a similar problem installing FC3 x86_64 with my Radeon
9800 Pro and Syncmaster 191+.  With the Monitor connected via the DVI
interface, the screen blanks and the install fails because an invalid
sync rate.  Changing to a VGA connection (exact same video card and
monitor) allowed the install to complete without problem.  After the
post-install reboot and configure, switching back to the DVI
connection works just fine.  

FC3 test 3 did not have this problem.  Only FC3 final.

Comment 3 Mike A. Harris 2005-04-11 02:46:56 UTC
Install in text mode if you haven't gotten the OS installed already,
then afterward, log in as root, and run:

system-config-display --reconfig

Try to start up X, and if it does not work, please attach your X server
log file, and config file to the bug report using the attachment feature

Also, please file a bug report in the X.Org project bugzilla at in the "xorg" component, as this will maximize
the likelyhood of this issue being fixed sooner and made available as
an update for Fedora Core.  Once you've filed your bug report in X.Org
bugzilla, paste the URL here and we will track the issue in the upstream

Comment 4 Mike A. Harris 2005-04-11 02:47:43 UTC
Setting status to "NEEDINFO", awaiting upstream bug URL and file attachments
as requested above.

Comment 5 Mike A. Harris 2005-05-16 21:36:33 UTC
6 months have elapsed since the last feedback from this issue, and there
has not been any feedback to my request in comment #3, so I assume the
issue is resolved in the current updates released for Fedora Core 3.

If the problem is still an issue with all Fedora updates applied however,
file a bug report to X.Org as requested above, and if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "RAWHIDE"

Comment 6 Chris Colohan 2005-05-16 22:10:56 UTC
Unfortunately, I do not have a spare computer to reinstall the operating system
on from scratch for testing purposes.  :-(

I switched to a text console on my working and fully-up-to-date system, and ran
"system-config-display --reconfig", and was rewarded with a blank screen (due to
it starting up an X server with an invalid sync rate).  I had to kill the
invisible X server with ctrl-alt-backspace.  No files were touched in /etc/X11
by doing this, so I have no failing config file to attach.  If you can tell me
where this command might leave a log file I can go looking for it.  :-)

I did a search for similar bugs in the X.Org bugzilla, and although I didn't
find one exactly like this one, I did figure out that they would like exact X
server invocation and configuration information in their bugreports.  Since the
redhat configure scripts do not give me this information (and I sadly don't have
the time to read all of the redhat scripts to figure this out), I can't file a
bugreport which would be useful to them.

If you can tell me:
  a)  where to find any log files which are generated by the X server started up
by "system-config-display --reconfig", and
  b)  how to find out what command line invocation of X is performed by this command
then I will happily give you the information you desire.

Comment 7 Chris Colohan 2005-06-15 14:27:29 UTC
Now that FC4 is out, I was able to try it again.  It still doesn't work, so I am
reopening the bug.

If you can give me instructions on how to generate the log file you need, I
would be happy to provide it.

Comment 8 Mike A. Harris 2005-06-23 17:52:13 UTC
As requested in comment #3 above, please file a bug report in the X.Org
project bugzilla at in the "xorg" component
in order for Xorg developers to be made aware of the issue.

The X server log file is automatically put into the system wide log directory
/var/log.  Attach the X server log file and config file to the bug
report you file, so that Xorg developers have enough detail to be able
to diagnose the problem.

Once you've filed your bug report in X.Org bugzilla, paste the URL here
and we will track the issue in the upstream bugzilla.

Setting status to "NEEDINFO", awaiting upstream bug URL.

Comment 9 Chris Colohan 2005-06-25 22:15:43 UTC
Created attachment 115979 [details] log file generated when running system-config-display

Comment 10 Chris Colohan 2005-06-25 22:17:21 UTC
Comment on attachment 115979 [details] log file generated when running system-config-display

I attempted to run "system-config-display --reconfig" on my FC4 system, and it
displayed a blank screen (invalid sync rate).  So it never got as far as
generating a new configuration file for me to try.

Attached is the error log from the system-config-display command.  I will open
an bug momentarily...

Comment 11 Chris Colohan 2005-06-25 22:23:13 UTC
FYI -- I have not attached the config file for Xorg since either there was none,
or system-config-display erased it faster than I was able to make a copy of it
in /tmp....

Comment 12 Chris Colohan 2005-06-25 22:25:17 UTC
Bug 3627 created in xorg is here:

Comment 13 Mike A. Harris 2005-09-28 00:43:03 UTC
Tracking in upstream master X.Org bug report:

Note You need to log in before you can comment on or make changes to this bug.