Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 138712 - mtrr: type mismatch for e8000000,8000000 old: write-back new: write-combining
Summary: mtrr: type mismatch for e8000000,8000000 old: write-back new: write-combining
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2004-11-10 20:15 UTC by Bill Nottingham
Modified: 2014-03-17 02:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-30 17:29:53 UTC


Attachments (Terms of Use)
config file (deleted)
2004-11-10 20:16 UTC, Bill Nottingham
no flags Details
xorg log (deleted)
2004-11-10 20:17 UTC, Bill Nottingham
no flags Details
/proc/mtrr before X (deleted)
2004-11-10 20:48 UTC, Bill Nottingham
no flags Details
/proc/mtrr after starting X (deleted)
2004-11-10 20:49 UTC, Bill Nottingham
no flags Details
dmesg before X (deleted)
2004-11-10 20:50 UTC, Bill Nottingham
no flags Details
dmesg after starting X (deleted)
2004-11-10 20:51 UTC, Bill Nottingham
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 4310 None None None Never

Description Bill Nottingham 2004-11-10 20:15:09 UTC
mtrr: type mismatch for e8000000,8000000 old: write-back new:
write-combining

<arjan> X vs mtrr driver disagreement
<arjan> then bug the X team for sure

00:00.0 Host bridge: Intel Corp. E7505 Memory Controller Hub (rev 03)
00:00.1 Class ff00: Intel Corp. E7505/E7205 Series RAS Controller (rev 03)
00:01.0 PCI bridge: Intel Corp. E7505/E7205 PCI-to-AGP Bridge (rev 03)
00:02.0 PCI bridge: Intel Corp. E7505 Hub Interface B PCI-to-PCI
Bridge (rev 03)00:02.1 Class ff00: Intel Corp. E7505 Hub Interface B
PCI-to-PCI Bridge RAS Controller (rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB2
EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corp. 82801DB/DBL (ICH4/ICH4-L) LPC
Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801DB (ICH4) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV34GL [Quadro
FX 500/600 PCI] (rev a1)
02:1c.0 PIC: Intel Corp. 82870P2 P64H2 I/OxAPIC (rev 04)
02:1d.0 PCI bridge: Intel Corp. 82870P2 P64H2 Hub PCI Bridge (rev 04)
02:1e.0 PIC: Intel Corp. 82870P2 P64H2 I/OxAPIC (rev 04)
02:1f.0 PCI bridge: Intel Corp. 82870P2 P64H2 Hub PCI Bridge (rev 04)
03:03.0 Ethernet controller: Intel Corp. 82545EM Gigabit Ethernet
Controller (Copper) (rev 01)

(using stock nv driver)

Comment 1 Bill Nottingham 2004-11-10 20:16:13 UTC
Created attachment 106435 [details]
config file

Comment 2 Bill Nottingham 2004-11-10 20:17:07 UTC
Created attachment 106436 [details]
xorg log

Comment 3 Mike A. Harris 2004-11-10 20:25:10 UTC
Configure the system to boot into runlevel 3, so that X does not
start after a clean system reboot.  Then capture the output of
/proc/mtrr so we know what MTRRs are set prior to X starting up.
Also check if /var/log/messages contains any MTRR related errors
or messages prior to starting X.

Then start up X using "startx", and attach the /proc/mtrr results
from the X session, and /var/log/messages MTRR entries, as well
as the X log if it differs from the attached one.

TIA

Comment 4 Bill Nottingham 2004-11-10 20:48:51 UTC
Created attachment 106437 [details]
/proc/mtrr before X

Comment 5 Bill Nottingham 2004-11-10 20:49:24 UTC
Created attachment 106438 [details]
/proc/mtrr after starting X

Comment 6 Bill Nottingham 2004-11-10 20:50:35 UTC
Created attachment 106439 [details]
dmesg before X

Comment 7 Bill Nottingham 2004-11-10 20:51:24 UTC
Created attachment 106440 [details]
dmesg after starting X

Comment 9 Dawid Gajownik 2005-02-01 11:42:52 UTC
Please read this thread รข
http://www.ussg.iu.edu/hypermail/linux/kernel/0411.3/0314.html - it
seems that this bug was fixed in kernel 2.6.10 (this was the main
reason why MPlayer was slower on 2.6 kernels; unfortunately it's still
faster on 2.4 ones).

There is still one question - does it need to be fixed in X.org X11 as
it says Alan Cox
(http://www.ussg.iu.edu/hypermail/linux/kernel/0411.3/1244.html)?

Comment 10 Mike A. Harris 2005-02-01 12:03:54 UTC
Carbon copying Alan to find out.

Setting status to "NEEDINFO"

Comment 12 Billy Biggs 2005-04-13 18:31:44 UTC
Was this ever resolved?  I am seeing this issue on RHEL4 and it is 
seriously hurting X performance.

Comment 13 Mike A. Harris 2005-04-13 21:17:25 UTC
Red Hat Enterprise Linux customers who are experiencing issues of this
nature, should contact Red Hat Global Support Services at 1-888-RED-HAT1
and discuss the issue with one of our associates.  Once GSS has been
contacted, they will work with the customer, engineering and other
parties on finding a solution for Red Hat Enterprise Linux.

Hope this helps.

Comment 14 Mike A. Harris 2005-08-30 06:39:37 UTC
This problem seems to be isolated to very few systems using Intel
integrated video hardware.  It isn't clear if anyone is still
experiencing this problem or not in Fedora Core 4.

At this point, the best advice I can give anyone who can still reproduce
this, is to file a bug report in X.Org bugzilla at http://bugs.freedesktop.org,
and include as many details as possible, including all of the above file
attachments and any other data that might help narrow the problem down.

Once you have filed a bug report in X.Org bugzilla, the upstream i810
driver maintainer (Alan Hourihane) and other developers who frequently
contribute to the i810 driver codebase will see your bug report and may
be able to directly troubleshoot it locally with hardware they have on
hand.

Once the report is filed upstream, paste the URL here and we will track
the issue in the X.org bugzilla going forward.



Comment 15 Mike A. Harris 2005-08-30 06:40:49 UTC
Setting status to "NEEDINFO_REPORTER" and awaiting upstream
bug report URL and status update.

Comment 16 Bill Nottingham 2005-08-30 17:29:53 UTC
https://bugs.freedesktop.org/show_bug.cgi?id=4310


Note You need to log in before you can comment on or make changes to this bug.