Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1383869 - PyGI warnings displayed when started from a terminal window
Summary: PyGI warnings displayed when started from a terminal window
Keywords:
Status: CLOSED DUPLICATE of bug 1354606
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-12 02:55 UTC by Peter Trenholme
Modified: 2016-10-12 07:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-12 07:00:17 UTC


Attachments (Terms of Use)

Description Peter Trenholme 2016-10-12 02:55:13 UTC
Description of problem: PyGI warnings displayed when started from a terminal window

Version-Release number of selected component (if applicable): 1.5.7 9.fc25

How reproducible: Every time

Steps to Reproduce: $ system-config-printer

Actual results: See below

Expected results: No warning messages


Additional info: Here's what I see (Rawhide on an AMD-8/12GB memory, dual monitor, running GNOME (Xorg)):

$ system-config-printer
/usr/share/system-config-printer/system-config-printer.py:31: PyGIWarning: Polkit was imported without specifying a version first. Use gi.require_version('Polkit', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import Polkit
/usr/share/system-config-printer/system-config-printer.py:35: PyGIWarning: GdkPixbuf was imported without specifying a version first. Use gi.require_version('GdkPixbuf', '2.0') before import to ensure that the right version gets loaded.
  from gi.repository import GdkPixbuf
/usr/share/system-config-printer/system-config-printer.py:37: PyGIWarning: Gdk was imported without specifying a version first. Use gi.require_version('Gdk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gdk
/usr/share/system-config-printer/system-config-printer.py:38: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
/usr/share/system-config-printer/jobviewer.py:28: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  from gi.repository import Notify
/usr/share/system-config-printer/jobviewer.py:55: PyGIWarning: GnomeKeyring was imported without specifying a version first. Use gi.require_version('GnomeKeyring', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GnomeKeyring

Comment 1 Jiri Popelka 2016-10-12 07:00:17 UTC

*** This bug has been marked as a duplicate of bug 1354606 ***


Note You need to log in before you can comment on or make changes to this bug.