Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 138274 - Evolution doesn't handle multipart mime/html email well
Summary: Evolution doesn't handle multipart mime/html email well
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
: 136298 138829 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2004-11-07 04:59 UTC by Colin Charles
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-11 19:06:49 UTC


Attachments (Terms of Use)
fedora-devel-list post that i first noticed this bug in (deleted)
2004-11-07 05:00 UTC, Colin Charles
no flags Details
attachment from bug #136298 which repeats this issue (deleted)
2004-11-07 05:02 UTC, Colin Charles
no flags Details
Another one on f-d-l that doesn't allow me to see it in evo (deleted)
2004-11-07 12:48 UTC, Colin Charles
no flags Details

Description Colin Charles 2004-11-07 04:59:54 UTC
Description of problem: Evolution doesn't display some HTML messages,
that outlook sends out. Multipart messages in MIME format, that is.
This is in Fedora Core 3 (rawhide latest, before the fc4 push so is fc3)


Version-Release number of selected component (if applicable):
evolution-2.0.2-3.ppc
gtkhtml3-3.3.2-3.ppc

How reproducible:
100%

Steps to Reproduce:
1. Click on e-mail message that has multipart mime

Actual results:

Nothing is displayed - seems like emtpy message

Expected results:

Message is displayed

Additional info:
This is really bug #136298, but its HTML spammed so badly, its hard
for anyone to even want to reply. I've attached the output of the
exact email (via viewing the email source) to this

Including gtkhtml versions as it might be caused by Owen patched ones,
as opposed to whats upstream. Probably happens on x86 too, but I dont
have test cases

Comment 1 Colin Charles 2004-11-07 05:00:56 UTC
Created attachment 106255 [details]
fedora-devel-list post that i first noticed this bug in

Comment 2 Colin Charles 2004-11-07 05:02:27 UTC
Created attachment 106256 [details]
attachment from bug #136298 which repeats this issue

Comment 3 Colin Charles 2004-11-07 12:48:39 UTC
Created attachment 106258 [details]
Another one on f-d-l that doesn't allow me to see it in evo

Its completely HTML this time, not even multi-part mime stuff...

Comment 4 Colin Charles 2004-11-08 22:56:09 UTC
*** Bug 136298 has been marked as a duplicate of this bug. ***

Comment 5 Colin Charles 2004-11-09 14:42:36 UTC
Restarting Evolution (taking on jeremy's advice) seems to "fix" the
issue. But it comes and goes... and according to him he's also seen it
on x86, so I'm going to change this to platform All now.

Comment 8 Dave Malcolm 2004-11-28 03:40:27 UTC
*** Bug 138829 has been marked as a duplicate of this bug. ***

Comment 9 Brian Fisher 2005-01-20 21:58:18 UTC
I can confirm this on a FC3 (2.6.10-1.9) x86 with
evolution-2.0.2-3.i836.  Doing an evolution force-shutdown, and
starting evolution again seems to fix it.  But after a while the
problem returns.  

Comment 10 Dave Malcolm 2005-02-23 20:29:32 UTC
Has anyone been seeing this with the evolution-2.1.* and gtkthml 3.5.*
packages?

Comment 11 Elliot Peele 2005-02-23 22:27:04 UTC
This seems to be resolved in evo 2.1.5 and gtkhtml 3.5.6.

I have noticed that I only see this issue when looking at mail in imap folders
with evo 2.0.3 and gtkhtml 3.2.4.

Comment 12 Colin Charles 2005-04-12 22:22:26 UTC
evolution-2.2.1.1-2.i386 and gtkhtml3-3.6.1-1.i386 seem to make this bug
disappear; i.e. I haven't noticed it happening to me in a while.

If I don't see complaints for a little longer, closing RAWHIDE...

Comment 13 Dave Malcolm 2005-08-18 21:14:44 UTC
I've occasionally seen these symptoms in recent packages (e.g. evolution 2.3 and
gtkhtml 3.7), so I'm going to keep this open (but moving from FC4 to FC5), since
it would be good to fix this.

Comment 15 Matthias Clasen 2006-07-06 21:51:08 UTC
Add to FC6Destop tracker

Comment 16 Matthew Barnes 2006-07-11 15:30:55 UTC
This bug has been lingering for quite awhile.

Are these symptoms still present in the latest evolution and gtkhtml packages?

$ rpm -q evolution gtkhtml3
evolution-2.7.3-9
gtkhtml3-3.11.3-1

Comment 17 Matthew Barnes 2006-08-11 19:06:49 UTC
I can't confirm that this behavior is still present in current Rawhide packages.
 Since this bug is approaching its 2nd birthday and has seen little activity
since last year, I'm going to close it and wait for someone to report the
problem again.

evolution-2.7.91-1.test.3
gtkhtml3-3.11.91-1

Comment 18 Matthew Barnes 2006-08-11 19:07:33 UTC
I can't confirm that this behavior is still present in current Rawhide packages.
 Since this bug is approaching its 2nd birthday and has seen little activity
since last year, I'm going to close it and wait for someone to report the
problem again.

evolution-2.7.91-2
gtkhtml3-3.11.91-1


Note You need to log in before you can comment on or make changes to this bug.