Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1382392 - Missing compat-sap-c++-5.so symlink
Summary: Missing compat-sap-c++-5.so symlink
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: compat-sap-c++-5
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Marek Polacek
QA Contact: Michael Petlan
Lenka Špačková
URL:
Whiteboard:
Depends On: 1365181
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-06 14:32 UTC by Marcel Kolaja
Modified: 2016-11-09 17:18 UTC (History)
8 users (show)

Fixed In Version: compat-sap-c++-5-5.3.1-10.el7_2
Doc Type: Bug Fix
Doc Text:
A symbolic link was previously not provided for use by SAP software. Consequently, SAP could not depend on this feature in their software for Red Hat Enterprise Linux, and hence end users could not receive SAP software versions that need this feature. With this update, the symbolic link compat-sap-c++-5.so has been added, which links to the runtime library. As a result, SAP software can use the symbolic rather than explicit library name, and hence SAP will in due course be able to release software relying upon the availability of this mechanism.
Clone Of: 1365181
Environment:
Last Closed: 2016-11-09 17:18:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2690 normal SHIPPED_LIVE compat-sap-c++-5 bug fix update 2016-11-09 22:10:51 UTC

Description Marcel Kolaja 2016-10-06 14:32:20 UTC
This bug has been copied from bug #1365181 and has been proposed
to be backported to 7.2 z-stream (EUS).

Comment 6 Michael Petlan 2016-10-12 16:48:42 UTC
$ ls -l `rpmquery -l compat-sap-c++-5`
-rwxr-xr-x. 1 root root 1582128 Aug 18 11:58 /opt/rh/SAP/lib64/compat-sap-c++-5.3.1.so
lrwxrwxrwx. 1 root root      23 Oct 12 12:43 /opt/rh/SAP/lib64/compat-sap-c++-5.so -> compat-sap-c++-5.3.1.so
...

Checked with compat-sap-c++-5-5.3.1-10.el7_2 on x86_64 and ppc64le. Seems that these are the architectures that will be shipped. If I miss some, please tell me. Thanks.

VERIFIED.

Comment 10 Cathy Giunta 2016-10-27 15:11:44 UTC
But SAP HANA 2.0 / Tokyo is SAP's new release, and we have agreed that new releases and new architectures will be supported on new RHEL releases. In that case, that would be RHEL 7.3.

For HANA, the request has been to support Power LE on the Tokyo release, and that will be done via RHEL 7.3. 

We all realize that this will require that RHEL 7.3 be certified, but it already needs to be certified to support the Power LE new architecture.

We do not add new features via the EUS stream. We add new features via a new release, and are following those rules with this.

If you think I am missing something on this, please let me know, but we never had plans to support the new Tokyo on the EUS release. It always needed to be moving up to the next RHEL release.

Regards,
Cathy

Comment 11 Alexander Hass 2016-10-27 15:25:45 UTC
(In reply to Cathy Giunta from comment #10)
> But SAP HANA 2.0 / Tokyo is SAP's new release, and we have agreed that new
> releases and new architectures will be supported on new RHEL releases. In
> that case, that would be RHEL 7.3.
> 
> For HANA, the request has been to support Power LE on the Tokyo release, and
> that will be done via RHEL 7.3. 
> 
> We all realize that this will require that RHEL 7.3 be certified, but it
> already needs to be certified to support the Power LE new architecture.
> 
> We do not add new features via the EUS stream. We add new features via a new
> release, and are following those rules with this.
> 
> If you think I am missing something on this, please let me know, but we
> never had plans to support the new Tokyo on the EUS release. It always
> needed to be moving up to the next RHEL release.

Cathy, I can confirm that we need this symlink for RHEL 7.2. Please let us not start the whole discussion again.

Thank you,
 Alexander.

Comment 12 Frank Danapfel 2016-10-27 15:27:09 UTC
(In reply to Cathy Giunta from comment #10)
> But SAP HANA 2.0 / Tokyo is SAP's new release, and we have agreed that new
> releases and new architectures will be supported on new RHEL releases. In
> that case, that would be RHEL 7.3.
> 
> For HANA, the request has been to support Power LE on the Tokyo release, and
> that will be done via RHEL 7.3. 
> 
> We all realize that this will require that RHEL 7.3 be certified, but it
> already needs to be certified to support the Power LE new architecture.
> 
> We do not add new features via the EUS stream. We add new features via a new
> release, and are following those rules with this.

This bug is not for adding new features but to provide a fix to an already existing feature.

> If you think I am missing something on this, please let me know, but we
> never had plans to support the new Tokyo on the EUS release. It always
> needed to be moving up to the next RHEL release.
> 
> Regards,
> Cathy

Comment 13 Cathy Giunta 2016-10-27 15:28:12 UTC
Thanks for the clarification on this.

Comment 16 errata-xmlrpc 2016-11-09 17:18:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2690.html


Note You need to log in before you can comment on or make changes to this bug.