Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1381565 - bash completion gives error when invoked after --text-width=-1 option
Summary: bash completion gives error when invoked after --text-width=-1 option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: clufter
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Pokorný [poki]
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On: 1387424
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-04 12:51 UTC by Miroslav Lisik
Modified: 2017-08-01 23:06 UTC (History)
0 users

Fixed In Version: clufter-0.75.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 23:06:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2198 normal SHIPPED_LIVE clufter bug fix and enhancement update 2017-08-01 19:41:26 UTC

Description Miroslav Lisik 2016-10-04 12:51:43 UTC
Description of problem:
Bash completion gives error message when invoked after --text-width=-1

Version-Release number of selected component (if applicable):
clufter-cli-0.59.5-2.el7

How reproducible:
always

Steps to Reproduce:

1. Write command in command line and invoke bash completion by pushing <TAB>:

[root@virt-024 ~]# clufter pcs2pcscmd --batch --quiet --silent --text-width=-1

Actual results:

[root@virt-024 ~]# clufter pcs2pcscmd --batch --quiet --silent --text-width=-1 -bash: declare: cannot use `-f' to make functions


Expected results:

List of choices from bash completion.

Comment 2 Jan Pokorný [poki] 2016-12-12 16:40:50 UTC
The trace is like this:

+ local 'opts_common=--sys --dist -q --quiet --color -d --debug --logfile --loglevel'
+ local 'opts_main=-h --help -H --help-full -l --list --list-dists -v --version -e --ext -s --skip-ext --completion-bash'
+ local 'opts_nonmain=-h --help -H --help-full'
+ local cur fnc i=5
+ true
+ test 5 -eq 0
+ let i-=1
+ cur==
+ [[ = =~ ^-.* ]]
+ case ${cur} in
+ fnc=_clufter_=
+ declare -f _clufter_=
> -bash: declare: cannot use `-f' to make functions

Comment 3 Jan Pokorný [poki] 2017-02-02 15:24:15 UTC
Already fixed in upstream, since v0.59.7.

Comment 6 errata-xmlrpc 2017-08-01 23:06:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2198


Note You need to log in before you can comment on or make changes to this bug.