Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 138 - Viewing RPM files in mc no longer works
Summary: Viewing RPM files in mc no longer works
Keywords:
Status: CLOSED DUPLICATE of bug 13
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-19 21:33 UTC by bbaetz
Modified: 2017-11-16 13:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-11-20 11:33:07 UTC


Attachments (Terms of Use)

Description bbaetz 1998-11-19 21:33:26 UTC
The new version of rpm (rpm-2.5.5-5.2) in RedHat 5.2 breaks
the rpm browsing ability of mc. I think this is because rpm
-qvl no longer has a separate column for the sticky bit, but
instead gives the same output as ls -l. The loss of this
column broke the sed script, which looked for either a - or
a t.

Patch follows:
--- /usr/lib/mc/extfs/rpm.orig  Thu Nov 19 23:25:40 1998
+++ /usr/lib/mc/extfs/rpm       Thu Nov 19 23:29:15 1998
@@ -97,7 +97,7 @@
         echo "$FILEPREF 0 $DATE INFO/CHANGELOG"
     fi

-    rpm -qlvp $1 | sed -e 's/^\(..........\)[-t] /\1 1 /'
+    rpm -qlvp $1 | sed -e 's/^\(..........\) /\1 1 /'
 }

 mcrpmfs_copyout ()

Comment 1 Bill Nottingham 1998-11-20 11:33:59 UTC
*** This bug has been marked as a duplicate of 13 ***

Comment 2 openshift-github-bot 2017-11-16 13:53:28 UTC
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/5f4f758e78c65ff7a193c15314ce70118359a7fd
Update README.md

Fixes issue #138


Note You need to log in before you can comment on or make changes to this bug.