Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1378312 - Occasional screen blanks on T460s with external monitor drm:intel_cpu_fifo_underrun_irq_handler
Summary: Occasional screen blanks on T460s with external monitor drm:intel_cpu_fifo_un...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-22 05:43 UTC by David Gibson
Modified: 2017-04-12 00:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-11 20:02:31 UTC


Attachments (Terms of Use)

Description David Gibson 2016-09-22 05:43:53 UTC
Description of problem:

I usually work with a T460s attached to an ASUS external monitor via DisplayPort.  Occasionally (several times a day) the screen will go blank black for a couple of seconds before returning.

This seems to be associated with the kernel logging this message:

[15017.132508] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

I've also seen these other messages, though I'm not sure if they were associated with a screen blanking event:

[14391.418060] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=184299 end=184300) time 151 us, min 1431, max 1439, scanline start 1429, end 1443
[14391.801776] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=184322 end=184323) time 171 us, min 1431, max 1439, scanline start 1428, end 1444


Version-Release number of selected component (if applicable):

kernel-4.7.3-200.fc24.x86_64
xorg-x11-drv-intel-2.99.917-24.20160712.fc24.x86_64

How reproducible:

Occasional and random

Steps to Reproduce:

Nothing specific.  Just running a MATE desktop on external monitor (laptop internal screen disabled).

Actual results:

Occasional screen blanks.

Expected results:

No screen blanks.


Additional info:

Intel inbuilt graphics in use:

$ lspci -v -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 2233
	Flags: bus master, fast devsel, latency 0, IRQ 126
	Memory at f0000000 (64-bit, non-prefetchable) [size=16M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at e000 [size=64]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915

ASUS 2560x1440 monitor, attached via DisplayPort:

$ edid-decode /sys/class/drm/card0-DP-3/edid
Extracted contents:
header:          00 ff ff ff ff ff ff 00
serial number:   04 69 a3 27 3b 0c 00 00 06 18
version:         01 04
basic params:    a5 3c 22 78 3a
chroma info:     a5 95 aa 54 4f a1 26 0a 50 54
established:     b7 ef 00
standard:        d1 c0 b3 00 95 00 81 80 81 40 81 00 81 c0 71 4f
descriptor 1:    56 5e 00 a0 a0 a0 29 50 30 20 35 00 55 50 21 00 00 1a
descriptor 2:    00 00 00 ff 00 45 32 4c 4d 54 46 30 30 33 31 33 31 0a
descriptor 3:    00 00 00 fd 00 18 4c 18 63 1e 04 11 01 40 f8 38 f0 3c
descriptor 4:    00 00 00 fc 00 41 53 55 53 20 50 42 32 37 38 0a 20 20
extensions:      01
checksum:        22

Manufacturer: ACI Model 27a3 Serial Number 3131
Made week 6 of 2014
EDID version: 1.4
Digital display
8 bits per primary color channel
DisplayPort interface
Maximum image size: 60 cm x 34 cm
Gamma: 2.20
DPMS levels: Off
Supported color formats: RGB 4:4:4, YCrCb 4:4:4, YCrCb 4:2:2
First detailed timing is preferred timing
Established timings supported:
  720x400@70Hz
  640x480@60Hz
  640x480@67Hz
  640x480@75Hz
  800x600@56Hz
  800x600@60Hz
  800x600@72Hz
  800x600@75Hz
  832x624@75Hz
  1024x768@60Hz
  1024x768@70Hz
  1024x768@75Hz
  1280x1024@75Hz
Standard timings supported:
  1920x1080@60Hz
  1680x1050@60Hz
  1440x900@60Hz
  1280x1024@60Hz
  1280x960@60Hz
  1280x800@60Hz
  1280x720@60Hz
  1152x864@75Hz
Detailed mode: Clock 241.500 MHz, 597 mm x 336 mm
               2560 2608 2640 2720 hborder 0
               1440 1443 1448 1481 vborder 0
               +hsync -vsync 
Serial number: E2LMTF003131
Monitor ranges (CVT): 24-76Hz V, 24-99kHz H, max dotclock 300MHz
CVT version 1.1
Max active pixels per line: 2560
Supported aspect ratios: 4:3 16:9 16:10 5:4 15:9
Preferred aspect ratio: 16:9
Supports CVT reduced blanking
Supported display scaling:
    Horizontal shrink
    Horizontal stretch
    Vertical shrink
    Vertical stretch
Preferred vertical refresh: 60 Hz
Monitor name: ASUS
Has 1 extension blocks
Checksum: 0x22 (valid)

CEA extension block
Extension version: 3
30 bytes of CEA data
  Video data block
    VIC 01 640x480@60Hz 
    VIC 02 720x480@60Hz 
    VIC 03 720x480@60Hz 
    VIC 17 720x576@50Hz 
    VIC 18 720x576@50Hz 
    VIC 19 1280x720@50Hz 
    VIC 04 1280x720@60Hz 
    VIC 20 1920x1080i@50Hz 
    VIC 05 1920x1080i@60Hz 
    VIC 31 1920x1080@50Hz 
    VIC 16 1920x1080@60Hz (native)
    VIC 14 1440x480@60Hz 
    VIC 15 1440x480@60Hz 
    VIC 29 1440x576@50Hz 
    VIC 30 1440x576@50Hz 
  Audio data block
    Linear PCM, max channels 1
    Supported sample rates (kHz): 96 48 44.1 32
    Supported sample sizes (bits): 24 20 16
  Speaker allocation data block
  Vendor-specific data block, OUI 000c6e
Basic audio support
Supports YCbCr 4:4:4
Supports YCbCr 4:2:2
1 native detailed modes
Detailed mode: Clock 27.000 MHz, 597 mm x 336 mm
                720  736  798  858 hborder 0
                480  489  495  525 vborder 0
               -hsync -vsync 
Detailed mode: Clock 74.250 MHz, 597 mm x 336 mm
               1280 1390 1430 1650 hborder 0
                720  725  730  750 vborder 0
               +hsync +vsync 
Detailed mode: Clock 74.250 MHz, 597 mm x 336 mm
               1280 1720 1760 1980 hborder 0
                720  725  730  750 vborder 0
               +hsync +vsync 
Detailed mode: Clock 27.000 MHz, 597 mm x 336 mm
                720  732  796  864 hborder 0
                576  581  586  625 vborder 0
               -hsync -vsync 
Checksum: 0x96 (valid)

EDID block does NOT conform to EDID 1.3!
	Detailed block string not properly terminated

Comment 1 Michael Vorburger 2016-11-03 11:30:28 UTC
Related to or duplicate of bug 1355851, bug 1375399, bug 1313662 ?

Comment 2 Hans de Goede 2016-11-03 12:11:40 UTC
There have been a number of skylake gfx regressions in the kernel starting with 4.7, which are fixed in 4.9-rc1 and recently these fixes where backported to 4.8.

Try downloading kernel-core-....rpm and kernel-modules-...rpm for your arch (x86_64) from either:

4.8 with backports:
http://koji.fedoraproject.org/koji/buildinfo?buildID=814638

4.9:
http://koji.fedoraproject.org/koji/buildinfo?buildID=813966

Save both of them in a directory and in this directory do:

sudo rpm -ivh kenrel*.rpm

Note "-ivh", not "-Uvh", so that you keep your old kernel and can always boot back into the old (mostly working) kernel.

Hopefully this will improve things.

Comment 3 Justin M. Forbes 2017-04-11 15:02:17 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-100.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 4 Michael Vorburger 2017-04-11 20:02:31 UTC
I'm not seeing this anymore on Fedora 24 with 4.10.8-100.fc24.x86_64 .. close.

Comment 5 David Gibson 2017-04-12 00:29:30 UTC
Seems to have gone away for me with recent kernels in Fedora 25 as well.


Note You need to log in before you can comment on or make changes to this bug.