Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1376289 - [Docs] All hosts filtered out when memory underutilized parameter left out
Summary: [Docs] All hosts filtered out when memory underutilized parameter left out
Keywords:
Status: CLOSED DUPLICATE of bug 1360696
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-4.0.7
: ---
Assignee: rhev-docs@redhat.com
QA Contact: rhev-docs@redhat.com
URL:
Whiteboard:
Depends On: 1354281 1359767
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-15 04:23 UTC by Tahlia Richardson
Modified: 2017-02-01 03:04 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 03:04:18 UTC
oVirt Team: Docs
Target Upstream Version:


Attachments (Terms of Use)

Description Tahlia Richardson 2016-09-15 04:23:07 UTC
The doc text from the following bug has a documentation request:  https://bugzilla.redhat.com/show_bug.cgi?id=1354281

"Cause:
Setting only one of the thresholds for power saving/evenly distributed memory based balancing (high or low) might lead to unexpected results.

Specific to this bug-
In power saving load balancing the threshold for memory over utilized hosts is set with a value and the threshold for memory under utilized host is undefined thus getting a default value of 0.

Consequence:
All hosts are considered as under utilized hosts and are chosen as sources for migration.
No host is chosen as a destination for migration.

Fix:
1.Documentation fix is needed, add the following limitation:

"Setting only one of the thresholds in memory based balancing (high or low) might lead to unexpected results."

2.When the threshold for memory under utilized host is undefined - it gets a default value of Long.MAX

Result:
1.After the documentation fix users will be guided not to choose only one of the memory thresholds for power saving / evenly distributed load balancing (preventing unwanted behaviour)

2.When in power saving load balancing the threshold for memory over utilized hosts is set with a value and the threshold for memory under utilized host is undefined:
- only over utilized hosts will be selected as sources for migration.
- destination hosts will be hosts that are not over utilized"


Comments in the bug are also quite detailed. 

Should just require adding a note to https://access.redhat.com/documentation/en/red-hat-virtualization/4.0/single/administration-guide/#Configuring_scheduling_policy and maybe the settings table.

Comment 1 Megan Lewis 2016-09-21 00:54:47 UTC
A 3.6 doc text bug also requests the same changes: 
https://bugzilla.redhat.com/show_bug.cgi?id=1359767

This bug is a clone of the bug mentioned above. 

"Cause: 
Setting only one of the thresholds for power saving/evenly distributed memory based balancing (high or low) might lead to unexpected results.

Specific to this bug- 
In power saving load balancing the threshold for memory over utilized hosts is set with a value and the threshold for memory under utilized host is undefined thus getting a default value of 0. 

Consequence: 
All hosts are considered as under utilized hosts and are chosen as sources for migration.
No host is chosen as a destination for migration.

Fix:
1.Documentation fix is needed, add the following limitation:

"Setting only one of the thresholds in memory based balancing (high or low) might lead to unexpected results."

2.When the threshold for memory under utilized host is   undefined - it gets a default value of Long.MAX

Result: 
1.After the documentation fix users will be guided not to choose only one of the memory thresholds for power saving / evenly distributed load balancing (preventing unwanted behaviour)

2.When in power saving load balancing the threshold for memory over utilized hosts is set with a value and the threshold for memory under utilized host is undefined:
- only over utilized hosts will be selected as sources for migration.
- destination hosts will be hosts that are not over utilized"

Comment 2 Lucy Bopf 2017-01-31 08:40:10 UTC
Tahlia, I think the same change is requested in bug 1360696. Can you confirm, and close this one as a duplicate if bug 1360696 covers the same change?

Comment 3 Tahlia Richardson 2017-02-01 03:04:18 UTC
Yes, I think this is same, or at least a similar, request. They both reference the same engineering bug. I'll include the doc text from this bug description as a comment in the other bug, and close this one as a duplicate.

*** This bug has been marked as a duplicate of bug 1360696 ***


Note You need to log in before you can comment on or make changes to this bug.