Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 137522 - [OOo] sends two right and left arrow to OOo apps
Summary: [OOo] sends two right and left arrow to OOo apps
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 137149
TreeView+ depends on / blocked
 
Reported: 2004-10-29 07:59 UTC by Leon Ho
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: openoffice.org-1.1.2-14.6.EL4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-06 02:08:02 UTC


Attachments (Terms of Use)

Description Leon Ho 2004-10-29 07:59:49 UTC
Description of problem:
The current event handling also affects the "right arrows" and "left
arrows". When LE is activiated, press right arrow or left arrow once
will be executed twice. (i.e. in oocalc, press right arrow will jump
from A column to C column)

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. LANG=ja_JP.UTF-8 oocalc
2. ctrl-space
3. press right arrow
  
Actual results:
C column

Expected results:
B column

Additional info:

Comment 1 Leon Ho 2004-11-05 18:36:51 UTC
Note there are no way for input method users to scroll through
properly ATM when LE is activiated (which is the case when they are
editing). 

Comment 2 Havoc Pennington 2004-11-10 16:57:12 UTC
Current estimate is that Dan or Caolan can work on this week of Nov 15
or 22, due to other issues in the queue.


Comment 3 Dan Williams 2004-11-15 14:32:07 UTC
Nov 22 is the probably target date for starting work on this.

Comment 4 Leon Ho 2004-11-30 01:31:03 UTC
This is fixed along with bug 136990. It works quite well in
1.1.2-14.6.EL4 now.

Comment 5 Dan Williams 2004-11-30 02:28:49 UTC
Ok, can I close this one then, or is more work required?

Comment 6 Lawrence Lim 2004-11-30 05:06:48 UTC
Tested with all supported CJK locale, ja, ko, cn and tw. The arrow
keys are working fine in the oocalc application. Will have a look at
indic locale shortly.


Thanks.

Comment 7 Lawrence Lim 2004-12-06 02:08:02 UTC
Confirm fixed in openoffice.org-1.1.2-14.6.EL4. Tested with all CJK
and UnitLE.

Thanks.

Comment 8 Akira TAGOH 2004-12-10 17:14:03 UTC
Tested with 1.1.2-17.6.EL4. it also works fine on all CJK and 5 Indic
locales.


Note You need to log in before you can comment on or make changes to this bug.