Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1373321 - Can't deploy an overcloud because selinux blocks neutron_t to access unlabeled_t files (nsfs)
Summary: Can't deploy an overcloud because selinux blocks neutron_t to access unlabele...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.3
Hardware: All
OS: Linux
unspecified
high
Target Milestone: pre-dev-freeze
: 7.4
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1359216 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-06 01:58 UTC by David Hill
Modified: 2017-08-01 15:15 UTC (History)
9 users (show)

Fixed In Version: selinux-policy-3.13.1-150.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 15:15:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1861 normal SHIPPED_LIVE selinux-policy bug fix update 2017-08-01 17:50:24 UTC

Description David Hill 2016-09-06 01:58:12 UTC
Description of problem:
Can't deploy an overcloud because selinux blocks neutron_t to access unlabeled_t files (nsfs)

require {
	type unlabeled_t;
	type neutron_t;
	class file { read open };
}

#============= neutron_t ==============
allow neutron_t unlabeled_t:file { read open };


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Generate images on RHEL 7.2
2. Install undercloud
3. Introspection works fine 
4. openstack overcloud deploy times out

Actual results:
Fails to PXE boot

Expected results:
Should be allowed.

Additional info:

Comment 1 David Hill 2016-09-06 03:01:21 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1359216 is the same issue.

Comment 2 Lon Hohberger 2017-02-17 15:35:41 UTC
*** Bug 1359216 has been marked as a duplicate of this bug. ***

Comment 3 Lon Hohberger 2017-02-17 15:37:27 UTC
Sounds like a configuration / labeling issue:

1) Nothing should be unlabeled_t
2) The installer should be setting contexts if necessary

Comment 4 Lon Hohberger 2017-02-20 14:27:42 UTC
https://bugzilla.redhat.com/attachment.cgi?id=1090403&action=diff#a/policy-f22-base.patch.orig_sec2

RHEL base policy is missing that patch from upstream.

...

+fs_use_task nsfs gen_context(system_u:object_r:fs_t,s0);

...

Comment 9 errata-xmlrpc 2017-08-01 15:15:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1861


Note You need to log in before you can comment on or make changes to this bug.