Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 137275 - can't eject cdrom after http install completes
Summary: can't eject cdrom after http install completes
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2004-10-27 06:45 UTC by Ellen Shull
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-14 19:35:14 UTC


Attachments (Terms of Use)

Description Ellen Shull 2004-10-27 06:45:18 UTC
Description of problem: 
Did a test install of FC3-rc1 in text mode, and rc2 in graphical 
mode.  Used the rescue cd and did an http install both times.  When 
install was complete, in both cases it helpfully advised me to remove 
all installation media before rebooting, but the CD-ROM drive was 
locked and wouldn't eject. 
 
Version-Release number of selected component (if applicable): 
anaconda-10.1.0.0-1 (that's what it is installed in rc2, so I'm 
assuming that's what the installer was built with) 
 
How reproducible: 
Both times I tried it. 
 
Steps to Reproduce: 
0.  Boot rescue disc, do 'linux' or 'linux text' to start install 
1.  Install from http 
2.  Try to eject disc when advised to do so 
3.  ??? 
4.  Don't profit. 
   
Actual results: 
ignores presses of eject button on drive 
 
Expected results: 
Drive ejects disc 
 
Additional info: 
I'm guessing it just needs to unmount whatever it's got mounted on 
the disc first... 
 
Not sure if the http install is a necessary part.  Maybe it messes up 
on all non-disc-based installs this way, since it hasn't had to 
unmount stuff to allow for swapping of discs?

Comment 1 Jeremy Katz 2004-10-27 15:57:45 UTC
This is because we're using the second stage off of the CD.  Need to
reword that a bit, but can't do that while string frozen.  Targetting FC4.

Comment 6 Chris Lumens 2007-03-14 19:35:14 UTC
Fixed string to not tell you to eject the CD, since there's no way we can really
tell that you booted off the rescue disc.  We can't fix this to unmount the CD
since the second stage is loopback mounted off the CD.


Note You need to log in before you can comment on or make changes to this bug.