Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1371485 - [RFE]: AFR events
Summary: [RFE]: AFR events
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1361082 1373743
TreeView+ depends on / blocked
 
Reported: 2016-08-30 10:11 UTC by Ravishankar N
Modified: 2017-03-06 17:23 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1373743 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:23:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2016-08-30 10:11:20 UTC
Description of problem:
This RFE is to track the changes required in the AFR component to generate the events to be consumed by the eventing framework.

Comment 1 Worker Ant 2016-08-30 10:13:44 UTC
REVIEW: http://review.gluster.org/15349 (afr: add replication events) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 2 Worker Ant 2016-09-01 11:52:24 UTC
REVIEW: http://review.gluster.org/15349 (afr: add replication events) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 3 Worker Ant 2016-09-01 12:28:12 UTC
REVIEW: http://review.gluster.org/15349 (afr: add replication events) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 4 Worker Ant 2016-09-03 13:23:54 UTC
REVIEW: http://review.gluster.org/15349 (afr: add replication events) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 5 Worker Ant 2016-09-06 20:21:11 UTC
REVIEW: http://review.gluster.org/15349 (afr: add replication events) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 6 Worker Ant 2016-09-06 20:28:51 UTC
REVIEW: http://review.gluster.org/15349 (afr: add replication events) posted (#6) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 7 Worker Ant 2016-09-07 06:05:41 UTC
COMMIT: http://review.gluster.org/15349 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 86e312d872a957afff1e508f13f62c4102dba22d
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Thu Sep 1 13:01:22 2016 +0530

    afr: add replication events
    
    Added the following events for the eventing framework:
    
      "EVENT_AFR_QUORUM_MET", --> Sent when quorum is met.
      "EVENT_AFR_QUORUM_FAIL" -->Sent when quorum is lost.
      "EVENT_AFR_SUBVOL_UP" -->Sent when afr witnesses the first up subvolume.
      "EVENT_AFR_SUBVOLS_DOWN"-->Sent when all children of an afr subvol are down.
      "EVENT_AFR_SPLIT_BRAIN" -->Sent when self-heal detects split-brain in heal
    path (not read/write path).
    
    Change-Id: I937c61ca1ce78b5922ade73c7bfa3051df59c513
    BUG: 1371485
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/15349
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 8 Shyamsundar 2017-03-06 17:23:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.