Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1371427 - [DELL-7.3 BUG] systemd show Dependency fail for Hyper-V FCOPY daemon,KVP daemon, VSS daemon
Summary: [DELL-7.3 BUG] systemd show Dependency fail for Hyper-V FCOPY daemon,KVP daem...
Keywords:
Status: CLOSED DUPLICATE of bug 1367240
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: hyperv-daemons
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 7.3
Assignee: Vitaly Kuznetsov
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-30 08:14 UTC by Purnendu Bhushan
Modified: 2016-09-02 16:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-02 11:03:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/log/messages showing issue (deleted)
2016-08-30 08:14 UTC, Purnendu Bhushan
no flags Details

Description Purnendu Bhushan 2016-08-30 08:14:36 UTC
Created attachment 1195728 [details]
/var/log/messages showing issue

Description of problem:
After successful installation and boot into RHEL-7.3 alpha on C6320 in BIOS mode, /var/log/messages shows the following messages:
"systemd: Dependency failed for Hyper-V FCOPY daemon.
 systemd: Job hypervfcopyd.service/start failed with result 'dependency'.
 systemd: Job sys-devices-virtual-misc-vmbus\x21hv_fcopy.device/start failed with result 'timeout'.
 systemd: Job sys-devices-virtual-misc-vmbus\x21hv_kvp.device/start timed out.
 systemd: Timed out waiting for device sys-devices-virtual-misc-vmbus\x21hv_kvp.device.
 systemd: Dependency failed for Hyper-V KVP daemon.
 systemd: Job hypervkvpd.service/start failed with result 'dependency'.
 systemd: Job sys-devices-virtual-misc-vmbus\x21hv_kvp.device/start failed with result 'timeout'.
 systemd: Job sys-devices-virtual-misc-vmbus\x21hv_vss.device/start timed out.
 systemd: Timed out waiting for device sys-devices-virtual-misc-vmbus\x21hv_vss.device.
 systemd: Dependency failed for Hyper-V VSS daemon.
 systemd: Job hypervvssd.service/start failed with result 'dependency'.
 systemd: Job sys-devices-virtual-misc-vmbus\x21hv_vss.device/start failed with result 'timeout'. "


Version-Release number of selected component (if applicable):
systemd-219-26.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.install RHEL 7.3 beta on x86_64
2.boot into OS and check for /var/log/messages


Actual results:
 /var/log/messages show this dependency failure 

Expected results:
no such failure should occur

Additional info:

Comment 2 Lukáš Nykrýn 2016-08-30 14:53:46 UTC
Isn't this duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1367240

Comment 3 Karl Hastings 2016-08-30 20:28:47 UTC
Purnendu,

Can you verify you are using hyperv-daemons-0-0.29.20160216git.el7 or later for your test? 

Please note that the Beta is available on the partner FTP site and you should probably be using that to verify/test with.

Comment 4 Yaju Cao 2016-08-31 03:11:49 UTC
It is a duplicate of Bug 1367240, but the fixed build hyperv-daemons-0-0.29.20160216git.el7 is not included in Beta, so this issue can still be seen.

Comment 5 Purnendu Bhushan 2016-09-01 11:21:35 UTC
karl, 
after testing with rhel 7.3 beta and snapshort-1 i can still find the issue

Comment 6 Vitaly Kuznetsov 2016-09-01 13:07:12 UTC
(In reply to Purnendu Bhushan from comment #5)
> karl, 
> after testing with rhel 7.3 beta and snapshort-1 i can still find the issue

What's the hyperv-daemons package version? I still think we're just seeing a https://bugzilla.redhat.com/show_bug.cgi?id=1367240 duplicate here.

Comment 7 Sujith 2016-09-02 05:20:23 UTC
(In reply to Karl Hastings from comment #3)
> Purnendu,
> 
> Can you verify you are using hyperv-daemons-0-0.29.20160216git.el7 or later
> for your test? 
> 
> Please note that the Beta is available on the partner FTP site and you
> should probably be using that to verify/test with.

(In reply to Vitaly Kuznetsov from comment #6)
> What's the hyperv-daemons package version? I still think we're just seeing a
> https://bugzilla.redhat.com/show_bug.cgi?id=1367240 duplicate here.

Hi Karl,
RHEL-7.3-Snapshot-1 has hyperv-daemons-0-0.28.20160216git.el7
Which build will hyperv-daemons-0-0.29.20160216git.el7 be made available?

-
Sujith

Comment 8 Karl Hastings 2016-09-02 05:43:42 UTC
Sujith,

I'm looking into this currently.  From my understanding it should have been in Snap 1.

Comment 9 Vitaly Kuznetsov 2016-09-02 11:03:26 UTC
Mystery solved, the build was not in the errata. Should be solved now.

*** This bug has been marked as a duplicate of bug 1367240 ***

Comment 10 Sujith 2016-09-02 12:11:13 UTC
(In reply to Vitaly Kuznetsov from comment #9)
> Mystery solved, the build was not in the errata. Should be solved now.
> 
> *** This bug has been marked as a duplicate of bug 1367240 ***

So the fix will be released in the next build?

Comment 11 Karl Hastings 2016-09-02 16:38:39 UTC
Sujith,

The fix should be in Snap 3.  If you would like I can get you a copy of the hyperv-daemons-0-0.29.20160216git.el7 rpm earlier for your testing.


Note You need to log in before you can comment on or make changes to this bug.