Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 137134 - firefox missing Language Packs
Summary: firefox missing Language Packs
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
: 127922 139196 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2004-10-25 23:06 UTC by Warren Togami
Modified: 2007-11-30 22:10 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-30 22:10:48 UTC


Attachments (Terms of Use)
output of "sh -x /usr/bin/firefox -debug" (deleted)
2005-05-22 21:43 UTC, Ronny Buchmann
no flags Details

Description Warren Togami 2004-10-25 23:06:27 UTC
Description of problem:
firefox and thunderbird shipped in FC3 are missing language packs. 
This should be a RHEL4RCBlocker.  While the i18n translation team is
not responsible for these translations, it would help if they could
assist in locating the language packs for each language and post them
in this report.  The RH mozilla maintainers will then attempt to
import these language packs into the packages.

Version-Release number of selected component (if applicable):
firefox-0.10.1-1.0PR1.20
thunderbird-0.8.0-9

Comment 1 Leon Ho 2004-10-26 00:11:20 UTC
*** Bug 136999 has been marked as a duplicate of this bug. ***

Comment 2 Leon Ho 2004-10-26 00:12:09 UTC
As I mentioned in the other bug yesterday:
http://www.mozilla.org/projects/l10n/mlp_otherproj.html#firefox

From upstream, not many languages are translated into 1.0PR ATM,
however we do need to support localization to our default languages.

Need Chris' input on how possible to use 0.9.X packs.


Comment 3 Leon Ho 2004-10-26 00:31:27 UTC
http://www.mozilla.org/projects/l10n/mlp_otherproj.html#thunderbird

Number of the thunderbird translations for 0.8 is not that great either.

Comment 5 Michelle Kim 2004-10-26 05:21:40 UTC
Hi,

The Korean Mozilla Project website is: http://www.mozilla.or.kr/

And also 
* Korean Mozilla Website: http://www.mozilla.or.kr/products/mozilla1.x/
* Korean thunderbird website:
http://www.mozilla.or.kr/products/thunderbird/
* Korean firefox website: http://www.mozilla.or.kr/products/firefox/

If you want to download the Korean lang packs for each application, 
please go to:

* Korean version of Mozilla: 

http://www.mozilla.or.kr/download/?http://www.mozilla.or.kr/download//mozilla-i686-pc-linux-gnu-1.7.2-koKR-installer.tar.gz

* Korean version of thunderbird:

http://www.mozilla.or.kr/download/?http://www.mozilla.or.kr/download//thunderbird-0.7.3-i686-linux-gtk2+xft-koKR.tar.gz

* Korean version of firefox:

http://www.mozilla.or.kr/download/?http://www.mozilla.or.kr/download//firefox-0.9.3-i686-linux-gtk2+xft-installer-koKR.tar.gz

Hope this helps! (If it does, 5 dollars please :)

Michelle 



Comment 6 Jean-Paul Aubry 2004-10-26 05:28:56 UTC
Hi there,

It looks like the French version are at the following
address:http://frenchmozilla.sourceforge.net/
Regards,
JP

Comment 7 Warren Togami 2004-10-27 11:25:08 UTC
Mozilla Project's lack of a centralized translation project makes it a
huge burden for us package distributors to maintain.  Too often with
new versions language packs disappear as the package maintainers are
not able to quickly find all language packs, or the language packs are
not maintained satisfactorily to be included (since no translation is
better than poor translation).

After RHEL4 we must make it a priority to help organize an upstream
centralized Mozilla translation project, or this bad situation with
language packs will continue forever.

For RHEL4 the best we can do is import only whatever languages are
ready, and hopefully fix it later in RHEL4 U1.

Comment 10 Jens Petersen 2004-11-11 04:29:31 UTC
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-0.11-l10n/linux-xpi/

ja-JP.xpi works for me anyway (with "firefox -UILocale ja[_JP[.UTF-8]]"
as reported in bug 138339).

It would good if firefox would fallback to English menus when it
is run with "firefox -UILocale $LANG" for a locale without a lang
pack installed btw.

Comment 14 Enrico Scholz 2004-11-13 03:51:57 UTC
fwiw, I package my language packs like in

http://www-user.tu-chemnitz.de/~ensc/fedora/firefox-de-1.0-2.src.rpm 
(360kB)
http://www-user.tu-chemnitz.de/~ensc/fedora/firefox-de.spec
http://www-user.tu-chemnitz.de/~ensc/fedora/thunderbird-de.spec


I am not sure whether the Xvfb trick is still needed; perhaps a better
method exists in the meantime. I know that the firefox URL does not
work, it is from a nightly build.



A base-concept is the

| pref("intl.locale.matchOS", true);

which enables the standard Linux i18n through the $LANG variable. It
is said that it increases the startup-time of the browser but I have
not made any measurements on this.

When there is not exist such a performance impact, it should replace
the current /usr/lib/firefox-1.0/defaults/pref/firefox-l10n.js which
contains

| pref("general.useragent.locale", "en-US");





Comment 15 Den 2004-11-13 14:21:20 UTC
I package my language packs like in

http://mozilla.ru/unghost/firefox/1.0/

May be this way is better? 

Comment 16 Christopher Aillon 2004-11-14 20:26:30 UTC
*** Bug 139196 has been marked as a duplicate of this bug. ***

Comment 17 Chester Cheng 2004-11-16 04:14:57 UTC
Hi All,

I just happened to find this FTP site that contains (maybe) all
versions of Firefox 1.0:

ftp://ftp.scarlet.be/pub/mozilla.org/firefox/nightly/latest-0.11-l10n/

I downloaded and installed the Traditional Chinese one and found it
works well (time stamp is 15 Nov, 2004). It seems to be the right
version we're looking for:

ftp://ftp.scarlet.be/pub/mozilla.org/firefox/nightly/latest-0.11-l10n/firefox-1.0.zh-TW.linux-i686.installer.tar.gz

or 

ftp://ftp.scarlet.be/pub/mozilla.org/firefox/nightly/latest-0.11-l10n/firefox-1.0.zh-TW.linux-i686.tar.gz


However, on the TC Firefox website (http://moztw.org/) it doesn't
mention this release.

Comment 18 Chester Cheng 2004-11-16 04:25:35 UTC
Thunderbird 0.9 Traditional Chinese version can be found at:
http://moztw.org/dls/tb/thunderbird-0.9-linux-gtk2xft-zhTW.tar.bz2

Comment 20 David Barzilay 2004-11-17 04:26:36 UTC
Hi Folks!
I just installed both pt_BR packages in my machine, and they look
great. Please follow these steps to download the Brazilian Portuguese
packs:

Firefox
go to http://www.mozilla.org.br/saite/
click on "Baixe já!" on the horizontal upper menu
click on the Firefox logo
click on the ligh blue link "Baixe já!"

Thunderbird
go to http://www.mozilla.org.br/saite/
click on "Baixe já!" on the horizontal upper menu
click on the Thunderbird logo
click on the ligh blue link "Baixe já!"

Cheers,
Dave

Comment 23 Christopher Blizzard 2004-11-30 21:38:09 UTC
I picked up all of the languages that were available upstream.  These
include:

ast-ES.jar
ca-AD.jar
cs-CZ.jar
da-DK.jar
de-DE.jar
el-GR.jar
en-GB.jar
es-AR.jar
fi-FI.jar
fr-FR.jar
he-IL.jar
hu-HU.jar
it-IT.jar
ja-JP.jar
ja-JPM.jar
ko-KR.jar
nb-NO.jar
pl-PL.jar
pt-BR.jar
ro-RO.jar
ru-RU.jar
sl-SI.jar
sv-SE.jar
zh-CN.jar
zh-TW.jar

There should be more coming upstream some time soon as issues with
individual packs are ironed out.


Comment 25 Lawrence Lim 2004-12-06 08:10:59 UTC
Thanks for the lang packs in firefox. Been through all the 14
supported locale for RHEL4 and noticed that 6 of the supported locale
does not have a lang pack. 

Chris,
Is there any plan for these lang pack to be included for RHEL4?

1) es_ES
2) bn_IN
3) gu_IN
4) hi_IN
5) pa_IN
6) ta_IN

Thanks.

Comment 26 Jatin Nansi 2004-12-06 11:15:38 UTC
AFAIR, Firefox has not yet been translated to any of the 5 supported
indic languages.

Comment 27 Lawrence Lim 2004-12-16 04:17:09 UTC
In firefox-1.0-12.EL4, the following Language Packs are not available.

1) es_ES
2) bn_IN
3) gu_IN
4) hi_IN
5) pa_IN
6) ta_IN



Comment 31 Sukhjinder Sidhu 2004-12-27 13:46:19 UTC
Any ideas when a Punjabi version will be available on the main website?

Comment 32 Warren Togami 2004-12-27 23:31:40 UTC
Are the indic languages being translated?  We need to know about
translation projects or it will not happen.

Comment 33 Sukhjinder Sidhu 2004-12-27 23:33:51 UTC
Well the Punjabi version has already been translated (1.0 final). 
Although it's not on the main web site.  See:
http://www.sourceforge.net/projects/punlinux/

Comment 34 Amanpreet Singh Alam 2004-12-29 02:05:01 UTC
punjabi is also available to main website of thunderbird also, check 
http://www.mozilla.org/products/thunderbird/all.html

Comment 36 Ronny Buchmann 2005-04-10 16:45:50 UTC
latest firefox (1.0.2-3) and thunderbird (1.0.2-1) in rawhide don't have
language packs again

Comment 37 Kyrre Ness Sjøbæk 2005-04-30 11:56:46 UTC
confirmed.
firefox-1.0.3-2 have only english on this norwegian bokmål system.

Is there a huge problem that it has not been translated to *all* supported
languages yet? Isn't it better to push it with support for 90% of the languages,
and add the rest as they come?

reopening? It says "closed rawhide" and it is not fixed, but it is out of my
reach to reopen it...

Comment 38 Christopher Aillon 2005-05-03 20:31:17 UTC
*** Bug 127922 has been marked as a duplicate of this bug. ***

Comment 39 Kyrre Ness Sjøbæk 2005-05-11 20:24:33 UTC
Its still here on FC4-test3.

Comment 40 Jens Petersen 2005-05-16 05:59:29 UTC
Is there anything the i18n team can do to help with this?

Comment 41 Warren Togami 2005-05-16 06:44:18 UTC
caillon said he is attempting to fix this and other FC4Blocker issues before the
final freeze.  This issue may be complicated by the fact that the last time we
added the language packs, firefox would mysteriously fail to start in new
profiles.  If this happens again, it would be even more of a blocker for FC4
than missing language packs.

Comment 42 Ankit Patel 2005-05-16 07:25:53 UTC
From here,
you can find the activities of firefox/thunderbird localisation:-

http://wiki.mozilla.org/L10n:Firefox_1.0.x_Status
http://wiki.mozilla.org/L10n:Firefox_1.1.x_Status
http://wiki.mozilla.org/L10n:Thunderbird_1.1.x_Status

It says that indic languages are also going to be included...

Comment 43 Christopher Aillon 2005-05-21 16:29:48 UTC
http://people.redhat.com/caillon/RPMS/rawhide/mozilla.org/firefox-1.0.4-2.2.i386.rpm
for anyone that wishes to test.  I will note that Firefox is likely to get fixed
for FC4 final, however Thunderbird is not (I will attempt it as an update). 
Thus, I recommend we split this bug up into two.

Comment 44 Kyrre Ness Sjøbæk 2005-05-22 14:56:08 UTC
I can confirm that my firefox is now in Norwegian :)

Comment 45 Ronny Buchmann 2005-05-22 21:41:22 UTC
Doesn't work for me (UI is english), and interestingly google is in zh_TW
I've also tried setting LANG to nb_NO with no effect.

Comment 46 Ronny Buchmann 2005-05-22 21:43:17 UTC
Created attachment 114693 [details]
output of "sh -x /usr/bin/firefox -debug"

Comment 47 Warren Togami 2005-05-22 21:53:31 UTC
http://people.redhat.com/wtogami/temp/firefox/
I copied i386, x86_64, and ppc binaries here along with SRPM for testing.


Comment 48 Lawrence Lim 2005-05-22 23:35:53 UTC
In response to Comment #43, created bug 158490 to track the inclusion of LANG
pack into thunderbird as FC4 update. Updating the summary of current bug as well.

Comment 49 Jens Petersen 2005-05-23 01:26:08 UTC
firefox-1.0.4-2.2.i386 is working very well for me in Japanese. :)
I tested both for an existing user and a new user.

Comment 53 Jens Petersen 2005-05-23 08:45:24 UTC
Also for languages I tried, the search box always seems to default
to Argentina Google!  Also there are an enormous number of search site
alternatives now: well far to many - looks like those of all langpacks
may be appearing...

Comment 54 Warren Togami 2005-05-24 02:11:03 UTC
I too went to Argentina Google while in en_US.UTF-8.  This is a bit wacky.

Talked to Sopwith about this today.  It doesn't sound like he would allow this
in the distribution at this point because it doesn't solve an
installation/upgrade problem.  He didn't exactly say no either.  But at this
point I would say "wait for an upgrade" because the software is just misbehaving
too much.

Comment 55 Warren Togami 2005-05-24 04:43:23 UTC
http://people.redhat.com/wtogami/temp/firefox/
Newer binaries that are supposed to fix the above proble.  Please test!


Comment 56 Jens Petersen 2005-05-24 07:49:21 UTC
Warren, firefox-1.0.4-3 still takes me to Argentinian Google.

Comment 57 Lawrence Lim 2005-05-24 08:34:51 UTC
Typing google.com in the Navigation Toolbar works fine. Brings me to the correct
google depending on the locale firefox was started.

eg. LANG=ja_JP.UTF-8 firefox will bring up google japan

Noticed that with firefox-1.0.4-2/3, the issue I encounter is:
(Done by typing enter at the google box at the top right hand corner, navigation
menu)

zh_CN defaults to zh_TW (Not OK)
zh_TW defaults to zh_TW (OK)
ja_JP defaults to zh_TW (Not OK)
ko_KR defaults to zh_TW (Not OK)
en_US defaults to zh_TW (Not OK)

Seems to always default to zh_TW which is my desktop locale. I tried to create a
new profile as well.

Comment 58 Warren Togami 2005-05-24 10:33:43 UTC
I know, I said during the meeting that the build after -3 would remove
non-English search plugins.


Comment 59 Ronny Buchmann 2005-05-24 20:27:49 UTC
1.0.4-3 works for me, too

Isn't it possible to have the search plugins language dependent?

Comment 60 Warren Togami 2005-05-24 20:31:12 UTC
For now no, it isn't a priority to make it ideal.  In the long term yes.


Comment 61 Ronny Buchmann 2005-05-24 20:54:06 UTC
Can the package be split into sub packages? It's really huge now.
This would fix the search plugins too, it seems.

Comment 62 Christopher Aillon 2005-05-24 21:28:47 UTC
There is no way to make the search plugins dependent, even on the mozilla trunk.
 And it could be conceivable that I want to have multiple versions installed for
a locale...  Tricky issue that yeah needs to get resolved, but not right now.

The package won't be split up for fc4 -- that might happen in fc5.  the
localizations are huge, I agree, but it could be much worse in size.

Comment 63 Christopher Aillon 2005-05-24 21:52:51 UTC
fwiw, new files 1.0.4-3.1 at
http://people.redhat.com/caillon/RPMS/rawhide/mozilla.org/ for testing

Comment 64 Enrico Scholz 2005-05-24 22:22:32 UTC
When separate -langpack subpackages are not possible; can appropriate '%lang()'
attributes be set for them, please?

Comment 66 Jens Petersen 2005-05-25 02:40:05 UTC
1.0.4-3.1 looks good to me too :)

[now if only I didn't need to scroll the above line off the screen
 and back into view to see it render properly (bug 149991):]

Comment 67 Jens Petersen 2005-05-27 11:39:19 UTC
1.0.4-4 looks good to me too. :)

Comment 68 Warren Togami 2005-05-30 22:10:48 UTC
Closing this bug.  Please open a new bug for additional missing languages.


Note You need to log in before you can comment on or make changes to this bug.