Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 137 - RPM reports multiple copies of the same package are installed
Summary: RPM reports multiple copies of the same package are installed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-19 21:10 UTC by bbaetz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-05 16:15:52 UTC


Attachments (Terms of Use)

Description bbaetz 1998-11-19 21:10:30 UTC
When upgrading to 5.2 from downloaded rpms, netkit-base
cannot be upgraded, just giving the error message:

error: netkit-base-0.10-13.i386.rpm cannot be installed

This led to multiple versions of netkit-base being
installed, which I could not delete. I tried to install a
5.0 netkit-base rpm with --force to try and get it to
replace the other two, but this didn't work. Now I have:

~# rpm -q netkit-base
netkit-base-0.10-10
netkit-base-0.10-5
netkit-base-0.10-13

~# rpm -e netkit-base
"netkit-base" specifies multiple packages

~# rpm -e netkit-base-0.10-10
~# rpm -e netkit-base-0.10-5
~# rpm -e netkit-base-0.10-13
~# rpm -q netkit-base
netkit-base-0.10-10
netkit-base-0.10-5
netkit-base-0.10-13

The files actually installed from the package correspond to
the 0.10-13 version, but:

~# rpm -Uvh --force netkit-base-0.10-10.rpm
netkit-base
##################################################
error: netkit-base-0.10-10.i386.rpm cannot be installed

However, despite this error message, the installed files now
correspond to the 0.10-10 version.

This was all done with all three netkit-base rpms in the
current directory.

The error doesn't appear to affect the working of ping nad
inetd, containted in the package.

Comment 1 Aleksey Nogin 1998-11-21 03:35:59 UTC
Is it possible it is the same triggers problem as in bug report #103?

Comment 2 bbaetz 1998-11-21 04:17:59 UTC
Yes. Thank you, doing rpm -e --notriggers <packagename> deleted the unwanted packages.
However, I had to do rpm --rebuilddb, or else rpm -q --showtriggers netkit-base gave two lines of error: could not read database record.
I looked for a bug report for RPM before I put this one in, but I only looked under 5.2.

Comment 3 Jeff Johnson 1998-12-05 16:15:59 UTC
Upgrade your rpm to the latest available (2.5.5-5.2 as of this
writing) or you may experience trigger related problems again.

It is possible to have multiple versions of packages installed if
you use --force.

Normally each package can be deinstalled by doing
	rpm -q name
	rpm -e name-version-release
for each package displayed. However, because of a bug in the
trigger code, rpm (2.5 <= version < 2.5.2) needs the "--notriggers"
option to successfully remove certain packages:
	samba, ypbind, bootparamd, Xaw3d-devel, portmap, ypserv

Any/every time that rpm segfaults you should also do
	rpm --rebuilddb

Comment 4 bbaetz 1998-12-06 02:35:59 UTC
~$ rpm -q rpm
rpm-2.5.5-5.2

rpm was the first package I upgraded when trying to go from 5.1 to
5.2.
I was trying to remove netkit-base, which isn't one of the packages
you mentioned, and rpm didn't segfault, it just didn't work. Doing a
--rebuilddb didn't help when the multilple packages were installed.

It _started off_ with two pacakges - I only used force after that. I
had a similar problem about six months ago where sowngrading to an
uninstalled, earlier version, with --force (NOT --oldpackage), and
then upgrading to the wanted version fixed the problem.

As a side issue, and probably a separate bug, rpm -q --triggers foo
gives --triggers: unknown option, whether or not the package foo is
installed or not.

On the other hand, it's fixed now...


Note You need to log in before you can comment on or make changes to this bug.