Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 136990 - Backspace fails after IIIMF input
Summary: Backspace fails after IIIMF input
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC3Update 137149
TreeView+ depends on / blocked
 
Reported: 2004-10-24 21:55 UTC by Warren Togami
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: openoffice.org-1.1.2-14.6.EL4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-06 01:58:56 UTC


Attachments (Terms of Use)
proposed patch (deleted)
2004-11-18 09:11 UTC, Akira TAGOH
no flags Details | Diff

Description Warren Togami 2004-10-24 21:55:56 UTC
Description of problem:
After you input anything using IIIMF then hit ENTER to commit,
Backspace fails to delete anything.  If you hit ENTER again to
newline, then Backspace is able to delete.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-10

How reproducible:
Always

Steps to Reproduce:
1. Enable cannaLE for Japanese.
2. Type "nihongo" then ENTER to commit.
3. Hit Backspace and see failure.
4. Hit ENTER for newline.
5. Hit Backspace a few times, now it works.

Comment 1 Warren Togami 2004-10-25 14:49:33 UTC
dcbw said this probably will require fixes to openoffice.org, IIIMF,
or both.

Comment 4 Leon Ho 2004-10-28 13:43:43 UTC
Pretty important to non-english IM users as it will make them unable
to do text editing properly. Dan, any pointers on where trigger this
bug in -10?

Comment 5 Havoc Pennington 2004-11-10 16:57:15 UTC
Current estimate is that Dan or Caolan can work on this week of Nov 15
or 22, due to other issues in the queue.


Comment 6 Dan Williams 2004-11-15 14:32:04 UTC
Nov 22 is the probably target date for starting work on this.

Comment 7 Akira TAGOH 2004-11-18 09:11:47 UTC
Created attachment 106937 [details]
proposed patch

I've looked into OOo and I see that this problem happened due to the backspace
key event is always dropped. an attached patch fixes this problem.  Also,
Bug#137522 was caused since OOo swallows the cursor keys events when it's even
a filtered key event. this patch can fixes that problem too by ignoring the
filtered key events.

Comment 8 Dan Williams 2004-11-22 17:24:30 UTC
Ok, looking into this bug now.

Comment 9 Dan Williams 2004-11-24 23:00:48 UTC
Ok, found the problem.  It was both a Canna LE problem (diagnosed by
Akira Tagoh), which will be fixed with im-sdk >= 12.1-10 (specific
patch is leif-canna-fix-caret-position-r2070-136651.patch) and an OOo
problem.  The OOo side of things should be fixed in 1.1.2-14 and later.

Comment 10 Akira TAGOH 2004-11-25 07:14:00 UTC
Err, it's for Bug#136651 (Canna LE side) and Bug#140716 (OOo side).
but not related this Backspace issue, though :)

Comment 11 Leon Ho 2004-11-30 01:30:02 UTC
It works quite well in 1.1.2-14.6.EL4 now.

Comment 12 Dan Williams 2004-11-30 02:28:32 UTC
Ok, can I close this one then, or is more work required?

Comment 13 Lawrence Lim 2004-11-30 04:53:21 UTC
Tested with CJK LE, CannaLE, hangulLE, xcin and chinput, backspace
problem has been removed. Will try with UnitLE for the indic locale
and update the bug shortly.

Comment 14 Lawrence Lim 2004-12-06 01:58:56 UTC
Confirm fixed in openoffice.org-1.1.2-14.6.EL4. Tested with all CJK LE
and UnitLE.

Thanks.

Comment 15 Akira TAGOH 2004-12-10 16:56:56 UTC
Tested with 1.1.2-17.6.EL4. It also works fine.


Note You need to log in before you can comment on or make changes to this bug.