Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1369172 - "Download these requirements" text file is static and incomplete.
Summary: "Download these requirements" text file is static and incomplete.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: jkim
QA Contact: bmorriso
URL:
Whiteboard:
Depends On:
Blocks: 1359577
TreeView+ depends on / blocked
 
Reported: 2016-08-22 15:09 UTC by bmorriso
Modified: 2016-09-13 16:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:37:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
Requirements File (deleted)
2016-08-22 15:09 UTC, bmorriso
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description bmorriso 2016-08-22 15:09:57 UTC
Created attachment 1192956 [details]
Requirements File

Description of problem:
On the Product Selection Page, the "Download these requirements" link downloads a text file with the same requirements included every time, regardless of what has been selected in the WebUI. 

Instead, this file lists requirements for every product available to be installed, but is incomplete because it doesn't include the requirements for OpenShift. The requirements also differ between the WebUI and text file. For instance, the RHEV requirements in the text file do not mention Gluster, and the WebUI does.

Version-Release number of selected component (if applicable):
QCI-1.0-RHEL-7-20160819.t.0

How reproducible:
always

Steps to Reproduce:
1. Start a New Deployment
2. Select products to install.
3. Click "Download these requirements"

Actual results:
The downloaded file includes requirements for every product available (except for OpenShift)

Expected results:
The downloaded file includes requirements for the products selected. Requirements in the text file match with the requirements shown in the WebUI

Additional info:

Comment 2 cchase 2016-08-26 15:19:13 UTC
https://github.com/fusor/fusor/pull/1188

Comment 4 bmorriso 2016-08-30 16:51:22 UTC
Failed to verify on compose QCI-1.0-RHEL-7-20160829.t.0

On this latest compose, the requirements text file does include the requirements for each of the selected products. However, for the combination of RHEV + CFME, the hypervisor requirements are not correctly updated. 

For example, with RHEV only selected, the engine+hypervisor requirements are:

- 2 hosts (1 for engine, 1 for hypervisor). 
  -- Engine     : 25 GB disk space, 4  GB RAM, 2 CPU. 
  -- Hypervisor : 10 GB disk space, 16 GB RAM, 4 CPUs

For RHEV + OSE:

- 2 hosts (1 for engine, 1 for hypervisor). 
  -- Engine     : 25 GB disk space, 4  GB RAM, 2 CPU. 
  -- Hypervisor : 10 GB disk space, 32 GB RAM, 4 CPUs

The hypervisor RAM is increased to account for the 16 GB of additional memory required by OSE.

For RHEV + CFME:

- 2 hosts (1 for engine, 1 for hypervisor). 
  -- Engine     : 25 GB disk space, 4  GB RAM, 2 CPU. 
  -- Hypervisor : 10 GB disk space, 16 GB RAM, 4 CPUs

The expectation for RHEV + CFME is that the hypervisor RAM requirement would include the additional 8GB specified by the CFME requirements.

Comment 6 bmorriso 2016-08-31 13:46:14 UTC
Verified in compose QCI-1.0-RHEL-7-20160830.t.0

The issue in Comment #4 has been addressed. The requirements file correctly included the requirements for the selected products.

Comment 8 errata-xmlrpc 2016-09-13 16:37:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.