Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1369169 - [pioneer] Disable build on Power and s390
Summary: [pioneer] Disable build on Power and s390
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pioneer
Version: 25
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio Trande
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker PPCTracker F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2016-08-22 15:05 UTC by Rafael Fonseca
Modified: 2016-10-26 13:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-26 13:55:10 UTC


Attachments (Terms of Use)
Make pioneer ExcludeArch for Power and s390 (deleted)
2016-08-22 15:05 UTC, Rafael Fonseca
no flags Details | Diff

Description Rafael Fonseca 2016-08-22 15:05:42 UTC
Created attachment 1192955 [details]
Make pioneer ExcludeArch for Power and s390

Description of problem: pioneer uses some x86-only asm instruction which do not work on Power or s390.

../../contrib/profiler/Profiler.h: In constructor 'BVHTree::BVHTree(int, const objPtr_t*, const Aabb*)':
../../contrib/profiler/Profiler.h:158:51: error: impossible register constraint in 'asm'
     asm volatile("rdtsc" : "=a" (__a), "=d" (__d));


Version-Release number of selected component (if applicable): all versions are affected


How reproducible: always on ppc-koji and s390-koji


Actual results: http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3630383


Additional info: patch attached

Comment 1 Ben Rosser 2016-08-22 16:54:46 UTC
It looks like this might be fixable without disabling building on those architectures; on ARM, the code sets a flag in the profiler [1] that disables the use of those instructions [2], and the spec has already been modified to set it on aarch64 too (in addition to other stuff) [3]. Possibly the same modifications will enable building on these architectures?

[1] https://github.com/pioneerspacesim/pioneer/blob/master/contrib/profiler/Profiler.h#L13

[2] https://github.com/pioneerspacesim/pioneer/blob/master/contrib/profiler/Profiler.h#L154

[3] http://pkgs.fedoraproject.org/cgit/rpms/pioneer.git/tree/pioneer.spec#n131

Comment 2 Rafael Fonseca 2016-08-22 17:25:26 UTC
I'll try it out and report back.

Comment 3 Rafael Fonseca 2016-10-26 13:55:10 UTC
pioneer is now ExclusiveArch in Fedora because of [1]. So I'm closing this bug.

[1] https://github.com/pioneerspacesim/pioneer/issues/3846


Note You need to log in before you can comment on or make changes to this bug.