Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1368043 - [RFE] OVN: IP address management with static MACs
Summary: [RFE] OVN: IP address management with static MACs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Mark Michelson
QA Contact: qding
Ioanna Gkioka
URL:
Whiteboard:
Depends On:
Blocks: 1366899
TreeView+ depends on / blocked
 
Reported: 2016-08-18 07:58 UTC by Marcin Mirecki
Modified: 2018-07-16 15:30 UTC (History)
11 users (show)

Fixed In Version: openvswitch-2.6.1-2.git20161206.el7fdb
Doc Type: Enhancement
Doc Text:
OVN IP address management support added for static MAC addresses This update adds support for dynamic IP address assignment with user-specified static MAC addresses. As a result, Open Virtual Network (OVN) users can now create configurations with dynamic IP that are associated with static MAC addresses.
Clone Of:
Environment:
Last Closed: 2018-02-16 16:59:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
log files (deleted)
2016-12-13 14:38 UTC, Mor
no flags Details

Description Marcin Mirecki 2016-08-18 07:58:05 UTC
The commit message for:
https://github.com/openvswitch/ovs/commit/8639f9becd81e4c0c6737a103b748609b411c978
suggests that only dynamic macs will be supported.

For our needs we need support for static MACs.
When a NIC with a static MAC (provided externally) is connected and is marked for IP allocation, the IPAM should allocate an IP address to the NIC.
This will be helpful for any scenario where many VM's with fixed MACs are deployed.

Comment 3 Lance Richardson 2016-09-15 14:32:35 UTC
RFC patch with static MAC support posted here:

    http://openvswitch.org/pipermail/dev/2016-September/079544.html

Comment 5 Lance Richardson 2016-12-06 16:13:20 UTC
It's my understanding that OVS 2.6 (the first release with OVN)
will not be available in the fast datapath beta channel until
February 2017, which would be earliest that this could be included
in a released package.

Comment 6 Russell Bryant 2016-12-06 19:14:10 UTC
(In reply to Lance Richardson from comment #5)
> It's my understanding that OVS 2.6 (the first release with OVN)
> will not be available in the fast datapath beta channel until
> February 2017, which would be earliest that this could be included
> in a released package.

and we need to backport this patch to our OVS 2.6 package.  Lance, that's on your todo list, right?

Comment 7 Lance Richardson 2016-12-06 19:16:51 UTC
(In reply to Russell Bryant from comment #6)
> and we need to backport this patch to our OVS 2.6 package.  Lance, that's on
> your todo list, right?

Correct, that will need to be handled as a downstream backport (one of
several I'll be handling at this point).

Comment 8 Lance Richardson 2016-12-12 16:00:04 UTC
RPMS with changes for this BZ can be found here:
  http://download.eng.bos.redhat.com/brewroot/packages/openvswitch/2.6.1/2.git20161206.el7fdb

Comment 9 Mor 2016-12-13 14:38:15 UTC
Created attachment 1231245 [details]
log files

Comment 10 Lance Richardson 2016-12-13 14:47:16 UTC
(In reply to Mor from comment #9)
> Created attachment 1231245 [details]
> log files

The northd log has:

  2016-12-13T06:23:30.269Z|00002|daemon_unix(monitor)|ERR|1 crashes: pid 26011 died, killed (Segmentation fault), core dumped, restarting

Could you attach a few of the core dump files?

Thanks,

   Lance

Comment 11 Lance Richardson 2016-12-13 14:47:46 UTC
(In reply to Mor from comment #9)
> Created attachment 1231245 [details]
> log files

The northd log has:

  2016-12-13T06:23:30.269Z|00002|daemon_unix(monitor)|ERR|1 crashes: pid 26011 died, killed (Segmentation fault), core dumped, restarting

Could you attach a few of the core dump files?

Thanks,

   Lance

Comment 12 Lance Richardson 2016-12-13 14:47:58 UTC
(In reply to Mor from comment #9)
> Created attachment 1231245 [details]
> log files

The northd log has:

  2016-12-13T06:23:30.269Z|00002|daemon_unix(monitor)|ERR|1 crashes: pid 26011 died, killed (Segmentation fault), core dumped, restarting

Could you attach a few of the core dump files?

Thanks,

   Lance

Comment 13 Mor 2016-12-13 14:52:38 UTC
I was requested to try the RPM's from the brew repository with my test cases.

One of them that checks for IPAM functionality failed. The scenario was:
Start a VM with OVN network that has subnet defined, and try to request for IP address from DHCP.

Test failed at around: 2016-12-13 13:39.

I have attached the logs from the engine and host.

Comment 17 Mor 2017-01-05 12:06:06 UTC
Hi guys,

Quick update on my recent finding: 

Running with the latest version of OVN provider, the process ovn-northd is no longer crashing in the setup.

Thanks!

Comment 19 qding 2017-01-13 08:29:24 UTC
Verified with openvswitch-2.6.1-3.git20161206.el7fdb.x86_64

the command in test is as:
ovn-nbctl lsp-set-addresses $port "$mac dynamic". It assigns only IPv4 address, and Russell Bryant has confirmed this in another separate mail that "I just read the code and it looks like IPAM only supports IPv4.  I've put IPv6 IPAM on our backlog.​"

beaker job: https://beaker.engineering.redhat.com/jobs/1666684

Comment 21 Flavio Leitner 2018-02-16 16:59:21 UTC
Closing resolved bugs.


Note You need to log in before you can comment on or make changes to this bug.