Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 136783 - (i815) Switching back to X from VT crashes X
Summary: (i815) Switching back to X from VT crashes X
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2004-10-22 11:41 UTC by Michael Young
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 08:29:38 UTC


Attachments (Terms of Use)
Xorg.0.log (deleted)
2004-10-22 15:06 UTC, Michael Young
no flags Details
xorg.conf (deleted)
2004-10-22 15:08 UTC, Michael Young
no flags Details
lines from /var/log/messages that look relevant (deleted)
2004-10-22 15:12 UTC, Michael Young
no flags Details
Xorg.0.log from clean configuration (deleted)
2004-10-22 16:28 UTC, Michael Young
no flags Details
clean xorg.conf (deleted)
2004-10-22 16:29 UTC, Michael Young
no flags Details

Description Michael Young 2004-10-22 11:41:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; rv:1.7.3) Gecko/20040916
Firefox/0.10.1

Description of problem:
I am running xorg-x11-6.8.1-12 and have just discovered that if I am
running X (startx from run level 3) and switch to a text session
(ctrl-alt-f1), then X crashes when I try to switch back (alt-f7). The
lines (minus comments) generated after the crash in Xorg.0.log are

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)

Fatal server error:
EnterVT failed for screen 0

FatalError re-entered, aborting
Caught signal 11. Server aborting

Comment 1 Mike A. Harris 2004-10-22 14:30:21 UTC
>(WW) Open APM failed (/dev/apm_bios) (No such file or directory)

This is normal operation for a system which does not use APM power
management.  If APM is not enabled in the BIOS and kernel, then
the X server can't use APM managment features, so it can't open
/dev/apm_bios.  The message is labelled as "(WW)" which is a warning,
but technically it is just "informational".  It isn't a bug, and
APM is just an optional feature the X server supports if your
system is configured to use it.  It is not required, and is unrelated
to this bug.


If EnterVT failed, there must be a bug in the video driver or
X server.  Please attach your X server log file and config file
to the bug report as individual uncompressed file attachments, using
the link below.

Thanks in advance.


Comment 2 Michael Young 2004-10-22 15:06:22 UTC
Created attachment 105654 [details]
Xorg.0.log

Comment 3 Michael Young 2004-10-22 15:08:51 UTC
Created attachment 105655 [details]
xorg.conf

Comment 4 Michael Young 2004-10-22 15:12:19 UTC
Created attachment 105656 [details]
lines from /var/log/messages that look relevant

Comment 5 Mike A. Harris 2004-10-22 15:25:31 UTC
Please run the following command:

system-config-display --reconfig

This will generate a new config file, please do not edit or modify
it.

After this, please try to start up the X server and attempt to
reproduce the problem again.  If the problem is still reproduceable,
please attach your new xorg.conf and X server log.

Thanks in advance.

Comment 6 Michael Young 2004-10-22 16:28:44 UTC
Created attachment 105663 [details]
Xorg.0.log from clean configuration

Comment 7 Michael Young 2004-10-22 16:29:59 UTC
Created attachment 105664 [details]
clean xorg.conf

Comment 8 Mike A. Harris 2005-04-14 21:56:36 UTC
Since this report was last updated, we have released a bugfix update
to Xorg X11.  The new release is an update to version 6.8.2 and includes
numerous bug fixes, including fixes to the i810 driver for issues of
this nature.  Some users have indicated that the new release resolves
their problem, however there are other users who still report the issue
remains for them.

Please upgrade to our latest xorg-x11-6.8.2 rpms released for FC3,
and let us know if the problem is resolved.

If the problem persists with the latest xorg-x11 update for FC3, please
open a bug report in the official X.Org bug tracker located at:

    http://bugs.freedesktop.org in the "xorg" component against the i810 driver

Once you've filed your report in the X.org tracker, please paste the
URL here and we will track the issue in the X.org bugzilla and review
any fixes that become available for consideration in future Fedora Core
updates.

Thanks in advance.


Comment 9 Mike A. Harris 2005-04-14 22:29:40 UTC
Setting status to "NEEDINFO" awaiting testing of current update,
and upstream bug report URL for tracking if problem still persists.

Comment 10 Michael Young 2005-04-15 08:29:38 UTC
I am now FC4t? now, but the problem seems to be fixed with 6.8.2-22 which is
what I have installed at the moment, so I assume the latest FC3 fixes it as well.


Note You need to log in before you can comment on or make changes to this bug.