Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367824 - Incomplete command output printed after running a container with oc run
Summary: Incomplete command output printed after running a container with oc run
Keywords:
Status: CLOSED DUPLICATE of bug 1341450
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Andy Goldstein
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-17 14:49 UTC by Eric Rich
Modified: 2016-08-18 18:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-18 18:35:09 UTC


Attachments (Terms of Use)

Description Eric Rich 2016-08-17 14:49:20 UTC
Description of problem:

After running: 

> oc run --generator=deploymentconfig/v1 --attach --stdin --tty --image registry.access.redhat.com/rhel7/rhel-tools rhel-tools bash

and exiting the container, I see: 

> Session ended, resume using ' rhel-tools-1-hkz0c -c rhel-tools -i -t' command when the pod is running

Version-Release number of selected component (if applicable):

oc version
oc v3.2.0.46-1-g3fab54d
kubernetes v1.2.0-36-g4a3f9c5

How reproducible: Frequent 

Steps to Reproduce:
1. oc run --generator=deploymentconfig/v1 --attach --stdin --tty --image registry.access.redhat.com/rhel7/rhel-tools rhel-tools bash
2. exit container (ctrl+c)

Actual results:

Session ended, resume using ' rhel-tools-1-hkz0c -c rhel-tools -i -t' command when the pod is running

Expected results:

The command should say: 

Session ended, resume using 'oc attach rhel-tools-1-hkz0c -c rhel-tools -i -t' command when the pod is running

Additional info:

After running: 

> oc attach rhel-tools-1-hkz0c -c rhel-tools -i -t

and exiting the container, I see that the output says: 

> Session ended, resume using 'kubectl attach rhel-tools-1-hkz0c -c rhel-tools -i -t' command when the pod is running

This too is wrong as the command its pulling is kubectl and not oc (even though they are synonymous). 

Error: https://github.com/openshift/origin/blob/master/vendor/k8s.io/kubernetes/pkg/kubectl/cmd/attach.go#L242

Comment 1 Xingxing Xia 2016-08-18 05:06:10 UTC
Tried above commands "oc run" and "oc attach" both with oc v3.2.0.46 and oc v3.3.0.22. Fixed in v3.3.0.22, reproduced in v3.2.0.46. In fact, there was one: https://bugzilla.redhat.com/show_bug.cgi?id=1341450

Comment 2 Andy Goldstein 2016-08-18 18:35:09 UTC
This is a dupe of 1341450. It was fixed in 3.3.

*** This bug has been marked as a duplicate of bug 1341450 ***


Note You need to log in before you can comment on or make changes to this bug.