Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367774 - Support for Client side Events
Summary: Support for Client side Events
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: eventsapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1351589
TreeView+ depends on / blocked
 
Reported: 2016-08-17 12:41 UTC by Aravinda VK
Modified: 2017-03-27 18:19 UTC (History)
0 users

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 18:19:57 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-08-17 12:41:54 UTC
Description of problem:
Add support for sending messages from GlusterFS Clients

Discussed here https://www.gluster.org/pipermail/gluster-devel/2016-August/050324.html

Comment 1 Vijay Bellur 2016-08-17 12:43:38 UTC
REVIEW: http://review.gluster.org/15189 (eventsapi: New API gf_event_client) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Worker Ant 2016-08-27 10:09:31 UTC
REVIEW: http://review.gluster.org/15189 (eventsapi: Add support for Client side Events) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Worker Ant 2016-08-27 10:32:38 UTC
REVIEW: http://review.gluster.org/15189 (eventsapi: Add support for Client side Events) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 4 Worker Ant 2016-08-27 15:10:01 UTC
REVIEW: http://review.gluster.org/15189 (eventsapi: Add support for Client side Events) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 5 Worker Ant 2016-08-28 13:40:20 UTC
REVIEW: http://review.gluster.org/15189 (eventsapi: Add support for Client side Events) posted (#5) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 6 Worker Ant 2016-08-29 04:22:14 UTC
REVIEW: http://review.gluster.org/15189 (eventsapi: Add support for Client side Events) posted (#6) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 7 Worker Ant 2016-08-29 06:34:32 UTC
REVIEW: http://review.gluster.org/15189 (eventsapi: Add support for Client side Events) posted (#7) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 8 Worker Ant 2016-08-30 09:53:03 UTC
REVIEW: http://review.gluster.org/15189 (eventsapi: Add support for Client side Events) posted (#8) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 9 Worker Ant 2016-08-30 13:54:16 UTC
REVIEW: http://review.gluster.org/15189 (eventsapi: Add support for Client side Events) posted (#9) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 10 Worker Ant 2016-08-31 01:35:04 UTC
COMMIT: http://review.gluster.org/15189 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit b71ae7d77d7ab1581d266f6435d134958844d0db
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Aug 17 13:46:00 2016 +0530

    eventsapi: Add support for Client side Events
    
    Client side gf_event uses ctx->cmd_args.volfile_server to push
    notifications to the eventsd.
    
    Socket server changed from Unix domain socket to UDP to support
    external events.
    
    Following to be addressed in different patch
    - Port used for eventsd is 24009. Make it configurable
      Already configurable in Server side. Configurable in gf_event API
      is required.
    - Auth Token yet to be added as discussed in
      https://www.gluster.org/pipermail/gluster-devel/2016-August/050324.html
    
    Change-Id: I159acf80b681d10b82d52cfb3ffdf85cb896542d
    BUG: 1367774
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/15189
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 11 Shyamsundar 2017-03-27 18:19:57 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.