Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367765 - API controllers newer than Apipie cache! Run apipie:cache rake task to regenerate cache
Summary: API controllers newer than Apipie cache! Run apipie:cache rake task to regene...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-17 12:18 UTC by Thom Carlin
Modified: 2017-04-25 16:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-02 08:50:30 UTC


Attachments (Terms of Use)

Description Thom Carlin 2016-08-17 12:18:37 UTC
Description of problem:

Warning Messages in /var/log/httpd/error_log and "foreman-rake console"

Version-Release number of selected component (if applicable):

QCI-1.0-RHEL-7-20160815.t.0

How reproducible:

100%

Steps to Reproduce:
1. Install/configure QCI
2A. Deploy RHV
3A. Examine /var/log/httpd/error_log
OR
2B. foreman-rake console

Actual results:

A:
[ 2016-08-17 07:54:46.2909 19133/7fce6b1d6700 Pool2/Spawner.h:738 ]: [App 57408 stdout] API controllers newer than Apipie cache! Run apipie:cache rake task to regenerate cache.

B:
API controllers newer than Apipie cache! Run apipie:cache rake task to regenerate cache.
/usr/share/foreman/lib/tasks/console.rake:4: warning: already initialized constant ARGV
Loading production environment (Rails 4.1.5)

Expected results:

No messages about Apipie cache

Additional info:

More of an annoyance than an actual error but it does add quite a bit of noise since it reoccurs.

Comment 1 John Matthews 2016-08-17 18:37:46 UTC
Thom,

Please file this against Satellite.

Comment 3 Tomas Strachota 2017-03-01 13:23:41 UTC
I believe this itself is not a bug but a feature. Apipie uses the message to inform a sysadmin that the cache is out of sync and should be regenerated. Normally this shouldn't happen, because apipie cache is updated as one of upgrade steps. Seeing this message after upgrade means that some of the upgrade steps probably failed.

Therefore I propose to close this BZ as not a bug, but I'd like some apipie core dev to confirm first. Ivan?

Comment 4 Ivan Necas 2017-03-01 13:59:03 UTC
ACK on this should not be a bug, on satellite side at least, as we the rake cache is running as part of the installer.

Comment 5 Tomas Strachota 2017-03-02 08:50:30 UTC
Based on information above I'm closing this as "not a bug".

If the message occurs repeatedly after upgrade, please open a new bz with foreman-debug attached and we will track down the real cause of upgrade failure. Thank you.


Note You need to log in before you can comment on or make changes to this bug.