Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367754 - Add local storage or NFS storage don't list in the storage page,and FC storage or iscsi storage can be list
Summary: Add local storage or NFS storage don't list in the storage page,and FC storag...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-node
Classification: oVirt
Component: UI
Version: 4.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ---
: ---
Assignee: Fabian Deutsch
QA Contact: Yihui Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-17 11:48 UTC by Yihui Zhao
Modified: 2016-08-17 12:57 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-17 12:49:13 UTC
oVirt Team: Node
rule-engine: planning_ack?
rule-engine: devel_ack?
cshao: testing_ack+


Attachments (Terms of Use)
FC.png (deleted)
2016-08-17 11:48 UTC, Yihui Zhao
no flags Details
local.png (deleted)
2016-08-17 11:49 UTC, Yihui Zhao
no flags Details
local_rhevm.png (deleted)
2016-08-17 11:49 UTC, Yihui Zhao
no flags Details
NFS_error.png (deleted)
2016-08-17 11:50 UTC, Yihui Zhao
no flags Details
NFC FC_rhevm.png (deleted)
2016-08-17 11:51 UTC, Yihui Zhao
no flags Details
NFS_terminal.png (deleted)
2016-08-17 11:51 UTC, Yihui Zhao
no flags Details
Log about local storage. (deleted)
2016-08-17 11:53 UTC, Yihui Zhao
no flags Details
Log about FC and nfs storage. (deleted)
2016-08-17 11:54 UTC, Yihui Zhao
no flags Details
yihui.ks (deleted)
2016-08-17 11:59 UTC, Yihui Zhao
no flags Details

Description Yihui Zhao 2016-08-17 11:48:23 UTC
Created attachment 1191577 [details]
FC.png

Description of problem:
Add local storage or NFS storage don't list in the storage page,and FC storage or iscsi storage can be list.

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160816.0.x86_64
imgbased-0.8.4-1.el7ev.noarch
cockpit-ws-0.114-2.el7.x86_64
cockpit-ovirt-dashboard-0.10.6-1.3.6.el7ev.noarch


How reproducible:
100%


Steps to Reproduce:
NFS storage:
1. Install RHVH rhvh-4.0-0.20160816.0.x86_64
2. mount local storage on rhvh: mount -t nfs 10.66.61.114:/home/zyh/nfs1 /root/data, mount successfully
3.add RHVH4.0 to engine,then add a new nfs storage domain,it should be successful
4.login to cockpit(ip:9090)
5.check the nfs storage in the storage page on cockpit

Local storage:
1.Install RHVH rhvh-4.0-0.20160816.0.x86_64
2.create DC(local) and cluster on rhevm
3.add rhvh4.0 to engine
4.add local storage domain as data on rhevm
5.login to cockpit(ip:9090)
6.check the local storage in the storage page on cockpit

FC storage:
1.Install RHVH rhvh-4.0-0.20160816.0.x86_64 on FC machine
2.add rhvh4.0 to engine
3.add FC storage domain as data on rhevm
4.login to cockpit(ip:9090)
5.check the FC storage in the storage page on cockpit


   


Actual results:
Add local storage or NFS storage don't list in the storage page.

Expected results:
Add local storage or NFS storage should be  list in the storage page.

Additional info: 
when i add FC or iscsi storage domain on rhevm,and login to cockpit ,it can be listed in the storage page on cockpit.
Some pictures listed on attachment.

Comment 1 Red Hat Bugzilla Rules Engine 2016-08-17 11:48:32 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Yihui Zhao 2016-08-17 11:49:15 UTC
Created attachment 1191578 [details]
local.png

Comment 3 Yihui Zhao 2016-08-17 11:49:48 UTC
Created attachment 1191591 [details]
local_rhevm.png

Comment 4 Yihui Zhao 2016-08-17 11:50:28 UTC
Created attachment 1191592 [details]
NFS_error.png

Comment 5 Yihui Zhao 2016-08-17 11:51:02 UTC
Created attachment 1191593 [details]
NFC FC_rhevm.png

Comment 6 Yihui Zhao 2016-08-17 11:51:44 UTC
Created attachment 1191594 [details]
NFS_terminal.png

Comment 7 Yihui Zhao 2016-08-17 11:53:14 UTC
Created attachment 1191595 [details]
Log about local storage.

Comment 8 Yihui Zhao 2016-08-17 11:54:23 UTC
Created attachment 1191596 [details]
Log about FC and nfs storage.

Comment 9 Yihui Zhao 2016-08-17 11:59:34 UTC
Created attachment 1191598 [details]
yihui.ks

Comment 10 Fabian Deutsch 2016-08-17 12:35:34 UTC
What is the goal of the flow described in comment 0?

Comment 11 Yihui Zhao 2016-08-17 12:45:31 UTC
(In reply to Fabian Deutsch from comment #10)
> What is the goal of the flow described in comment 0?

Hi Fabian,
  The goal:if add the local/NFS/FC/iscsi storage on rhvh4.0,when login to cockpit,
some information about local/NFS/FC/iscsi should be listed in the storage page on cockpit.But the local and NFS storage don't list in.

Thank you.
Yihui Zhao

Comment 12 Fabian Deutsch 2016-08-17 12:49:13 UTC
Right.

Cockpit currently only supports to enumerate/list block storage devices/sessions. That is why iSCSI and FC are shown.
Please note that this feature is generic, and not specific for RHV.

If you also want to view mounts (like NFS) on cockpit, please file an RFE against cockpit.

Comment 13 Yihui Zhao 2016-08-17 12:57:53 UTC
(In reply to Fabian Deutsch from comment #12)
> Right.
> 
> Cockpit currently only supports to enumerate/list block storage
> devices/sessions. That is why iSCSI and FC are shown.
> Please note that this feature is generic, and not specific for RHV.
> 
> If you also want to view mounts (like NFS) on cockpit, please file an RFE
> against cockpit.

OK,Thank you for your help.


Note You need to log in before you can comment on or make changes to this bug.