Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367747 - fusor_server did not find 'Katello.config.logging.ignored_paths' available, skipping silence of logs for '["api/v21/foreman_tasks", "fusor/api/v21/unlogged"]'
Summary: fusor_server did not find 'Katello.config.logging.ignored_paths' available, s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-server
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ga
: 1.0
Assignee: Jesus M. Rodriguez
QA Contact: James Olin Oden
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-17 11:27 UTC by Thom Carlin
Modified: 2016-09-13 16:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:36:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Thom Carlin 2016-08-17 11:27:52 UTC
Description of problem:

Error message in Foreman production.log.

Version-Release number of selected component (if applicable):

QCI-1.0-RHEL-7-20160815.t.0

How reproducible:

100%

Steps to Reproduce:
1. Install/Configure QCI
2. Wait 1/2 hour
3. Examine /var/log/foreman/production.log

Actual results:

2016-08-17 03:58:54 [app] [W] fusor_server did not find 'Katello.config.logging.ignored_paths' available, skipping silence of logs for '["api/v21/foreman_tasks", "fusor/api/v21/unlogged"]'

Expected results:

No errors

Additional info:

Many messages have datetime of x:00 or x:30 which suggests a cron job?

Possibly: /opt/theforeman/tfm/root/usr/share/gems/gems/fusor_server-1.0.1/lib/fusor/engine.rb

Comment 1 John Matthews 2016-08-17 18:31:10 UTC
Plan is to remove this snippet, this was intended for Sat 6.1 when they had the SilencedLogger.

https://github.com/fusor/fusor/blob/master/server/lib/fusor/engine.rb#L12-L25

Comment 3 Jesus M. Rodriguez 2016-08-18 13:54:24 UTC
https://github.com/fusor/fusor/pull/1169

Comment 4 James Olin Oden 2016-08-31 19:46:41 UTC
Verified on QCI-1.0-RHEL-7-20160831.t.0

Comment 6 errata-xmlrpc 2016-09-13 16:36:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.