Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367746 - mock update skipped, depend problem.
Summary: mock update skipped, depend problem.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1378176 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-17 11:25 UTC by mejiko
Modified: 2016-09-23 08:05 UTC (History)
7 users (show)

Fixed In Version: mock-1.2.21
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-23 08:05:20 UTC


Attachments (Terms of Use)

Description mejiko 2016-08-17 11:25:54 UTC
Hello.

Update mock (1.2.19-2.fc24) is skipped. because "depend" problem.


Reason:

Conflict that fedora-release package. 


Details:

1) This system is not installed fedora-release, fedora-logos, and fedora-release-note package.

and

2) This system is installed generic-release, generic-logos, and generic-release-notes. (I think that this is Fedora derived or Fedora derived distribution)

or

3) This system is installed Fedora derived distribution. 


I see and check Fedora trademark guideline, I think that Fedora derived and/or Fedora derived distribution must be remove fedora-logos, fedora-release, fedora-release-notes. (Is this is correct ?)


This problem is affect that:

1) installed/replaced generic-release, generic-logos, or generic-release-notes users. (I think that this is Fedora derived or Fedora derived distribution)

or

2) installed Fedora derived distribution users. 



I suggest that resolve depend problem. (Modify SPEC file)

Thanks.




Reference:

https://fedoraproject.org/wiki/Remix
https://fedoraproject.org/wiki/Legal:Trademark_guidelines

Comment 1 Miroslav Suchý 2016-08-17 13:08:14 UTC
We require fedora-release, because we need /etc/os-release
And I am trying to avoid file dependencies.
So it seems that depending on virtual provides `system-release`, will be better as both provide it.

Comment 2 Miroslav Suchý 2016-08-17 13:10:29 UTC
Fixed in commit:
* b0d81f4 require generic system-release rather than fedora-release [RHBZ#1367746]

Comment 3 Miroslav Suchý 2016-09-23 08:02:09 UTC
*** Bug 1378176 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Suchý 2016-09-23 08:05:20 UTC
This somehow went off the radar. This fix is already in mock-1.2.21, which is either in updates or in stable.


Note You need to log in before you can comment on or make changes to this bug.