Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367724 - [public_networking_54]ingress ip should not be assigned ip by ingress controller for cloud vm cluster
Summary: [public_networking_54]ingress ip should not be assigned ip by ingress control...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.3.0
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: ---
Assignee: Maru Newby
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-17 10:23 UTC by zhaozhanqi
Modified: 2017-03-08 18:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
This bug was filed and fixed before the feature in question was released, so no docs are required.
Clone Of:
Environment:
Last Closed: 2016-09-27 09:44:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC
Origin (Github) 10455 None None None 2016-08-17 12:27:57 UTC

Description zhaozhanqi 2016-08-17 10:23:29 UTC
Description of problem:

ingress ip should not be assigned by ingress controller for cloud vm cluster. since it should be configure the cloud-specific load balancers

Version-Release number of selected component (if applicable):
openshift version
openshift v3.3.0.21
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git


How reproducible:
always

Steps to Reproduce:
1. Set 'ingressIPNetworkCIDR: 172.31.0.0/16' in master-config.yaml

2. Restart the master service
3. Create one 'LoadBalancer' type service
4. oc get svc

Actual results:

the ingress ip was assigned 

# oc get svc ws-unsecure -o yaml
apiVersion: v1
kind: Service
metadata:
  creationTimestamp: 2016-08-17T03:13:03Z
  labels:
    name: ws-unsecure
  name: ws-unsecure
  namespace: default
  resourceVersion: "9431"
  selfLink: /api/v1/namespaces/default/services/ws-unsecure
  uid: 82e1651a-6428-11e6-adfd-0e7bf32fd285
spec:
  clusterIP: 172.30.11.17
  deprecatedPublicIPs:
  - 172.31.4.231
  externalIPs:
  - 172.31.4.231
  portalIP: 172.30.11.17
  ports:
  - name: http
    nodePort: 31922
    port: 27017
    protocol: TCP
    targetPort: 9999
  selector:
    name: hello-websocket
  sessionAffinity: None
  type: LoadBalancer
status:
  loadBalancer:
    ingress:
    - ip: 172.31.4.231


Expected results:

ingress ip should not be assigned for cloud vm cluster.

Additional info:

Comment 1 Maru Newby 2016-08-17 12:27:57 UTC
This is a known problem and a fix is in process.

Comment 2 Troy Dawson 2016-08-19 21:14:25 UTC
This has been merged into ose and is in OSE v3.3.0.23 or newer.

Comment 4 zhaozhanqi 2016-08-22 06:43:36 UTC
verified this bug on 

openshift version
openshift v3.3.0.23-dirty
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

When given an ingressIPNetworkCIDR option on master-config.yaml. the master service will cannot be started.
and check the log from journalctl -xe:
networkConfig.ingressIPNetworkCIDR[0]: Invalid value: "10.66.0.0/16": should not be provided when a cloud-provider is enabled

Comment 6 errata-xmlrpc 2016-09-27 09:44:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.