Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367713 - JMX/Threads console is blank
Summary: JMX/Threads console is blank
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: stlewis@redhat.com
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-17 09:34 UTC by Xia Zhao
Modified: 2016-09-19 13:07 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-19 13:07:48 UTC


Attachments (Terms of Use)
pod_logs (deleted)
2016-08-17 09:34 UTC, Xia Zhao
no flags Details
screenshot of the blank mgmt console (deleted)
2016-08-17 09:35 UTC, Xia Zhao
no flags Details
s2i logs (deleted)
2016-08-17 09:37 UTC, Xia Zhao
no flags Details
jvm console screenshot (deleted)
2016-08-23 09:11 UTC, chunchen
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC
Github openshift origin pull 10650 None None None 2016-08-25 19:24:25 UTC

Description Xia Zhao 2016-08-17 09:34:36 UTC
Created attachment 1191524 [details]
pod_logs

Description of problem:
JMX/Threads console is blank after deploying the s2i built-out fabric8 applications.

Version-Release number of selected component (if applicable):
# openshift version
openshift v3.3.0.21
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

How reproducible:
Always

Steps to Reproduce:
1. Built-out the fabric8 application by doing s2i:
$ git clone https://github.com/fabric8io/ipaas-quickstarts
$ mvn archetype:generate   -DarchetypeCatalog=https://repo.fusesource.com/nexus/content/groups/public/archetype-catalog.xml   -DarchetypeGroupId=io.fabric8.archetypes   -DarchetypeVersion=2.2.99   -DarchetypeArtifactId=cdi-camel-archetype
$ cd cdi-camel-archetype
$ git remote add origin git@github.com:xiazhao2015/cdi-camel-archetype.git
$ git push -u origin master
$ vi quickstart-template.json
Set value "https://github.com/xiazhao2015/cdi-camel-archetype.git" to parameter GIT_REPO
$ oc new-project java-test
$ oc new-app -f quickstart-template.json
$ oc import-image s2i-java-s2i-quickstart-cdi-camel:1.2.5
2.Check build result:
$ oc get build
NAME                         TYPE      FROM          STATUS     STARTED             DURATION
s2i-quickstart-cdi-camel-1   Source    Git@4fa12cb   Complete   About an hour ago   2m50s
3.Check app pod status:
$ oc get po
NAME                               READY     STATUS      RESTARTS   AGE
s2i-quickstart-cdi-camel-1-3myb9   1/1       Running     0          1h
4.Login openshift webconsole, go to JMX/Threads console by clicking on hyperlink "Open Java Console" inside the app pod 

Actual results:
JMX/Threads console is blank at this redirecting URL:  https://{master-dns}:8443/console/java?con=s2i-quickstart-cdi-camel

Expected results:
JMX/Threads console should not be blank

Additional info:
Full fabric8 pod log attached
Screenshot attached

Comment 1 Xia Zhao 2016-08-17 09:35:56 UTC
Created attachment 1191538 [details]
screenshot of the blank mgmt console

Comment 2 Xia Zhao 2016-08-17 09:37:32 UTC
Created attachment 1191539 [details]
s2i logs

Comment 3 stlewis@redhat.com 2016-08-17 18:48:10 UTC
PR -> https://github.com/openshift/origin-web-console/pull/407

Comment 4 Jessica Forrester 2016-08-17 18:51:02 UTC
since this is an OCP (enterprise) bug it will go to MODIFIED after the change is vendored into the origin repo later today

Comment 5 Jessica Forrester 2016-08-18 00:02:27 UTC
Merging into origin in https://github.com/openshift/origin/pull/10495

Comment 6 Troy Dawson 2016-08-19 21:08:00 UTC
This has been merged into ose and is in OSE v3.3.0.23 or newer.

Comment 8 Xia Zhao 2016-08-22 05:14:32 UTC
Verification work is blocked by upstream issue: https://github.com/fabric8io/ipaas-quickstarts/issues/1400

Comment 9 chunchen 2016-08-23 07:18:56 UTC
It's failed to deploy jvm pod due to "no main manifest attribute, in /deployments/cdi-camel-archetype.jar", please refer to below testing details:

[chunchen@F17-CCY ~]$ mvn archetype:generate   -DarchetypeCatalog=https://repo.fusesource.com/nexus/content/groups/public/archetype-catalog.xml   -DarchetypeGroupId=io.fabric8.archetypes   -DarchetypeVersion=2.2.164   -DarchetypeArtifactId=cdi-camel-archetype

[chunchen@F17-CCY cdi-camel-archetype]$ oc new-app -f quickstart-template.json
[chunchen@F17-CCY cdi-camel-archetype]$ oc get pod
NAME                                READY     STATUS             RESTARTS   AGE
s2i-quickstart-cdi-camel-1-build    0/1       Completed          0          13m
s2i-quickstart-cdi-camel-1-deploy   1/1       Running            0          8m
s2i-quickstart-cdi-camel-1-lz060    0/1       CrashLoopBackOff   6          8m

[chunchen@F17-CCY cdi-camel-archetype]$ oc logs s2i-quickstart-cdi-camel-1-build
Pulling image "fabric8/s2i-java@sha256:843f1be826aef974c06731043d8ecaca258b53c417138d73260512b2edc3a1f0" ...
Pulling image "fabric8/s2i-java@sha256:843f1be826aef974c06731043d8ecaca258b53c417138d73260512b2edc3a1f0" ...
<------------snip---------->
<------------snip---------->
[INFO] Building jar: /tmp/src/target/cdi-camel-archetype.jar
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 04:16 min
[INFO] Finished at: 2016-08-23T07:01:47+00:00
[INFO] Final Memory: 39M/305M
[INFO] ------------------------------------------------------------------------
Copying Maven artifacts from /tmp/src/target to /deployments ...
Running: cp *.jar /deployments
... done
Pushing image 172.30.212.66:5000/cproj/s2i-quickstart-cdi-camel:latest ...
Pushed 0/21 layers, 0% complete
Pushed 1/21 layers, 5% complete
Pushed 2/21 layers, 10% complete
Pushed 3/21 layers, 14% complete
Pushed 4/21 layers, 19% complete
Pushed 5/21 layers, 24% complete
Pushed 6/21 layers, 29% complete
Pushed 7/21 layers, 33% complete
Pushed 8/21 layers, 38% complete
Pushed 9/21 layers, 43% complete
Pushed 10/21 layers, 48% complete
Pushed 11/21 layers, 52% complete
Pushed 12/21 layers, 57% complete
Pushed 13/21 layers, 62% complete
Pushed 14/21 layers, 67% complete
Pushed 15/21 layers, 71% complete
Pushed 16/21 layers, 76% complete
Pushed 17/21 layers, 81% complete
Pushed 18/21 layers, 86% complete
Pushed 19/21 layers, 90% complete
Pushed 20/21 layers, 95% complete
Pushed 21/21 layers, 100% complete
Push successful

[chunchen@F17-CCY cdi-camel-archetype]$ oc logs s2i-quickstart-cdi-camel-1-lz060
Starting the Java application using /opt/run-java/run-java.sh ...
I> No access restrictor found, access to any MBean is allowed
Jolokia: Agent started with URL https://10.1.1.10:8778/jolokia/
no main manifest attribute, in /deployments/cdi-camel-archetype.jar

Comment 10 chunchen 2016-08-23 09:09:27 UTC
It's still reproduced, please refer to screenshot named "jvm console screenshot".
The messages in comment #9 can be ignored.

oc v3.3.0.23-dirty
kubernetes v1.3.0+507d3a7
features: Basic-Auth GSSAPI Kerberos SPNEGO

Comment 11 chunchen 2016-08-23 09:11:22 UTC
Created attachment 1193275 [details]
jvm console screenshot

Comment 12 Samuel Padgett 2016-08-24 13:09:00 UTC
I can reproduce in origin. We're correctly pulling in the version 1.0.45, updated from Stan's commit.

https://github.com/openshift/origin-web-console/pull/407

This is also the latest version of openshift-jvm, although it is from Mar 29. Stan, are you sure that release has the fix?

Comment 14 Samuel Padgett 2016-08-24 14:32:30 UTC
I'm using quickstart-java-simple-mainclass to test. I couldn't deploy the s2i-quickstart-cdi-camel in the description because of an error creating the image stream.

However, the problem with the proxy request -- at least with quickstart-java-simple-mainclass -- is we're connecting through the proxy using https to a port serving http content.

Comment 15 Antonin Stefanutti 2016-08-24 14:59:01 UTC
I've just pushed https://github.com/openshift/origin-web-console/pull/469 that hopefully should fix the issue.

Comment 16 openshift-github-bot 2016-08-24 20:32:04 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/7e2bbafaebbbf6fbd9dad5619466e1265e2d3248
Fix bug #1367713 - JMX/Threads console is blank

Comment 17 Jessica Forrester 2016-08-24 20:49:28 UTC
several fixes related to this are merged into the console and are merging into origin with https://github.com/openshift/origin/pull/10618

there is still some concern over comment 14  because the jolokia name should not show up on a port that doesn't support https, we only allow communicating with jolokia over https

Comment 18 Jessica Forrester 2016-08-25 19:24:25 UTC
Bumped the jvm console again to fix issues with a number of missing assets, merging to origin in https://github.com/openshift/origin/pull/10650

Comment 19 Jessica Forrester 2016-08-25 19:28:38 UTC
@xiazhao can you verify in origin with PR 10650 that the Javascript runtime issue is resolved.  You will still probably see an issue with actually connecting to the jvm using your example because of what is causing comment 14 which is not a problem in the jvm console but seems to be a problem with the base images being used in your example.  The images need to be setting the env var AB_JOLOKIA_AUTH_OPENSHIFT=true

If the jvm console JS runtime issue is resolved I want to transfer this to the Images component and to @hchirino

Comment 20 chunchen 2016-08-26 01:52:46 UTC
Will verify it while the PR 10650 is merged.

Comment 21 chunchen 2016-08-29 03:14:34 UTC
The issue is fixed in origin, checked with devenv-rhel7_4943.

oc v1.3.0-alpha.3+4250e53
kubernetes v1.3.0+507d3a7
features: Basic-Auth GSSAPI Kerberos SPNEGO

Comment 22 Xia Zhao 2016-08-29 06:02:53 UTC
Verified with OSE version v3.3.0.26, this issue has been fixed. Please set back to ON_QA state for closure, thanks!

# openshift version
openshift v3.3.0.26
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

Comment 23 Jessica Forrester 2016-08-29 13:23:30 UTC
moving to MODIFIED so it can get the errata details added, @tdawson its already confirmed to be fixed in 3.3.0.26

Comment 24 Troy Dawson 2016-08-29 20:11:07 UTC
This has been merged into ose and is in OSE v3.3.0.27 or newer.

Comment 25 Troy Dawson 2016-08-29 20:12:50 UTC
Already in errata, so moving it manually to QE.

Comment 26 Xia Zhao 2016-08-30 02:29:09 UTC
Verified with OSE version v3.3.0.27, this issue has been fixed with the repro of https://bugzilla.redhat.com/show_bug.cgi?id=1371000, set to verified.

# openshift version
openshift v3.3.0.27
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git


Note You need to log in before you can comment on or make changes to this bug.