Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367672 - Extraneous error message when satellite auto-attaches before subscription-manager
Summary: Extraneous error message when satellite auto-attaches before subscription-man...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
: 1413829 (view as bug list)
Depends On: 1405480
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-17 07:59 UTC by qianzhan
Modified: 2018-04-10 09:48 UTC (History)
7 users (show)

Fixed In Version: subscription-manager-1.20.2-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-04-10 09:47:31 UTC


Attachments (Terms of Use)
Unnecessary_error_window.png (deleted)
2016-08-17 08:00 UTC, qianzhan
no flags Details
rhsm.log (deleted)
2016-08-17 08:00 UTC, qianzhan
no flags Details
foreman-debug-7ll2U.tar.xz (deleted)
2016-08-22 02:10 UTC, qianzhan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:48:38 UTC
Github candlepin subscription-manager pull 1661 None None None 2017-07-06 18:17:07 UTC

Description qianzhan 2016-08-17 07:59:52 UTC
Description of problem:
Unnecessary error window when registering and auto-attach in GUI on s390x

Version-Release number of selected component (if applicable):
subscription-manager: 1.17.10-1.el7
python-rhsm: 1.17.6-1.el7

How reproducible:
always

Steps to Reproduce:
1. Install RHEL-7.3-server-s390x-Beta-1.0 (RHEL-7.3-20160811.0).
2. Open subscription-manager-gui, register and auto-attach:
An error window prompts, but the system is already registered and auto-attached. Please see attachments 'Unnecessary_error_window.png' and 'rhsm.log'

Actual results:


Expected results:


Additional info:

Comment 1 qianzhan 2016-08-17 08:00:13 UTC
Created attachment 1191483 [details]
Unnecessary_error_window.png

Comment 2 qianzhan 2016-08-17 08:00:36 UTC
Created attachment 1191484 [details]
rhsm.log

Comment 4 qianzhan 2016-08-19 06:29:14 UTC
This bug also exists on RHEL-7.3-server-aarch64-Beta-1.1 (RHEL-7.3-20160817.1) against Satellite-6.2.0-RHEL-7-20160817.0

Comment 5 Chris Snyder 2016-08-19 21:39:36 UTC
@CP_devs: Someone please reproduce this.


@qianzhan: Please attach the satellite logs (foreman-debug) from when this occurred.

Comment 6 qianzhan 2016-08-22 02:09:39 UTC
Hi Chris,

I reproduced this bug on RHEL-7.3-server-aarch64-Beta-1.1 against satellite6.2, and then ran command 'foreman-debug' on satellite getting the 'foreman-debug-7ll2U.tar.xz' attachment. Hope this can help.

Comment 7 qianzhan 2016-08-22 02:10:14 UTC
Created attachment 1192738 [details]
foreman-debug-7ll2U.tar.xz

Comment 8 Kevin Howell 2016-09-16 19:24:35 UTC
What I *think* is happening here (we'll need to confirm), is that:
when subscription-manager-gui sets the service level, this results in an update of the host facts, and since the host is set to auto-attach subscriptions in Satellite (katello), this triggers an auto-attach *from katello*.

I suppose we should confirm the following: is the host set to auto-attach in Satellite? (Or maybe org set to auto-attach)?

If my assumptions are correct, then the error message is accurate; what has happened is that katello and subscription-manager have (nearly) simultaneously performed an auto attach, and in this case subscription-manager's failed because it came afterwards. I am thinking that we should document that katello's auto-attach and subscription-manager(-gui)'s auto-attach features should not be used together. One or the other is sufficient.

Otherwise, I'm not sure what expected behavior is... in terms of katello and subscription-manager both doing an auto-attach.

Comment 9 qianzhan 2016-09-18 09:41:02 UTC
Hi, Kevin

I will try your assumptions after a RHEL-7.3-20160914.1-server-s390x is provisioned in beaker.

Comment 10 qianzhan 2016-09-19 10:21:46 UTC
Bug still can be reproduced with RHEL-7.3-Snapshot-4.0-server-s390x and Satellite-6.2.0-RHEL-7-20160907.6.

The auto-attach option just can be operated when the system is registered to candlepin. That means:
1) auto-attach can be enabled from subscription-manager cli /gui when the system is registered.
2) auto-attach can be enabled from satellite web UI when the system is registered.

So, I tried: Register first, and then auto-attach in subscription-manager-gui, then the bug still can be reproduced, which means I can try assumptions in comment 8:

1. When the system is registered to satellite6.2, auto-attach is enabled both on satellite webUI and client.
2. Disable auto-attach on satellite webUI, and enable it on client: The bug was NOT reproduced.
3. Enable auto-attach on satellite webUI, and disable it on client: The bug was reproduced.

Comment 11 qianzhan 2016-09-29 08:02:24 UTC
This bug still exists on RHEL-7.3-Server-PPC64-Snapshot-5.0 against Satellite-6.2.0-RHEL-7-20160907.6, but not on RHEL-7.3-Server-PPC64le-Snapshot-5.0

Comment 12 qianzhan 2016-10-14 09:05:13 UTC
This bug still exists on RHEL-7.3-Server-s390x-RC-2.0 against Satellite-6.2.0-RHEL-7-20160907.6.

Comment 13 Kevin Howell 2016-12-16 15:44:14 UTC
There is no straightforward solution for this until bug 1405480 is implemented.

Comment 14 Barnaby Court 2017-01-19 15:42:06 UTC
*** Bug 1413829 has been marked as a duplicate of this bug. ***

Comment 15 qianzhan 2017-02-22 09:40:47 UTC
This bug can be reproduced on RHEL-6.9-20170215.0 against Satellite-6.2

Comment 16 qianzhan 2017-04-12 07:40:34 UTC
This bug can be reproduced on RHEL-7.4-20170330.1 against Satellite-6.2.9, when auto-attach subscription 'CloudForms (10-pack)'(SKU:MCT2358, service-level: Premium).

Comment 17 Kevin Howell 2017-05-03 14:13:26 UTC
Un-assigning for now.

Comment 19 qianzhan 2017-08-29 06:46:49 UTC
Verifying version:

Satellite6.2.12
subscription-manager: 1.19.21-1.el7
python-rhsm: 1.19.9-1.el7

1. Install RHEL-7.4-20170808.1-Server-x86_64, RHEL-7.4-20170808.1-Server-ppc64le, and RHEL-7.4-20170808.1-Server-s390x.

2. On the above systems, open subscription-manager-gui and register with auto-attach. There are no error windows prompting, and the auto-attachs are successful.

Moving to VERIFIED.

Comment 22 errata-xmlrpc 2018-04-10 09:47:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.