Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367603 - dnf install paraview missing libmpi.so.1
Summary: dnf install paraview missing libmpi.so.1
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: paraview
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 23:34 UTC by Mark Dwyer
Modified: 2016-08-18 23:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-18 23:02:11 UTC


Attachments (Terms of Use)

Description Mark Dwyer 2016-08-16 23:34:59 UTC
Description of problem:
Does not install a openmpi-devel dependency

paraview: error while loading shared libraries: libmpi.so.1: cannot open shared object file: No such file or directory

Version-Release number of selected component (if applicable):
$ dnf info paraview
Last metadata expiration check: 0:00:06 ago on Wed Aug 17 09:29:13 2016.
Installed Packages
Name        : paraview
Arch        : x86_64
Epoch       : 0
Version     : 5.1.0
Release     : 1.fc24
Size        : 139 M
Repo        : @System
From repo   : updates
Summary     : Parallel visualization application
URL         : http://www.paraview.org/
License     : BSD

$ uname -a
Linux hostname 4.6.6-300.fc24.x86_64 #1 SMP Wed Aug 10 21:07:35 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
Install paraview on a fresh system


Steps to Reproduce:
1. dnf install paraview
2. run paraview from commandline
3. 

Actual results:
$ paraview
paraview: error while loading shared libraries: libmpi.so.1: cannot open shared object file: No such file or directory


Expected results:
Launch program

Additional info:
Easy fix (but a hack nonetheless)
dnf install openmpi-devel
ln -s /usr/lib64/openmpi/lib/libmpi.so /usr/lib64/openmpi/lib/libmpi.so.1

Comment 1 Orion Poplawski 2016-08-18 21:38:18 UTC
I can't reproduce.  What's the output of:

which paraview
rpm -qa paraview\*
rpm -Va paraview\*

Comment 2 Mark Dwyer 2016-08-18 23:02:11 UTC
$ which paraview
~/Tools/bin/paraview

Well, that's embarrassing.  A previously compiled one in a restore.

Removed and /usr/bin/paraview works fine.

Sorry for your time.


Note You need to log in before you can comment on or make changes to this bug.