Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1367593 - [DOCS] Disconnected Install need certain images to always live on the hosts, or in a external registry without auth. [NEEDINFO]
Summary: [DOCS] Disconnected Install need certain images to always live on the hosts, ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Vikram Goyal
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 21:37 UTC by Ryan Howe
Modified: 2018-04-24 15:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-24 15:36:28 UTC
erich: needinfo? (rhowe)


Attachments (Terms of Use)

Description Ryan Howe 2016-08-16 21:37:03 UTC
Document URL: 

   https://docs.openshift.com/enterprise/3.2/install_config/install/disconnected_install.html#disconnected-importing-containerized-components

Section Number and Name: 

  disconnected-importing-containerized-components

Describe the issue: 

  We need to outline that for a disconnected install these images must live of every node with the correct tags. 

   registry.access.redhat.com/openshift3/ose-haproxy-router 
    registry.access.redhat.com/openshift3/ose-deployer 
    registry.access.redhat.com/openshift3/ose-sti-builder 
    registry.access.redhat.com/openshift3/ose-docker-builder 
    registry.access.redhat.com/openshift3/ose-pod 
    registry.access.redhat.com/openshift3/ose-docker-registry



If pushed to another registry they must be located in the openshift3 directory and tagged correctly. 

To change the internal component pull format the following needs to be changed on all nodes and masters-confg.yaml files

  imageConfig:
    format: openshift3/ose-${component}:${version}
    latest: false


Lastly the internal registry can not be used as far as I can tell to pull these images. So one must either have these image located on all nodes at all times or configure another registry to serve these to the cluster.


Note You need to log in before you can comment on or make changes to this bug.